7.7 Проблема с обработкой "Груповая обработка документов"

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем kavak, 20 май 2010.

  1. TopicStarter Overlay
    kavak
    Offline

    kavak Опытный в 1С

    Регистрация:
    13 май 2010
    Сообщения:
    703
    Симпатии:
    0
    Баллы:
    26
    Вот код обработки самой,а в прикрепленном файле сам глобальный модуль.Я пришел в фирму недавно предыдущие программисты тут его наворотили до сих пор плюхаюсь,тем более что 1С 7 плохо знаю.Подскажите в чем ошибка?С технической стороны с принтером порядок.Одиночные документы печатает.Знаю что именно с комплектами документов очень много было изменений.Заранее спасибо.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Нет прикрепленных данных..
  3. TopicStarter Overlay
    kavak
    Offline

    kavak Опытный в 1С

    Регистрация:
    13 май 2010
    Сообщения:
    703
    Симпатии:
    0
    Баллы:
    26
    код обработки:
    Код:
    <pre><FONT COLOR="blue"><FONT FACE="Courier">
    [color=green]////////////////////////////////////////////////////////////////////////////////[/color]
    [color=green]// ПЕРЕМЕННЫЕ МОДУЛЯ[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> Документы[color=red];[/color]		    [color=green]// список значений с идентификаторами видов документов системы[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> ОтобранныеДокументы[color=red];[/color]	[color=green]// список отобранных документов        [/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> МеткаЕсть[color=red],[/color] МеткиНет[color=red];[/color]  [color=green]// Номера иконок пометки строки таблицы[/color]
    
    [color=green]////////////////////////////////////////////////////////////////////////////////[/color]
    [color=green]// ПРОЦЕДУРЫ И ФУНКЦИИ МОДУЛЯ[/color]
    [color=green]//[/color]
    [color=green]//******************************************************************************[/color]
    [color=green]// УправлениеДиалогом()[/color]
    [color=green]//[/color]
    [color=green]// Параметры: [/color]
    [color=green]//	Нет[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение: [/color]
    [color=green]//	Нет[/color]
    [color=green]//[/color]
    [color=green]// Описание: [/color]
    [color=green]//	Управление доступностью элементов диалога.[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> УправлениеДиалогом[color=red]([/color][color=red])[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ВариантДействия [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Форма[color=red].[/color]СпособПечати[color=red].[/color]Доступность[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    Форма[color=red].[/color]СпособПечати[color=red].[/color]Доступность[color=red]([/color][color=black]0[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ВариантДействия [color=red]=[/color] [color=black]2[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Форма[color=red].[/color]ПометкаУдаления[color=red].[/color]Доступность[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    Форма[color=red].[/color]ПометкаУдаления[color=red].[/color]Доступность[color=red]([/color][color=black]0[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ВариантДействия [color=red]=[/color] [color=black]4[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Форма[color=red].[/color]Проект[color=red].[/color]Доступность[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    Форма[color=red].[/color]Проект[color=red].[/color]Доступность[color=red]([/color][color=black]0[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]//УправлениеДиалогом()   [/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// ГрупповаяПометка(Режим)[/color]
    [color=green]//[/color]
    [color=green]// Параметры: [/color]
    [color=green]//  Режим:[/color]
    [color=green]//   1 - пометить все[/color]
    [color=green]//   2 - снять пометку[/color]
    [color=green]//   3 - инвертировать пометку[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Вызывается из формул элементов диалога[/color]
    [color=green]// кнопки групповой пометки[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//  Производит групповые действия с пометкой строк таблицы формы[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ГрупповаяПометка[color=red]([/color]Режим[color=red])[/color]
    
    ТаблицаДокументов[color=red].[/color]ВыбратьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">	Пока</span> ТаблицаДокументов[color=red].[/color]ПолучитьСтроку[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Режим[color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>              
    
    ТаблицаДокументов[color=red].[/color]Пометка [color=red]=[/color] МеткаЕсть[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">		ИначеЕсли</span> Режим[color=red]=[/color][color=black]2[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    
    ТаблицаДокументов[color=red].[/color]Пометка [color=red]=[/color] МеткиНет[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">		ИначеЕсли</span> Режим[color=red]=[/color][color=black]3[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">			Если</span> ТаблицаДокументов[color=red].[/color]Пометка[color=red]=[/color]МеткиНет <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТаблицаДокументов[color=red].[/color]Пометка [color=red]=[/color] МеткаЕсть[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">			Иначе</span>
    ТаблицаДокументов[color=red].[/color]Пометка [color=red]=[/color] МеткиНет[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">			КонецЕсли</span>[color=red];[/color]                           
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">	КонецЦикла</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// ГрупповаяПометка()         [/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// ПерезаполнитьСтрокуТаблицы(НомерСтроки)[/color]
    [color=green]//[/color]
    [color=green]// Параметры: [/color]
    [color=green]//  НомерСтроки - номер строки таблица, чьи колонки надо перезаполнить[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//  Заполняет значения ячеек для строки с переданным номером[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПерезаполнитьСтрокуТаблицы[color=red]([/color]НомерСтроки[color=red])[/color]
    
    Док			[color=red]=[/color] ТаблицаДокументов[color=red].[/color]ПолучитьЗначение[color=red]([/color]НомерСтроки[color=red],[/color] [color=black]"Документ"[/color][color=red])[/color][color=red];[/color]
    СтрСумма	[color=red]=[/color] глСуммаДокументаВЖурнале[color=red]([/color]Док[color=red])[/color][color=red];[/color]
    СтрВалюта	[color=red]=[/color] СокрЛП[color=red]([/color]глВалютаДокументаВЖурнале[color=red]([/color]Док[color=red])[/color][color=red])[/color][color=red];[/color]
    
    СтрКонтрагент [color=red]=[/color] [color=black]""[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> глЕстьРеквизитШапки[color=red]([/color][color=black]"Контрагент"[/color][color=red],[/color]Док[color=red].[/color]Вид[color=red]([/color][color=red])[/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Док[color=red].[/color]Контрагент[color=red].[/color]Выбран[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СтрКонтрагент [color=red]=[/color] [color=black]" Контрагент: "[/color][color=red]+[/color]СокрЛП[color=red]([/color]Док[color=red].[/color]Контрагент[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    СтрДоговор[color=red]=[/color][color=black]""[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> глЕстьРеквизитШапки[color=red]([/color][color=black]"Договор"[/color][color=red],[/color]Док[color=red].[/color]Вид[color=red]([/color][color=red])[/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Док[color=red].[/color]Договор[color=red].[/color]Выбран[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СтрДоговор [color=red]=[/color] [color=black]" Договор: "[/color][color=red]+[/color]СокрЛП[color=red]([/color]Док[color=red].[/color]Договор[color=red])[/color][color=red]+[/color][color=black]". "[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]	
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    СтрИнформация [color=red]=[/color] СтрКонтрагент [color=red]+[/color] СтрДоговор[color=red];[/color]
    
    СтрСтатус [color=red]=[/color] [color=black]""[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> [color=red]([/color]Док[color=red].[/color]ПометкаУдаления[color=red]([/color][color=red])[/color][color=red]>[/color][color=black]0[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СтрСтатус [color=red]=[/color] [color=black]"Помечен на уд."[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">	ИначеЕсли</span> [color=red]([/color]Док[color=red].[/color]Проведен[color=red]([/color][color=red])[/color][color=red]>[/color][color=black]0[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СтрСтатус [color=red]=[/color] [color=black]"Проведен"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]	       
    
    СтрДокумент [color=red]=[/color] глНазваниеДокументаВЖурнале[color=red]([/color]Док[color=red])[/color][color=red];[/color]
    
    ТаблицаДокументов[color=red].[/color]УстановитьЗначение[color=red]([/color]НомерСтроки[color=red],[/color] [color=black]"Дата"[/color][color=red],[/color]       Док[color=red].[/color]ДатаДок[color=red])[/color][color=red];[/color]
    ТаблицаДокументов[color=red].[/color]УстановитьЗначение[color=red]([/color]НомерСтроки[color=red],[/color] [color=black]"СтрДокумент"[/color][color=red],[/color]СтрДокумент[color=red])[/color][color=red];[/color]
    ТаблицаДокументов[color=red].[/color]УстановитьЗначение[color=red]([/color]НомерСтроки[color=red],[/color] [color=black]"Номер"[/color][color=red],[/color]      Док[color=red].[/color]НомерДок[color=red])[/color][color=red];[/color]
    ТаблицаДокументов[color=red].[/color]УстановитьЗначение[color=red]([/color]НомерСтроки[color=red],[/color] [color=black]"Автор"[/color][color=red],[/color]      СокрЛП[color=red]([/color]Док[color=red].[/color]Автор[color=red])[/color][color=red])[/color][color=red];[/color]
    ТаблицаДокументов[color=red].[/color]УстановитьЗначение[color=red]([/color]НомерСтроки[color=red],[/color] [color=black]"Статус"[/color][color=red],[/color]     СтрСтатус[color=red])[/color][color=red];[/color]
    ТаблицаДокументов[color=red].[/color]УстановитьЗначение[color=red]([/color]НомерСтроки[color=red],[/color] [color=black]"Сумма"[/color][color=red],[/color]      СтрСумма[color=red])[/color][color=red];[/color]         
    ТаблицаДокументов[color=red].[/color]УстановитьЗначение[color=red]([/color]НомерСтроки[color=red],[/color] [color=black]"Валюта"[/color][color=red],[/color]     СтрВалюта[color=red])[/color][color=red];[/color] 
    ТаблицаДокументов[color=red].[/color]УстановитьЗначение[color=red]([/color]НомерСтроки[color=red],[/color] [color=black]"Проект"[/color][color=red],[/color]     СокрЛП[color=red]([/color]Док[color=red].[/color]Проект[color=red])[/color][color=red])[/color][color=red];[/color] 
    ТаблицаДокументов[color=red].[/color]УстановитьЗначение[color=red]([/color]НомерСтроки[color=red],[/color] [color=black]"Информация"[/color][color=red],[/color] СтрИнформация[color=red])[/color][color=red];[/color] 
    ТаблицаДокументов[color=red].[/color]УстановитьЗначение[color=red]([/color]НомерСтроки[color=red],[/color] [color=black]"Комментарий"[/color][color=red],[/color]Док[color=red].[/color]Комментарий[color=red])[/color][color=red];[/color] 
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// ПерезаполнитьСтрокуТаблицы()[/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// ПриДвойномЩелчкеНаТаблице()[/color]
    [color=green]//[/color]
    [color=green]// Параметры: [/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Вызывается из формул элементов диалога[/color]
    [color=green]//  Таблица значений ТаблицаДокументов[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//  Обрабатывает двойной щелчок (нажатие клавиши "Enter") на таблице формы[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПриДвойномЩелчкеНаТаблице[color=red]([/color][color=red])[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> ТекКол[color=red],[/color] ТекСтр[color=red];[/color]
    
    ТаблицаДокументов[color=red].[/color]ТекущаяКолонка[color=red]([/color][color=red],[/color]ТекКол[color=red])[/color][color=red];[/color]
    ТекСтр [color=red]=[/color] ТаблицаДокументов[color=red].[/color]ТекущаяСтрока[color=red]([/color][color=red])[/color][color=red];[/color]
    КодТекКол [color=red]=[/color] ТаблицаДокументов[color=red].[/color]ПолучитьПараметрыКолонки[color=red]([/color]ТекКол[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ТекСтр [color=red]>[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> КодТекКол [color=red]=[/color] [color=black]"Пометка"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">			Если</span> ТаблицаДокументов[color=red].[/color]Пометка [color=red]=[/color] МеткаЕсть <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТаблицаДокументов[color=red].[/color]Пометка [color=red]=[/color] МеткиНет[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">			Иначе</span>
    ТаблицаДокументов[color=red].[/color]Пометка [color=red]=[/color] МеткаЕсть[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">			КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">		Иначе</span>
    
    ОткрытьФормуМодально[color=red]([/color]ТаблицаДокументов[color=red].[/color]Документ[color=red])[/color][color=red];[/color]
    ПерезаполнитьСтрокуТаблицы[color=red]([/color]ТекСтр[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// ПриДвойномЩелчкеНаТаблице()[/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// ПоКнопкеВыполнить()[/color]
    [color=green]//[/color]
    [color=green]// Параметры: [/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Вызывается из формул элементов диалога[/color]
    [color=green]//  По кнопке выполнить[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//  Производит выбранное действия с выбранными позициями номенклатуры[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПоКнопкеВыполнить[color=red]([/color][color=red])[/color]
    
    [color=green]// Проверим, все ли задано[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ВариантДействия [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span> [color=green]// Печать[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> СпособПечати[color=red].[/color]ТекущаяСтрока[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/предупреждение')">			Предупреждение</span>[color=red]([/color][color=black]"Не выбран способ печати."[/color][color=red],[/color][color=black]60[/color][color=red])[/color][color=red];[/color]
    Активизировать[color=red]([/color][color=black]"СпособПечати"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">			Возврат</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">	ИначеЕсли</span> ВариантДействия [color=red]=[/color] [color=black]2[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span> [color=green]// Пометка на удаление[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ПометкаУдаления[color=red].[/color]ТекущаяСтрока[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/предупреждение')">			Предупреждение</span>[color=red]([/color][color=black]"Не выбрано действие с пометкой на удаление."[/color][color=red],[/color][color=black]60[/color][color=red])[/color][color=red];[/color]
    Активизировать[color=red]([/color][color=black]"ПометкаУдаления"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">			Возврат</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">	ИначеЕсли</span> ВариантДействия [color=red]=[/color] [color=black]4[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span> [color=green]// Отнести к проекту[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ПустоеЗначение[color=red]([/color]Проект[color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/предупреждение')">			Предупреждение</span>[color=red]([/color][color=black]"Не выбрано проект, к которому надо отнести документы."[/color][color=red],[/color][color=black]60[/color][color=red])[/color][color=red];[/color]
    Активизировать[color=red]([/color][color=black]"Проект"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">			Возврат</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]	
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/попытка')">	Попытка</span>
    НачатьТранзакцию[color=red]([/color][color=red])[/color][color=red];[/color]
    
    Док [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"Документ"[/color][color=red])[/color][color=red];[/color]
    ЖурналРасчетовЗарплата [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"ЖурналРасчетов.Зарплата"[/color][color=red])[/color][color=red];[/color]
    ТаблицаДокументов[color=red].[/color]ВыбратьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">		Пока</span> ТаблицаДокументов[color=red].[/color]ПолучитьСтроку[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    
    ТекСтрока [color=red]=[/color] ТаблицаДокументов[color=red].[/color]НомерСтроки[color=red];[/color] 
    
    [color=green]// Не помечен к обработке[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">			Если</span> ТаблицаДокументов[color=red].[/color]Пометка [color=red]=[/color] МеткиНет <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/продолжить')">				Продолжить</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">			КонецЕсли</span>[color=red];[/color]	
    
    [color=green]// не оказалось документа[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">			Если</span> Док[color=red].[/color]НайтиДокумент[color=red]([/color]ТаблицаДокументов[color=red].[/color]Документ[color=red])[/color] [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/сообщить')">				Сообщить</span>[color=red]([/color][color=black]"Не найден "[/color][color=black]""[/color] [color=red]+[/color] СокрЛП[color=red]([/color]ТаблицаДокументов[color=red].[/color]Документ[color=red])[/color] [color=red]+[/color] [color=black]""[/color][color=black]"! Действие не выполнено!"[/color][color=red],[/color][color=black]"!"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/продолжить')">				Продолжить</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">			КонецЕсли</span>[color=red];[/color]	
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/сообщить')">			Сообщить</span>[color=red]([/color][color=black]"Выполняется обработка позиции "[/color][color=red]+[/color]СокрЛП[color=red]([/color]Док[color=red].[/color]ТекущийДокумент[color=red]([/color][color=red])[/color][color=red])[/color][color=red],[/color][color=black]"."[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">			Если</span> ВариантДействия [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>  [color=green]// Напечатать[/color]
    
    глПечатьДокумента[color=red]([/color]Док[color=red].[/color]ТекущийДокумент[color=red]([/color][color=red])[/color][color=red],[/color] СпособПечати[color=red].[/color]ПолучитьЗначение[color=red]([/color]СпособПечати[color=red].[/color]ТекущаяСтрока[color=red]([/color][color=red])[/color][color=red])[/color][color=red])[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">			ИначеЕсли</span> ВариантДействия [color=red]=[/color] [color=black]2[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>  [color=green]// Пометка на удаление	[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">				Если</span> ПометкаУдаления[color=red].[/color]ТекущаяСтрока[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">					Если</span> Док[color=red].[/color]ТекущийДокумент[color=red]([/color][color=red])[/color][color=red].[/color]Вид[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]"НачислениеЗаработнойПлаты"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">						Если</span> Док[color=red].[/color]ТекущийДокумент[color=red]([/color][color=red])[/color][color=red].[/color]ДатаДок [color=red]<[/color] ЖурналРасчетовЗарплата[color=red].[/color]НачалоТекущегоПериода[color=red]([/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/сообщить')">							Сообщить</span>[color=red]([/color][color=black]"Документ находится в прошлом периоде журнала расчетов зарплаты. Пометить его на удаление нельзя."[/color][color=red],[/color] [color=black]"!"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/продолжить')">							Продолжить</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">						КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">					КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">					Если</span> глПриУдаленииДокумента[color=red]([/color]Док[color=red],[/color] [color=black]0[/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span> [color=green]// можно удалять[/color]
    Док[color=red].[/color]Удалить[color=red]([/color][color=black]0[/color][color=red])[/color][color=red];[/color]                              
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">					КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">				Иначе</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">					Если</span> глПриУдаленииДокумента[color=red]([/color]Док[color=red],[/color] [color=black]0[/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span> 
    Док[color=red].[/color]СнятьПометкуУдаления[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">					КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">				КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">			ИначеЕсли</span> ВариантДействия [color=red]=[/color] [color=black]3[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>  [color=green]// Сделать не проведенным[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">				Если</span> Док[color=red].[/color]Проведен[color=red]([/color][color=red])[/color] [color=red]>[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/попытка')">					Попытка</span>     
    
    [color=green]// Проверка даты запрета редактирования[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">						Если</span> Док[color=red].[/color]ДатаДок[color=red]<[/color][color=red]=[/color]Константа[color=red].[/color]ДатаЗапретаРедактирования <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/сообщить')">							Сообщить</span>[color=red]([/color][color=black]"Нельзя отменять проведение документов с датой, более ранней чем дата запрета редактирования документов!"[/color][color=red],[/color][color=black]"!"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">						Иначе</span>
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">							Если</span> Док[color=red].[/color]ТекущийДокумент[color=red]([/color][color=red])[/color][color=red].[/color]Вид[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]"НачислениеЗаработнойПлаты"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">								Если</span> Док[color=red].[/color]ТекущийДокумент[color=red]([/color][color=red])[/color][color=red].[/color]ДатаДок [color=red]<[/color] ЖурналРасчетовЗарплата[color=red].[/color]НачалоТекущегоПериода[color=red]([/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/сообщить')">									Сообщить</span>[color=red]([/color][color=black]"Документ находится в прошлом периоде журнала расчетов зарплаты. Пометить его на удаление нельзя."[/color][color=red],[/color] [color=black]"!"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/продолжить')">									Продолжить</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">								КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">							КонецЕсли</span>[color=red];[/color]
    
    Док[color=red].[/color]СделатьНеПроведенным[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">						КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/исключение')">					Исключение	</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/сообщить')">						Сообщить</span>[color=red]([/color][color=black]"Не удалось отменить проведение документа "[/color][color=red]+[/color]Строка[color=red]([/color]Док[color=red].[/color]ТекущийДокумент[color=red]([/color][color=red])[/color][color=red])[/color][color=red],[/color][color=black]"!"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпопытки')">					КонецПопытки</span>[color=red];[/color]  
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">				КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">			ИначеЕсли</span> ВариантДействия [color=red]=[/color] [color=black]4[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>  [color=green]// Отнести к проекту[/color]
    Док[color=red].[/color]Проект [color=red]=[/color] Проект[color=red];[/color]
    Док[color=red].[/color]Записать[color=red]([/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">			КонецЕсли</span>[color=red];[/color]
    
    ПерезаполнитьСтрокуТаблицы[color=red]([/color]ТекСтрока[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">		КонецЦикла</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/сообщить')">		Сообщить</span>[color=red]([/color][color=black]"Обработка закончена"[/color][color=red],[/color][color=black]"."[/color][color=red])[/color][color=red];[/color]
    ЗафиксироватьТранзакцию[color=red]([/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/исключение')">	Исключение</span>                          
    ОтменитьТранзакцию[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/сообщить')">		Сообщить</span>[color=red]([/color]ОписаниеОшибки[color=red]([/color][color=red])[/color][color=red],[/color] [color=black]"!"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпопытки')">	КонецПопытки</span>[color=red];[/color]
    
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// ПоКнопкеВыполнить() [/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// ПоКнопкеПечать()[/color]
    [color=green]//[/color]
    [color=green]// Параметры: [/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Вызывается из формул элементов диалога[/color]
    [color=green]//  по кнопке "Печать"[/color]
    [color=green]// [/color]
    [color=green]// Описание:[/color]
    [color=green]//  Выводит отобранные документы в таблицу MXL[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПоКнопкеПечать[color=red]([/color][color=red])[/color]
    
    Таб [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"Таблица"[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ИсходнаяТаблица[color=red]([/color] [color=black]"РеестрДокументов"[/color] [color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Отчет"[/color][color=red])[/color][color=red];[/color]
    глОживить[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    
    СуммыПоВалютам [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"ТаблицаЗначений"[/color][color=red])[/color][color=red];[/color]
    СуммыПоВалютам[color=red].[/color]НоваяКолонка[color=red]([/color][color=black]"Валюта"[/color]	[color=red],[/color] [color=black]"Строка"[/color][color=red])[/color][color=red];[/color]
    СуммыПоВалютам[color=red].[/color]НоваяКолонка[color=red]([/color][color=black]"Сумма"[/color]		[color=red],[/color] [color=black]"Число"[/color][color=red])[/color][color=red];[/color]
    
    НПП[color=red]=[/color][color=black]0[/color][color=red];[/color]             
    ТаблицаДокументов[color=red].[/color]ВыбратьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">	Пока</span> ТаблицаДокументов[color=red].[/color]ПолучитьСтроку[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ТаблицаДокументов[color=red].[/color]Пометка [color=red]=[/color] МеткиНет <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/продолжить')">Продолжить</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    НПП[color=red]=[/color]НПП[color=red]+[/color][color=black]1[/color][color=red];[/color]
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Докум"[/color][color=red])[/color][color=red];[/color]
    глОживить[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ПустоеЗначение[color=red]([/color]ТаблицаДокументов[color=red].[/color]Валюта[color=red])[/color] [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТекСумма [color=red]=[/color] Число[color=red]([/color]СтрЗаменить[color=red]([/color]ТаблицаДокументов[color=red].[/color]Сумма[color=red],[/color] [color=black]"'"[/color][color=red],[/color] [color=black]""[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    
    Поз	[color=red]=[/color] [color=black]0[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">			Если</span> СуммыПоВалютам[color=red].[/color]НайтиЗначение[color=red]([/color]ТаблицаДокументов[color=red].[/color]Валюта[color=red],[/color] Поз[color=red],[/color] [color=black]"Валюта"[/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СуммыПоВалютам[color=red].[/color]ПолучитьСтрокуПоНомеру[color=red]([/color]Поз[color=red])[/color][color=red];[/color]
    СуммыПоВалютам[color=red].[/color]Сумма [color=red]=[/color] СуммыПоВалютам[color=red].[/color]Сумма [color=red]+[/color] ТекСумма[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">			Иначе</span>
    СуммыПоВалютам[color=red].[/color]НоваяСтрока[color=red]([/color][color=red])[/color][color=red];[/color]
    СуммыПоВалютам[color=red].[/color]Сумма	[color=red]=[/color] ТекСумма[color=red];[/color]
    СуммыПоВалютам[color=red].[/color]Валюта	[color=red]=[/color] ТаблицаДокументов[color=red].[/color]Валюта[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">			КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">	КонецЦикла</span>[color=red];[/color]
    
    КолвоСтрок	[color=red]=[/color] СуммыПоВалютам[color=red].[/color]КоличествоСтрок[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> КолвоСтрок [color=red]>[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СуммыПоВалютам[color=red].[/color]ПолучитьСтрокуПоНомеру[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"ИтогоСнадписью"[/color][color=red])[/color][color=red];[/color]
    глОживить[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/для')">		Для</span> Сч [color=red]=[/color] [color=black]2[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/по')">По</span> КолвоСтрок <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    СуммыПоВалютам[color=red].[/color]ПолучитьСтрокуПоНомеру[color=red]([/color]Сч[color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Итого"[/color][color=red])[/color][color=red];[/color]
    глОживить[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">		КонецЦикла</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    Таб[color=red].[/color]Опции[color=red]([/color][color=black]0[/color][color=red],[/color] [color=black]0[/color][color=red],[/color] [color=black]5[/color][color=red],[/color] [color=black]0[/color][color=red],[/color] [color=black]"РеестрДокументов"[/color][color=red],[/color] [color=black]"РеестрДокументов"[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ТолькоПросмотр[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]Показать[color=red]([/color][color=black]"Реестр документов"[/color][color=red],[/color][color=black]""[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// ПоКнопкеПечать()[/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// ПоКнопкеСформировать()[/color]
    [color=green]//[/color]
    [color=green]// Параметры: [/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Вызывается из формул элементов диалога[/color]
    [color=green]//  По кнопке "Сформировать"[/color]
    [color=green]// [/color]
    [color=green]// Описание:[/color]
    [color=green]//  Отбирает необходимые ТМЦ и открывает слой обработки "Обработка"[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПоКнопкеСформировать[color=red]([/color][color=red])[/color]
    
    [color=green]// Формируем таблицу номенклатуры[/color]
    ТаблицаДокументов[color=red].[/color]Очистить[color=red]([/color][color=red])[/color][color=red];[/color]
    ТаблицаДокументов[color=red].[/color]НоваяКолонка[color=red]([/color][color=black]"Пометка"[/color][color=red],[/color]    [color=black]"Число"[/color]   [color=red],[/color][color=black]1[/color][color=red],[/color][color=red],[/color]             [color=red],[/color]     [color=black]4[/color]    [color=red])[/color][color=red];[/color]
    ТаблицаДокументов[color=red].[/color]НоваяКолонка[color=red]([/color][color=black]"Документ"[/color][color=red],[/color]   [color=black]"Документ"[/color][color=red],[/color] [color=red],[/color][color=red],[/color]             [color=red],[/color]          [color=red])[/color][color=red];[/color] 
    ТаблицаДокументов[color=red].[/color]НоваяКолонка[color=red]([/color][color=black]"Дата"[/color][color=red],[/color]       [color=black]"Дата"[/color]    [color=red],[/color] [color=red],[/color][color=red],[/color][color=black]"Дата"[/color]       [color=red],[/color]     [color=black]10[/color][color=red],[/color][color=red],[/color][color=black]2[/color][color=red])[/color][color=red];[/color]
    ТаблицаДокументов[color=red].[/color]НоваяКолонка[color=red]([/color][color=black]"СтрДокумент"[/color][color=red],[/color]<span style='color:black'>"Стр

Поделиться этой страницей