8.х БП Проблема с Клиент-Банком

Тема в разделе ""1С:Бухгалтерия БП"", создана пользователем Ольгусик, 3 ноя 2010.

  1. TopicStarter Overlay
    Ольгусик
    Offline

    Ольгусик Опытный в 1С Команда форума

    Регистрация:
    4 фев 2010
    Сообщения:
    646
    Симпатии:
    3
    Баллы:
    29
    Часть платежных поручений загружается из клиент-банка, часть вводится вручную. С нумерацией что-то не то творится. Иногда при загрузке выдаются ошибки, что не созданы документы. Проблема в том, что при загрузке делается попытка создать документы с номерами, которые уже есть. Причем как раз те, которые были введены вручную.
  2. kogor
    Offline

    kogor Опытный в 1С

    Регистрация:
    5 фев 2010
    Сообщения:
    412
    Симпатии:
    0
    Баллы:
    26
    Тоже столкнулся с такой проблемой.

    При загрузке из клиент-банка в БП 1.6.25.6 платежные поручения (исходящие) не записываются (вообще не появляются в журнале Банковские расчетные документы):

    После некоторых экспериментов оказалось, что не записываются только те документы, номера которых уже есть в базе.

    Были ли эти номера набраны вручную, сказать сейчас сложно.

    Но если вручную их заменить на какие-либо другие, то из клиент-банка документы загружаются и получают их старые номера.

    Кто-нибудь еще сталкивался с этой проблемой? Может быть она решена в последних релизах БП?
  3. roslakov
    Offline

    roslakov

    Регистрация:
    27 дек 2010
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Только что установили клиент-банк, система ДБО BS-клиент. В БП 1.6.27.1 созданы ППИ за 23.12.10. При попытке загрузить их из программы клиент банка система выдает сообщение: "Документ "Исходящее платежное поручение" № 00000000618 от 23.12.2010 0:00:00 не создан! Произошли ошибки при записи!"

    Документ "Исходящее платежное поручение" № 00000000618 от 23.12.2010 0:00:00: помечен на удаление.



    Это происходит в случае когда ППИ записаны в базе. Если же их провести в ручную и попробовать выполнить загрузку из КБ, то их проведение отменяется и они перезаписываются. Если же изменить их номера и выполнить загрузку, то создаются новые документы и проводятся.



    Подскажите что делаем не правильно.
  4. Наташа
    Offline

    Наташа Опытный в 1С

    Регистрация:
    14 авг 2010
    Сообщения:
    1.442
    Симпатии:
    2
    Баллы:
    29
    Всё верно - для документов стоит контроль уникальности номеров, соответственно две платежки с одним номером быть не может, и если в базе номер занят, то клиент-банк платежку создать не может. Нужно определиться - руками вы их создаете или всё таки загружаете, иначе пересечения по номерам так и будут продолжаться.
  5. r-d-v2008
    Offline

    r-d-v2008 Опытный в 1С

    Регистрация:
    16 сен 2010
    Сообщения:
    272
    Симпатии:
    0
    Баллы:
    26
    Какие ошибки произошли при записи?
    1. Сделайте тестирование и исправление в базе
    2. Да действительно определитесь уже как вы будете вводить вручную или автоматически,если автоматически нумерацию не создает тогда у документа на вкладке нумерация поменяйте если стоит строка то меняйте на число, если число меняйте на строку тогда будет создаваться автоматически
    Пока все как скажите какие ошибки возникают так дальше будем действовать
  6. sergsaminovka
    Offline

    sergsaminovka

    Регистрация:
    2 фев 2011
    Сообщения:
    2
    Симпатии:
    1
    Баллы:
    1
    За Комментировать в обработке Загрузка клиент-банка.

    Код:
    Процедура ЗаполнитьРеквизитПлатежногоПорученияИсходящего(ОбъектДокумента, ИсходныеДанные)
    //Организация, ДАТА, НОМЕР
    УстановитьСвойство(ОбъектДокумента, "Организация", Организация);
    УстановитьСвойство(ОбъектДокумента, "Дата", ИсходныеДанные.ДатаДок);
    Если ЗначениеЗаполнено(ИсходныеДанные.Списано) Тогда
    УстановитьСвойство(ОбъектДокумента, "Оплачено", Истина);
    УстановитьСвойство(ОбъектДокумента, "ДатаОплаты",НачалоДня(ИсходныеДанные.Списано), истина);
    КонецЕсли;
    Если ОбъектДокумента.ЭтоНовый() Тогда
    ОбъектДокумента.УстановитьНовыйНомер(Организация.Префикс);
    //Если Не ОбщегоНазначения.ЕстьНеЦифры(ИсходныеДанные.Номер) Тогда
    // ОкончаниеНомера = Формат(Число(СокрЛП(ИсходныеДанные.Номер)), "ЧН=; ЧГ=0");
    // ДлинаОкончания = СтрДлина(ОкончаниеНомера);
    // ДлинаНомера = СтрДлина(СокрЛП(ОбъектДокумента.Номер));
    // Если ДлинаОкончания < 3 Тогда
    // ДлинаОкончания = 3;
    // КонецЕсли;
    //
    // ОбъектДокумента.Номер = Лев(ОбъектДокумента.Номер, ДлинаНомера - ДлинаОкончания) + Формат(Число(ОкончаниеНомера), "ЧЦ=" + ДлинаОкончания + "; ЧВН=; ЧГ=0");
    //
    //КонецЕсли;
    КонецЕсли;
    Sorkin нравится это.
  7. YuliyaDen
    Offline

    YuliyaDen

    Регистрация:
    29 авг 2013
    Сообщения:
    46
    Симпатии:
    0
    Баллы:
    1
    В этом случае уникальность будет контролироваться не только по 3 последним цифрам, а по всему Префиксу, верно?

Поделиться этой страницей