7.7 Проблема с использованием двойного цикла в операциях.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Tolikv, 21 дек 2006.

  1. TopicStarter Overlay
    Tolikv
    Offline

    Tolikv

    Регистрация:
    4 июл 2006
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    Есть следующее:

    Опер.ВыбратьОперацииСПроводками('01.01.1980',ДатаДок,"001");
    Опер2.ВыбратьОперацииСПроводками('01.01.1980',ДатаДок,"001");
    Опер2.ВыбратьПроводки();
    Пока Опер2.ПолучитьПроводку() = 1 Цикл
    Деб = Опер2.Дебет.Субконто();
    Опер.ВыбратьПроводки();
    Пока Опер.ПолучитьПроводку() = 1 Цикл
    Кред = Опер.Кредит.Субконто();
    Если Деб = Кред Тогда
    ПроверкаВыбыл = 1;
    КонецЕсли;
    КонецЦикла;
    КонецЦикла;


    Дак вот, первый цикл проходит нормально, а на втором почемуто выдает ошибку Опер.ВыбратьПроводки(); - Операция не выбрана!
    Почему собсно так происходит?
  2. TopicStarter Overlay
    Tolikv
    Offline

    Tolikv

    Регистрация:
    4 июл 2006
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    Всё, разобрался...
  3. logger
    Offline

    logger Опытный в 1С

    Регистрация:
    11 окт 2006
    Сообщения:
    56
    Симпатии:
    0
    Баллы:
    26
    У тебя опер и опер2 перекрываются ) Написал бы, в чем проблема, чтобы другим помогло!
  4. TopicStarter Overlay
    Tolikv
    Offline

    Tolikv

    Регистрация:
    4 июл 2006
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    Нужно вот так:

    Опер2.ВыбратьОперацииСПроводками('01.01.1980',ДатаДок,"001");
    Пока Опер2.ПолучитьПроводку() = 1 Цикл
    Деб = Опер2.Дебет.Субконто();
    Опер.ВыбратьОперацииСПроводками('01.01.1980',ДатаДок,"001");
    Пока Опер.ПолучитьПроводку() = 1 Цикл
    Кред = Опер.Кредит.Субконто();
    Если Деб = Кред Тогда
    ПроверкаВыбыл = 1;
    КонецЕсли;
    КонецЦикла;
    КонецЦикла;

Поделиться этой страницей