8.х Проблема с ИнтернеПочта

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем SweetProGirl, 30 ноя 2010.

  1. TopicStarter Overlay
    SweetProGirl
    Offline

    SweetProGirl

    Регистрация:
    30 ноя 2010
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Люди помогите плиз!

    В 1С8 (релиз 8.2.12.75) при полученных от админа настройках к почтовому серверу, пытаюсь выполнять обмен между распределенными базами посредством почты.

    Использую компонент ИнтернетПочта. Код примитивный, практически полностью из справки.

    Почта = Новый ИнтернетПочта;
    Профиль = Новый ИнтернетПочтовыйПрофиль;
    Профиль.АдресСервераSMTP = "192.168.**.**";
    Профиль.АдресСервераPOP3 = "192.168.**.**";
    Профиль.ПортSMTP = 25;
    Профиль.ПортPOP3 = 110;
    Профиль.Пользователь = "****";
    Профиль.ПользовательSMTP = "****";
    Профиль.Пароль = "****";
    Профиль.ПарольSMTP = "****";

    Почта.Подключиться(Профиль);

    Заголовки = Почта.ПолучитьЗаголовки();
    Если Заголовки.Количество() = 0 Тогда
    //Текст = "ru=""На сервере нет сообщений!"";"

    // + " en=""There are no messages on the server!""";

    //Предупреждение(НСтр(Текст),,НСтр("ru=""Нет сообщений"";"" en=""No messages"""));

    КонецЕсли;

    Письма = Почта.Выбрать(Ложь);

    Если Письма.Количество() = 0 Тогда
    Сообщить("На сервере сообщений нет.");
    иначе
    Сообщить("Сообщения прочитаны)");
    КонецЕсли;
    Почта.Отключиться();




    Но система ругается на метод Выбрать():

    Начат обмен данными по настройке "основная настройка" (14:46:41).
    Получение почтовых сообщений
    Ошибка при получении почтовых сообщений: Ошибка при вызове метода контекста (Выбрать): Недопустимое значение параметра (параметр номер '1')
    Не найден входящий файл обмена данными.


    Поскажите что делать?
  2. UnNone
    Offline

    UnNone Опытный в 1С

    Регистрация:
    21 мар 2007
    Сообщения:
    148
    Симпатии:
    0
    Баллы:
    26
    Очень желательно программный код оформлять в соответствующем теге.
    А по проблеме: скорее всего причина в том, что у вас нету в почтовом ящике сообщений, а вы все равно пытаетесь получить почту.
    Попробуйте так:
    Код:
       Если Заголовки.Количество() = 0 Тогда
    Сообщить("Нет писем");
    Иначе
    Письма = Почта.Выбрать(Ложь);
    КонецЕсли;
    Почта.Отключиться();
    
  3. TopicStarter Overlay
    SweetProGirl
    Offline

    SweetProGirl

    Регистрация:
    30 ноя 2010
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1


    вопрос не в том, что там писем нет. Я ж сначала на ящик кидаю письма, а потом получаю. А строчку с получением заголовков убрала сознательно, так как заголовки получаются прекрасно, а вот метод выбрать вылетает с ошибкой. Причем, если писем в ящике нет, то метод выбрать отрабатывает хорошо.

Поделиться этой страницей