[РЕШЕНО] Проблема с группировками в СКД

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем NewLife89, 17 дек 2014.

  1. TopicStarter Overlay
    NewLife89
    Offline

    NewLife89 Опытный в 1С

    Регистрация:
    4 дек 2014
    Сообщения:
    63
    Симпатии:
    1
    Баллы:
    29
    И так, есть группировка

    Пример

    Дорога
    Дорога, Станиця, Контрагент.

    Задача вывести общий итог и чтобы первая группировка дорога была внизу. Ставлю в настройках расположение группировки конец и сразу пропадает итог, если же начало и начало и конец, то итог есть. Нужно обязательно чтобы дорога внизу и итог. Уже с ума схожу как сделать...
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.781
    Симпатии:
    509
    Баллы:
    204
    Своим макетом можно сделать.
  3. TopicStarter Overlay
    NewLife89
    Offline

    NewLife89 Опытный в 1С

    Регистрация:
    4 дек 2014
    Сообщения:
    63
    Симпатии:
    1
    Баллы:
    29
    А по другому никак?
  4. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.781
    Симпатии:
    509
    Баллы:
    204
    Поверьте, это самый простой способ. Ну или почитайте Хрусталеву, может в настройках где-то ошибка у вас. Давно с СКД не работал.
  5. TopicStarter Overlay
    NewLife89
    Offline

    NewLife89 Опытный в 1С

    Регистрация:
    4 дек 2014
    Сообщения:
    63
    Симпатии:
    1
    Баллы:
    29
    Попробовал через макет, тоже не получилось.
  6. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.781
    Симпатии:
    509
    Баллы:
    204
    Не верю -Banhappy-
  7. TopicStarter Overlay
    NewLife89
    Offline

    NewLife89 Опытный в 1С

    Регистрация:
    4 дек 2014
    Сообщения:
    63
    Симпатии:
    1
    Баллы:
    29
    Поверьте, как только ставлю у верхней группировки показывать в конце итоги пропадают :(
  8. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.781
    Симпатии:
    509
    Баллы:
    204
    Я имел ввиду про создание своего макета.
  9. TopicStarter Overlay
    NewLife89
    Offline

    NewLife89 Опытный в 1С

    Регистрация:
    4 дек 2014
    Сообщения:
    63
    Симпатии:
    1
    Баллы:
    29
    Я это и имел ввиду. Сделал макет присвоил имена группировкам, но итога так и нет когда ставлю результат группировки конец
  10. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.781
    Симпатии:
    509
    Баллы:
    204
    А в макете есть поля с общими итоговыми именами ?
  11. TopicStarter Overlay
    NewLife89
    Offline

    NewLife89 Опытный в 1С

    Регистрация:
    4 дек 2014
    Сообщения:
    63
    Симпатии:
    1
    Баллы:
    29
  12. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.647
    Симпатии:
    948
    Баллы:
    204
    1. когда пишите про СКД, то пишите платформу. Потоому как в 8.3 есть фишки которые отсутвуют в 8.2
    2. Надо посмотреть что вы делаете, так трудно сказать. просто там еще все может зависеть что является ресурсами, как Вы их расчитываете.
    3. Если говрить уже не смотря то можно либо через офрмление макета, как Вам выше писали. либо если не хочется заморачиваться с этим то вполне можно сделать через вложенную схему.
  13. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.781
    Симпатии:
    509
    Баллы:
    204
    Странно.
  14. TopicStarter Overlay
    NewLife89
    Offline

    NewLife89 Опытный в 1С

    Регистрация:
    4 дек 2014
    Сообщения:
    63
    Симпатии:
    1
    Баллы:
    29
    Задачу решил) Спасибо кто откликнулся.
  15. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.781
    Симпатии:
    509
    Баллы:
    204
    Хотя бы решение написали :)
  16. TopicStarter Overlay
    NewLife89
    Offline

    NewLife89 Опытный в 1С

    Регистрация:
    4 дек 2014
    Сообщения:
    63
    Симпатии:
    1
    Баллы:
    29
    решение оказалось вот таким


    Код:
    Для  к = 2 по Результат.ВысотаТаблицы - Удаленные цикл
            Если Результат.Область(к,3,к,3).Текст = "ДанныеДисл" Тогда
                Результат.Область(к+1,24,к+1,24).Текст =  Результат.Область(к,24,к,24).Текст;
                Результат.Область(к+1,25,к+1,25).Текст =  Результат.Область(к,25,к,25).Текст;
                Результат.Область(к+1,26,к+1,26).Текст =  Результат.Область(к,26,к,26).Текст;
                Удаленные = Удаленные + 1;
            ОбластьУдаления = Результат.Область(к,1,к,26);
                Результат.УдалитьОбласть(ОбластьУдаления, Смещать);
            КонецЕсли;
        КонецЦикла;
     
        Для  к = 2 по Результат.ВысотаТаблицы-Удаленные-1 цикл
            Если Результат.Область(к,1,к,1).Текст = Результат.Область(к+1,1,к+1,1).Текст Тогда
                Верх = к;
                Низ = определяемКОкнечнуюСтроку(к);
                ОбластьОбъединения = Результат.Область(Верх,1,Низ,1);
                ОбластьОбъединения.Объединить();
                к = Низ;
            КонецЕсли;
        КонецЦикла;
     
        Для  к = 2 по Результат.ВысотаТаблицы-Удаленные-1 цикл 
            Если Результат.Область(к,2,к,2).Текст = Результат.Область(к+1,2,к+1,2).Текст Тогда
                Верх = к;
                Низ = определяемКОкнечнуюСтроку2(к);
                ОбластьОбъединения = Результат.Область(Верх,2,Низ,2);
                ОбластьОбъединения.Объединить();
                ОбластьОбъединения = Результат.Область(Верх,24,Низ,24);
                ОбластьОбъединения.Объединить();
                ОбластьОбъединения = Результат.Область(Верх,25,Низ,25);
                ОбластьОбъединения.Объединить();
                ОбластьОбъединения = Результат.Область(Верх,26,Низ,26);
                ОбластьОбъединения.Объединить();
                к = Низ;
            КонецЕсли;
         
        КонецЦикла;
     
    КонецПроцедуры
    Функция определяемКОкнечнуюСтроку(к) Экспорт
        номер = 0;
        Пока Результат.Область(к,1,к,1).Текст = Результат.Область(к+Номер,1,к+Номер,1).Текст Цикл
            Номер = Номер + 1 ;
        КонецЦикла;
        Возврат к+номер-1;
    КонецФункции
    Функция определяемКОкнечнуюСтроку2(к) Экспорт
        номер = 0;
        Пока Результат.Область(к,2,к,2).Текст = Результат.Область(к+Номер,2,к+Номер,2).Текст Цикл
            Номер = Номер + 1 ;
        КонецЦикла;
        Возврат к+номер-1;
    КонецФункции
    Последнее редактирование модератором: 19 дек 2014
    alexburn нравится это.
  17. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.647
    Симпатии:
    948
    Баллы:
    204
    А это решение для этой задачи или той, где вы ячейки объединяли.
    Просто если Вам итоги внизу надо было, то паричем тут объединение ячеек..

    Если все же для итогов этоо решение, то не проще было бы через вложеную схему уже сделать
    --- Объединение сообщений, 19 дек 2014 ---
    Или оформление макета

Поделиться этой страницей