8.х Проблема с диаграммой

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем courageous, 15 дек 2010.

  1. TopicStarter Overlay
    courageous
    Offline

    courageous

    Регистрация:
    15 дек 2010
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Всем привет. Проблема такая. Есть ТабЗнач 3 колонки и 10 строк, загоняю в диаграмму данные:
    Код:
    1    Для Каждого Колонка из Траб.Колонки Цикл
    2        Если Траб.Колонки.Индекс(Колонка) <> 0 Тогда
    3            Диаграмма.Серии.Добавить(Колонка.Имя);
    4        КонецЕсли;
    5    КонецЦикла;
    6    Для Каждого СтрТраб из Траб Цикл
    7        Точка=Диаграмма.Точки.Добавить(СтрТраб.Получить(0));
    8        Индекс=0;
    9        Для Каждого Серия из Диаграмма.Серии Цикл
    10            Индекс=Индекс+1;
    11            Диаграмма.УстановитьЗначение(Точка,Серия,СтрТраб.Получить(Индекс));
    12        КонецЦикла;
    13    КонецЦикла;
    
    Так в первом цикле добавляются 2 серии - все хорошо, потом второй цикл, после строки 7(в коде) количество серий становиться равным 1, т.е. одна серия удаляется, а точнее удаляются обе, и появляется одна, какая-то левая (без текста и значения).
    При выводе других данных в другую диаграмму по этой же процедуре все ОК, но с этой уже мучаюсь.... никак не пойму в чем дело
  2. yzek
    Offline

    yzek Опытный в 1С

    Регистрация:
    13 окт 2010
    Сообщения:
    713
    Симпатии:
    0
    Баллы:
    26
    Возможно, все дело именно в сроке 7
    Код:
    7        Точка=Диаграмма.Точки.Добавить(СтрТраб.Получить(0));
    
    
    Может быть следует получать все строки, а не только строку с индексом 0?

Поделиться этой страницей