8.х УНФ Проблема при загрузке из клиент банка(НДС)

Тема в разделе ""1С:Управление небольшой фирмой УНФ"", создана пользователем TODD22, 26 май 2012.

  1. TopicStarter Overlay
    TODD22
    Offline

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.755
    Симпатии:
    146
    Баллы:
    104
    Здравствуйте.
    У нас АльфаОнлайн из него грузим в УНФ.
    При загрузке создаются документы, но НДС считается неправильно. Или может ещё в чём проблема. Если я выбирают ставку руками 10% то НДС пересчитывается не правильно и не совпадает с суммой.
    Скрин прикладываю:
    Посмотреть вложение 11223

    Вложения:

  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    На последней воспроизводиться?
  3. TopicStarter Overlay
    TODD22
    Offline

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.755
    Симпатии:
    146
    Баллы:
    104
    Да на 1.1.4.19
    Может у меня что то не правильно... Может цена из вида договора влияет так как установлен флаг "Цена включает НДС", Пока что проверить не могу у меня файла выгрузки из клиент банка нет.
  4. Настройщик
    Offline

    Настройщик Опытный в 1С

    Регистрация:
    17 окт 2010
    Сообщения:
    204
    Симпатии:
    7
    Баллы:
    29
    При загрузке из клиент-банка ставку НДС программа должна бы брать из "Заказа постащику". Но заказ к "Расходу со счета" не цепляется, не смотря на то, что его можно явно указать в клиент-банке в "Загрузке". Потому и ставится самая расхожая ставка.
    А что касается того, что сумма не идет при ручном выборе 10%, то здесь что-то не то с документом. Как-то не удается вывести 524 из 5845 через 10%.
  5. TopicStarter Overlay
    TODD22
    Offline

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.755
    Симпатии:
    146
    Баллы:
    104
    Не понял... То есть не цепляется? Нет такого функционала или же из за того что бух не проставил заказы при загрузке?

    Да надо смотреть что там в клиент банке... надо с буха трясти выгрузку.
  6. Настройщик
    Offline

    Настройщик Опытный в 1С

    Регистрация:
    17 окт 2010
    Сообщения:
    204
    Симпатии:
    7
    Баллы:
    29
    В клиент-банке указываем заказ, но к Расходу он все равно не цепляется. Скорее всего ошибка в программе.
  7. TopicStarter Overlay
    TODD22
    Offline

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.755
    Симпатии:
    146
    Баллы:
    104
    Посмотрел в конфигураторе процедуру заполнения, надо ещё в отладчике посмотреть.

    Код:
    // Заполнение шапки документа.
    УстановитьСвойство(
    ОбъектДокумента,
    "Дата",
    ИсходныеДанные.ДатаДок,
    ,
    ЭтоНовыйДокумент
    );
    
    УстановитьСвойство(
    ОбъектДокумента,
    "ВидОперации",
    ИсходныеДанные.ВидОперации,
    ,
    ЭтоНовыйДокумент
    );
    
    УстановитьСвойство(
    ОбъектДокумента,
    "Организация",
    Организация,
    ,
    ЭтоНовыйДокумент
    );
    
    УстановитьСвойство(
    ОбъектДокумента,
    "БанковскийСчет",
    ИсходныеДанные.БанковскийСчет,
    ,
    ЭтоНовыйДокумент
    );
    
    УстановитьСвойство(
    ОбъектДокумента,
    "ВалютаДенежныхСредств",
    ИсходныеДанные.БанковскийСчет.ВалютаДенежныхСредств,
    ,
    ЭтоНовыйДокумент
    );
    
    УстановитьСвойство(
    ОбъектДокумента,
    "Статья",
    ИсходныеДанные.СтатьяДДС,
    Истина,
    ЭтоНовыйДокумент
    );
    
    УстановитьСвойство(
    ОбъектДокумента,
    "СуммаДокумента",
    ИсходныеДанные.СуммаДокумента,
    Истина,
    ЭтоНовыйДокумент
    );
    
    УстановитьСвойство(
    ОбъектДокумента,
    "НомерВходящегоДокумента",
    ИсходныеДанные.НомерДок,
    ,
    ЭтоНовыйДокумент
    );
    
    УстановитьСвойство(
    ОбъектДокумента,
    "ДатаВходящегоДокумента",
    ИсходныеДанные.ДатаДок,
    ,
    ЭтоНовыйДокумент
    );
    
    Если ЭтоНовыйДокумент Тогда
    ОбъектДокумента.УстановитьНовыйНомер();
    Если ИсходныеДанные.ВидОперации = Перечисления.ВидыОперацийРасходСоСчета.Покупателю Тогда
    ОбъектДокумента.НалогообложениеНДС = УправлениеНебольшойФирмойСервер.НалогообложениеНДС(Организация, , ИсходныеДанные.ДатаДок);
    Иначе
    ОбъектДокумента.НалогообложениеНДС = Перечисления.ТипыНалогообложенияНДС.ОблагаетсяНДС;
    КонецЕсли;
    КонецЕсли;
    
    // Заполнение табличной части документа.
    Если ИсходныеДанные.ВидОперации = Перечисления.ВидыОперацийРасходСоСчета.Поставщику
    ИЛИ ИсходныеДанные.ВидОперации = Перечисления.ВидыОперацийРасходСоСчета.Покупателю Тогда
    
    Если ТипЗнч(ИсходныеДанные.СчетКонтрагента) <> Тип("Строка") Тогда
    УстановитьСвойство(
    ОбъектДокумента,
    "СчетКонтрагента",
    ИсходныеДанные.СчетКонтрагента,
    ,
    ЭтоНовыйДокумент
    );
    КонецЕсли;
    
    УстановитьСвойство(
    ОбъектДокумента,
    "Контрагент",
    ИсходныеДанные.Контрагент,
    ,
    ЭтоНовыйДокумент
    );
    
    Если ОбъектДокумента.РасшифровкаПлатежа.Количество() = 0 Тогда
    СтрокаРасшифровки = ОбъектДокумента.РасшифровкаПлатежа.Добавить();
    Иначе
    СтрокаРасшифровки = ОбъектДокумента.РасшифровкаПлатежа[0];
    КонецЕсли;
    
    ОднаСтрокаВРасшифровкеПлатежа = ОбъектДокумента.РасшифровкаПлатежа.Количество() = 1;
    
    УстановитьСвойство(
    СтрокаРасшифровки,
    "Договор",
    ?(ИсходныеДанные.Договор = "Не найден", Неопределено, ИсходныеДанные.Договор),
    ,
    ЭтоНовыйДокумент
    );
    
    УстановитьСвойство(
    СтрокаРасшифровки,
    "ПризнакАванса",
    ИсходныеДанные.ПризнакАванса,
    Истина,
    ЭтоНовыйДокумент
    );
    
    Если ЭтоНовыйДокумент
    ИЛИ ОднаСтрокаВРасшифровкеПлатежа
    И СтрокаРасшифровки.СуммаПлатежа <> ОбъектДокумента.СуммаДокумента Тогда
    
    СтрокаРасшифровки.СуммаПлатежа = ОбъектДокумента.СуммаДокумента;
    ДатаЗаполнения = ОбъектДокумента.Дата;
    ВалютаРасчетов = СтрокаРасшифровки.Договор.ВалютаРасчетов;
    
    РассчитатьКурсИСуммуРасчетов(
    СтрокаРасшифровки,
    ВалютаРасчетов,
    ДатаЗаполнения,
    ОбъектДокумента,
    ЭтоНовыйДокумент
    );
    
    Если СтрокаРасшифровки.Курс = 0 Тогда
    
    УстановитьСвойство(
    СтрокаРасшифровки,
    "Курс",
    1,
    ,
    ЭтоНовыйДокумент
    );
    
    УстановитьСвойство(
    СтрокаРасшифровки,
    "Кратность",
    1,
    ,
    ЭтоНовыйДокумент
    );
    
    УстановитьСвойство(
    СтрокаРасшифровки,
    "СуммаРасчетов",
    СтрокаРасшифровки.СуммаПлатежа,
    ,
    ЭтоНовыйДокумент
    );
    
    КонецЕсли;
    
    Если ОбъектДокумента.НалогообложениеНДС = Перечисления.ТипыНалогообложенияНДС.ОблагаетсяНДС Тогда
    
    СтавкаНДСПоУмолчанию = ОбъектДокумента.Организация.СтавкаНДСПоУмолчанию;
    ЗначениеСтавкиНДС = УправлениеНебольшойФирмойПовтИсп.ПолучитьЗначениеСтавкиНДС(СтавкаНДСПоУмолчанию);
    
    СтрокаРасшифровки.СтавкаНДС = СтавкаНДСПоУмолчанию;
    СтрокаРасшифровки.СуммаНДС = СтрокаРасшифровки.СуммаПлатежа
    - (СтрокаРасшифровки.СуммаПлатежа)
    / ((ЗначениеСтавкиНДС + 100) / 100);
    
    Иначе
    
    Если ОбъектДокумента.НалогообложениеНДС = Перечисления.ТипыНалогообложенияНДС.НеОблагаетсяНДС Тогда
    СтавкаНДСПоУмолчанию = УправлениеНебольшойФирмойПовтИсп.ПолучитьСтавкуНДСБезНДС();
    Иначе
    СтавкаНДСПоУмолчанию = УправлениеНебольшойФирмойПовтИсп.ПолучитьСтавкуНДСНоль();
    КонецЕсли;
    
    СтрокаРасшифровки.СтавкаНДС = СтавкаНДСПоУмолчанию;
    СтрокаРасшифровки.СуммаНДС = 0;
    
    КонецЕсли;
    
    КонецЕсли;
    
    КонецЕсли;
    
    
    Такое ощущение что это просто не реализовано.
  8. TopicStarter Overlay
    TODD22
    Offline

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.755
    Симпатии:
    146
    Баллы:
    104
    Всё разобрался. Дело в том что в одной платёжке могут быть разные ставки НДС у разных товаров, по этому и сумма по документу отличается от расчетной ндс.

Поделиться этой страницей