8.х Проблема при подключение фискального регистратора Штрих-ФР-Ф в 1С 8.1 Управление Торговлей

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем tlevit, 9 янв 2009.

Статус темы:
Закрыта.
  1. TopicStarter Overlay
    tlevit
    Offline

    tlevit

    Регистрация:
    16 окт 2008
    Сообщения:
    15
    Симпатии:
    0
    Баллы:
    1
    Помогите, пожалуйста может кто нибудь встречался со следующей проблемой при подключение фискального регистратора Штрих-ФР-Ф в 1С 8.1 Управление Торговлей. При закрытии чека пишет " Недостаточно фактических параметров" при открытии конфигурации ссылаеться на следующий код
    Код:
    Функция ПечатьЧека(Идентификатор, Пароль, НомерЧека, НомерСмены,
    ОписаниеЧека, СуммаНал, СуммаБезнал, ПризнакВозврата) Экспорт
    
    Обработка = Неопределено;
    Объект    = Неопределено;
    
    //Создаём объект драйвера
    Если ОбъектДрайвера = Неопределено Тогда 
    ОбъектДрайвера = СоздатьОбъектДрайвера(Идентификатор, Обработка, Объект);
    Результат = ОбъектДрайвера;
    Иначе
    Результат = ОбъектДрайвера;
    КонецЕсли;
    
    Если НЕ ЗначениеЗаполнено(Результат) Тогда
    Результат = Обработка.ОткрытьЧек(Объект, Пароль, ПризнакВозврата, НомерЧека, НомерСмены);
    Если НЕ ЗначениеЗаполнено(Результат) Тогда
    Позиция = Неопределено;
    Для Каждого Позиция Из ОписаниеЧека Цикл
    Результат = Обработка.ПечататьСтроку(Объект,
    Позиция.Наименование,
    Позиция.Количество,
    Позиция.Цена,
    Позиция.Скидка,
    Позиция.НомерСекции,
    Позиция.СтавкаНДС);
    
    Если ЗначениеЗаполнено(Результат) Тогда
    Прервать;
    КонецЕсли;
    КонецЦикла;
    Если НЕ ЗначениеЗаполнено(Результат) Тогда
    Результат = Обработка.ЗакрытьЧек(Объект, СуммаНал, СуммаБезнал);
    КонецЕсли;
    КонецЕсли;
    
    мОписаниеОшибки = Объект.ОписаниеОшибки;
    Иначе
    мОписаниеОшибки = ПолучитьТекстОшибкиПодключенияТО("ФР");
    КонецЕсли;
    
    Возврат Результат;
    
    КонецФункции // ПечатьЧека()
    
    
  2. TopicStarter Overlay
    tlevit
    Offline

    tlevit

    Регистрация:
    16 окт 2008
    Сообщения:
    15
    Симпатии:
    0
    Баллы:
    1
    вопрос решен
Похожие темы
  1. tlevit
    Ответов:
    1
    Просмотров:
    1.118
  2. korse
    Ответов:
    1
    Просмотров:
    1.264
  3. segen
    Ответов:
    1
    Просмотров:
    1.112
  4. astra
    Ответов:
    1
    Просмотров:
    1.432
  5. Will
    Ответов:
    9
    Просмотров:
    5.589
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей