8.х Проблема при обновлении УТ 11.0.8.13

Тема в разделе "Установка платформы "1С:Предприятие 8"", создана пользователем Korenkov, 1 мар 2013.

  1. TopicStarter Overlay
    Korenkov
    Offline

    Korenkov

    Регистрация:
    1 мар 2013
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Платформа 8.2.17.153, типовая конфигурация,обновляю до 11.0.9.5, само обновление из конфигуратора проходит нормально. После обновления запускаю в режиме предприятия, соглашаюсь с условиями распространения обновлений и начинается обновление информационно базы вот тут все виснет намертво. Пробовал смотреть из конфигуратора на каком месте все повисает - проблема в общем модуле АдресныйКлассификатор, процедура РазложитьАдресныеОбъектыПоЭлементам.
    Все зависает на первом цикле, дальше него дело не идет, ждали час и больше = результат нулевой.
    Может кто что посоветует как быть? куда посмотреть? что почитать?
    P.S. пробовал обновить сам адресный классификатор - не помогло.
    Код:
    Процедура РазложитьАдресныеОбъектыПоЭлементам() Экспорт
    
    // Обходим все записи регистра АдресныйКлассификатор и добавляем неактуальные адреса в массив
    МассивНеактуальныхАдресов = Новый Массив;
    Выборка = РегистрыСведений.АдресныйКлассификатор.Выбрать(,"<Нет>");
    Пока Выборка.Следующий() Цикл
    СтруктураАдреса = РазобратьАдресныйОбъектПоЭлементам(Выборка.Код, Выборка.ТипАдресногоЭлемента);
    Если СтруктураАдреса.ПризнакАктуальности <> 0 Тогда
    СтруктураАдреса.Вставить("Код", Выборка.Код);
    СтруктураАдреса.Вставить("ТипАдресногоЭлемента", Выборка.ТипАдресногоЭлемента);
    МассивНеактуальныхАдресов.Добавить(СтруктураАдреса);
    КонецЕсли;
    КонецЦикла;									
    
    // Исправляем записи с неактуальными адресами
    Для Каждого СтруктураАдреса Из МассивНеактуальныхАдресов Цикл
    // Читаем для изменения запись с неактуальным адресом
    МенеджерЗаписи = РегистрыСведений.АдресныйКлассификатор.СоздатьМенеджерЗаписи();
    МенеджерЗаписи.ТипАдресногоЭлемента = СтруктураАдреса.ТипАдресногоЭлемента;
    МенеджерЗаписи.Код = СтруктураАдреса.Код;
    МенеджерЗаписи.Прочитать();
    // Записываем запись с исправлением неактуального адреса
    МенеджерЗаписи.ТипАдресногоЭлемента = СтруктураАдреса.ТипАдресногоЭлемента;
    МенеджерЗаписи.Код = СтруктураАдреса.Код;
    МенеджерЗаписи.КодАдресногоОбъектаВКоде = СтруктураАдреса.КодАдресногоОбъектаВКоде;
    МенеджерЗаписи.КодРайонаВКоде = СтруктураАдреса.КодРайонаВКоде;
    МенеджерЗаписи.КодГородаВКоде = СтруктураАдреса.КодГородаВКоде;
    МенеджерЗаписи.КодНаселенногоПунктаВКоде = СтруктураАдреса.КодНаселенногоПунктаВКоде;
    МенеджерЗаписи.КодУлицыВКоде = СтруктураАдреса.КодУлицыВКоде;
    МенеджерЗаписи.ПризнакАктуальности = СтруктураАдреса.ПризнакАктуальности;
    МенеджерЗаписи.Записать();
    КонецЦикла;
    
  2. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.977
    Симпатии:
    397
    Баллы:
    104
    Как вариант. Попробуйте очистить вообще его. А потом загрузите заново.

    После того, как обновите в смысле.

Поделиться этой страницей