[РЕШЕНО] Проблема при обновлении (Клиент-Серверный вариант 1с)

Тема в разделе "Установка платформы "1С:Предприятие 8"", создана пользователем rexar3006, 27 авг 2014.

  1. TopicStarter Overlay
    rexar3006
    Offline

    rexar3006 Опытный в 1С

    Регистрация:
    11 июл 2012
    Сообщения:
    150
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте помогите решить проблему при обновлении , после сохранении базы данных и запуска отладки не производиться обновление и выдает ошибку (скрин 1), установлен 1с Сервер 64х Предприятия 8.2 и СУБД Ms SQL Server 2008 R2, в файловом варианте все обновление проходит и все запускается, помогите исправить данную проблему.Никогда не сталкивался с с ней

    Вложения:

  2. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.429
    Симпатии:
    372
    Баллы:
    104
    если свежее обновление - то могли и 1С накосячить

    или если у вас файловая это точная копия серверной - возможно проблемы с ИБ серверной
  3. TopicStarter Overlay
    rexar3006
    Offline

    rexar3006 Опытный в 1С

    Регистрация:
    11 июл 2012
    Сообщения:
    150
    Симпатии:
    0
    Баллы:
    26
    Файловая точная копия серверной, да и на сервере никаких действий не делал, хотя некоторое время назад я не смог зайти на ИБ сервера просит пароль, когда заходишь в свойство, пароль вводил несколько раз не принимает
  4. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Т.е. в режиме предприятия никак не получается запустить базу?

    Кэш почистите.

    В конфигураторе константа ПроверятьРазницуВоВремениССервером какой тип имеет?
  5. TopicStarter Overlay
    rexar3006
    Offline

    rexar3006 Опытный в 1С

    Регистрация:
    11 июл 2012
    Сообщения:
    150
    Симпатии:
    0
    Баллы:
    26
    Да не запускаеться программа, программа как бы начинает обновлять версию и сразу ошибка(скрин 2, скрин 3), кэш попробую почистить
    --- Объединение сообщений, 27 авг 2014 ---
    в константе тип: Булево стоит
    --- Объединение сообщений, 27 авг 2014 ---
    Чистка Кэша не помогла

    Вложения:

    Последнее редактирование: 27 авг 2014
  6. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Поставьте временно в конфигураторе "Возврат Истина;" перед "Если НЕ Константы.Проверять....."
  7. TopicStarter Overlay
    rexar3006
    Offline

    rexar3006 Опытный в 1С

    Регистрация:
    11 июл 2012
    Сообщения:
    150
    Симпатии:
    0
    Баллы:
    26
    не помогло та же ошибка выходит
  8. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Такого не может быть.
    Каким образом у вас та же самая ошибка может выходить, если код до той строчки с ошибкой в принципе дойти не может?

    Еще раз: кэш чистили?
  9. TopicStarter Overlay
    rexar3006
    Offline

    rexar3006 Опытный в 1С

    Регистрация:
    11 июл 2012
    Сообщения:
    150
    Симпатии:
    0
    Баллы:
    26
    Кэш чистил, что то думаю у меня проблема в 1с сервере
  10. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.429
    Симпатии:
    372
    Баллы:
    104
    а по коду если оно определяет что файловая то оно и не доходит до этой точки, делает возврат

    а что файловая вернёт если после определения типа ИБ вставить строчку кода
    которая сообщает какое значение содержит константа данная?


    PS
    если по грубому то можно так попробывать сделать:

    вместо
    Код:
    Если ОпределитьЭтаИнформационнаяБазаФайловая() Тогда
         Возврат Истина;
    КонецЕсли;
    
    вот так
    Код:
    Если ОпределитьЭтаИнформационнаяБазаФайловая() Тогда
         Возврат Истина;
    КонецЕсли;
    
    Если НЕ ОпределитьЭтаИнформационнаяБазаФайловая() Тогда
         Возврат Истина;
    КонецЕсли;
  11. TopicStarter Overlay
    rexar3006
    Offline

    rexar3006 Опытный в 1С

    Регистрация:
    11 июл 2012
    Сообщения:
    150
    Симпатии:
    0
    Баллы:
    26
    Почистил еще раз кэш, вроде проходит в режиме отладке обновления, ну сейчас попробую снова БД обновить в Клиент_Серверном варианте обязательно отпишусь по результатам
  12. TopicStarter Overlay
    rexar3006
    Offline

    rexar3006 Опытный в 1С

    Регистрация:
    11 июл 2012
    Сообщения:
    150
    Симпатии:
    0
    Баллы:
    26
    Проблема решилась чисткой кэша 1с, спасибо всем большое за помощь и участие в данной теме ))))

Поделиться этой страницей