8.х Проблема по ТЗ 1С8.1 ЗУП

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Vor4yn, 23 окт 2007.

  1. TopicStarter Overlay
    Vor4yn
    Offline

    Vor4yn

    Регистрация:
    23 окт 2007
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Не работает вид начислений "Оплата нерабочих праздничных дней".
    В документе начисления ЗП где вид оплаты почасовой ставке нужно что бы оплачивались праздн-е дни.8 рабочий день.
    что то у меня есть,а вот что дописать нужно я незнаю :unsure:

    регистр расчёта
    ОсновныеНачисленияРаботниковОрганизаций


    ////////////////////////////////////////////////////////////////////////////////
    // ПЕРЕМЕННЫЕ МОДУЛЯ

    Перем мЗаголовокФормы;

    ////////////////////////////////////////////////////////////////////////////////
    // ОБРАБОТЧИКИ СОБЫТИЙ ФОРМЫ

    // Если форма открывается из списка документов, процедура заполняет организацию
    // прописывает заголовок формы и выставляет отбор регистру
    //
    Процедура ПриОткрытии()

    мЗаголовокФормы = "Основные начисления работников организации ";
    ЭлементыФормы.РегистрРасчетаСписок.РежимВыбора = РежимВыбора;

    // заполним организацию
    ЗаполнениеОтбораПоОрганизацииПоУмолчанию(ЭтаФорма, Отбор.ОбособленноеПодразделение, ЭлементыФормы.Организация,
    ПараметрОтборПоРегистратору, Ложь, глТекущийПользователь,мЗаголовокФормы);

    УстановитьВидимостьЭУПоУчетнойПолитикеПоПерсоналу(ЭлементыФормы,
    глУчетнаяПолитикаПоПерсоналуОрганизации[ЭлементыФормы.Организация.Значение]);

    КонецПроцедуры

    Процедура ПриПовторномОткрытии(СтандартнаяОбработка)

    // заполним организацию
    ЗаполнениеОтбораПоОрганизацииПоУмолчанию(ЭтаФорма, Отбор.ОбособленноеПодразделение, ЭлементыФормы.Организация,
    ПараметрОтборПоРегистратору, Ложь, глТекущийПользователь,мЗаголовокФормы);

    УстановитьВидимостьЭУПоУчетнойПолитикеПоПерсоналу(ЭлементыФормы,
    глУчетнаяПолитикаПоПерсоналуОрганизации[ЭлементыФормы.Организация.Значение]);

    КонецПроцедуры



    ////////////////////////////////////////////////////////////////////////////////
    // ОБРАБОТЧИКИ СОБЫТИЙ ЭЛЕМЕНТОВ УПРАВЛЕНИЯ

    // Процедура прописывает заголовок формы
    //
    // Параметры:
    // Элемент - элемент формы, который отображает организацию
    //
    Процедура ОрганизацияПриИзменении(Элемент)

    Заголовок = мЗаголовокФормы + Элемент.Значение.Наименование;
    Отбор.ОбособленноеПодразделение.Использование = Не Элемент.Значение.Пустая();

    УстановитьВидимостьЭУПоУчетнойПолитикеПоПерсоналу(ЭлементыФормы,
    глУчетнаяПолитикаПоПерсоналуОрганизации[ЭлементыФормы.Организация.Значение]);

    КонецПроцедуры



    ////////////////////////////////////////////////////////////////////////////////
    // ПРОЦЕДУРЫ - ОБРАБОТЧИКИ СОБЫТИЙ ТАБЛИЧНОГО ПОЛЯ РегистрРасчетаСписок

    Процедура РегистрРасчетаСписокВыборЗначения(Элемент, СтандартнаяОбработка, Значение)

    // получим данные записи регистра
    Запрос = Новый Запрос("ВЫБРАТЬ ПЕРВЫЕ 1
    | *
    |ИЗ
    | РегистрРасчета.ОсновныеНачисленияРаботниковОрганизаций КАК ОсновныеНачисленияРаботниковОрганизации
    |
    |ГДЕ
    | ОсновныеНачисленияРаботниковОрганизации.Регистратор = &парамРегистратор И
    | ОсновныеНачисленияРаботниковОрганизации.НомерСтроки = &парамНомерСтроки");
    Запрос.УстановитьПараметр("парамРегистратор", Значение.Регистратор);
    Запрос.УстановитьПараметр("парамНомерСтроки", Значение.НомерСтроки);
    Выборка = Запрос.Выполнить().Выбрать();
    Выборка.Следующий();
    ОповеститьОВыборе(Выборка);
    СтандартнаяОбработка = Ложь;
    КонецПроцедуры

    // Обработчик события вывода строки списка регистра
    Процедура РегистрРасчетаСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)

    // не показываем некоторые ячейки
    ОформлениеСтроки.Ячейки.КолонкаПериодДействия.Видимость = Ложь;
    ОформлениеСтроки.Ячейки.КолонкаБазовыйПериод.Видимость = Ложь;
    ОформлениеСтроки.Ячейки.КолонкаПериодРасчетаСреднегоЗаработка.Видимость = Ложь;
    ОформлениеСтроки.Ячейки.КолонкаНадписьОтпускаПоУходу.Видимость = Ложь;


    КонецПроцедуры

Поделиться этой страницей