8.х Приведение реквизита составного типа документа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем saksaul, 28 апр 2010.

  1. TopicStarter Overlay
    saksaul
    Offline

    saksaul

    Регистрация:
    27 апр 2010
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Платформа 8.1
    Конфигурация: Управление Торговлей (не переписанная)

    ===============================================
    Не работающий код:
    Код:
                СуммаПоступления = 0;
    Докум = Документы.ПоступлениеТоваровУслуг.Выбрать(НачалоГода(НачДата),КонецГода(КонДата));
    Пока Докум.Следующий() Цикл
    Если Докум.Сделка = Неопределено Тогда
    Продолжить;
    КонецЕсли;	     		
    Если ТипЗнч(Докум.Сделка)=Тип("ДокументСсылка.ЗаказПокупателя") Тогда
    МТ = Новый Массив;
    МТ.Добавить(Тип("ДокументСсылка.ЗаказПокупателя"));
    ТЗ = Новый ОписаниеТипов(МТ);
    Попытка
    Заказ = Докум.Сделка;
    Заказ = ТЗ.ПривестиЗначение(Заказ);
    
    //Если ЗначениеВстрокуВнутр(Докум.Сделка)=ЗначениеВстрокуВнутр(Объект) Тогда
    СуммаПоступления = СуммаПоступления + Заказ.СуммаДокумента;
    Сообщить("Да");					
    Сообщить(Строка(Заказ.Номер)+" Сумма "+Строка(Заказ.СуммаДокумента));
    Исключение
    КонецПопытки;
    КонецЕсли;
    КонецЦикла;	
    
    
    Описание проблемы:
    Пир выполнении кода, во время перебора документов, составной реквизит "Сделка" не может найти значение равное типу документа "ДокументСсылка.ЗаказПокупателя", хотя таковое точно есть.
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    "составной реквизит "Сделка" не может найти значение равное типу документа"
    Не очень понял этой проблемы. Расшифруйте, что имеется ввиду.
    По данному коду вообще непонятно, зачем приведение типа используется
  3. TopicStarter Overlay
    saksaul
    Offline

    saksaul

    Регистрация:
    27 апр 2010
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Прошу прощения, с ошибкой разобрались. Просто реквизит Сделка вообще не заполнен, а нужная информация находилась в другом реквизите. Удалите тему, плз.

Поделиться этой страницей