7.7 ПрисоединитьСекцию

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Norvin, 23 окт 2012.

  1. TopicStarter Overlay
    Norvin
    Offline

    Norvin

    Регистрация:
    26 июл 2012
    Сообщения:
    33
    Симпатии:
    1
    Баллы:
    1
    Доброго времени суток! Прошу прошение, если подобные темы уже есть, не нашел.
    Прилагаю скрин своей проблемы. Не могли бы вы подсказать, что необходимо сделать, чтобы при срабатывании
    Код:
    ПрисоединитьСекцию()
    она выводилась не в шахматном порядке)))
  2. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Скрин не вижу.
    Но если выводится в шахматном порядке, то скорее всего неправильное сочетание ВывестиСекцию и ПрисоединитьСекцию.
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    не вижу скрина. Лучше покажите кусок кода
  4. TopicStarter Overlay
    Norvin
    Offline

    Norvin

    Регистрация:
    26 июл 2012
    Сообщения:
    33
    Симпатии:
    1
    Баллы:
    1
    Прошу прощения за ложную информацию о скрине =))))
    Код:
    Таб=СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    Таб.ВывестиСекцию("Заголовок|Основ");
    Пока Запрос.Группировка("ДатаП") = 1 Цикл
    Если ((Запрос.ДатаП > ДПериодаС) или (Запрос.ДатаП = ДПериодаС)) Тогда
    Пока Запрос.Группировка("Подразделение") = 1 Цикл
    Таб.ВывестиСекцию("Подразделение|Основ");
    Пока Запрос.Группировка("Сотрудник") = 1 Цикл
    М = Запрос.ПолучитьАтрибут("Сотрудник");
    Если М.ЭтоГруппа() = 1 Тогда
    Таб.ВывестиСекцию("Группа|Основ");
    Иначе
    Таб.ВывестиСекцию("Сотрудники|Основ");
    Для Т = 1 по 9 Цикл
    ДеньМесяца = Т; 
    Кол = Запрос.ПолучитьАтрибут("Колво0" + Т);
    Таб.ПрисоединитьСекцию("Заголовок|День");
    Таб.ПрисоединитьСекцию("Подразделение|День");
    Таб.ПрисоединитьСекцию("Сотрудники|День");
    КонецЦикла;
    Для Т = 10 по 31 Цикл
    ДеньМесяца = Т;
    Кол = Запрос.ПолучитьАтрибут("Колво" + Т);
    Таб.ПрисоединитьСекцию("Заголовок|День");
    Таб.ПрисоединитьСекцию("Подразделение|День");
    Таб.ПрисоединитьСекцию("Сотрудники|День");
    КонецЦикла;
    КонецЕсли
    КонецЦикла;
    КонецЦикла; 
    Иначе
    Продолжить;
    КонецЕсли;
    КонецЦикла;

    Вложения:

    • Отчет.JPG
      Отчет.JPG
      Размер файла:
      60 КБ
      Просмотров:
      68
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    			    Таб.ВывестиСекцию("Сотрудники|Основ");
    Для Т = 1 по 9 Цикл
    ДеньМесяца = Т;
    Кол = Запрос.ПолучитьАтрибут("Колво0" + Т);
    Таб.ПрисоединитьСекцию("Заголовок|День");
    Таб.ПрисоединитьСекцию("Подразделение|День");
    Таб.ПрисоединитьСекцию("Сотрудники|День");
    
    почему вы присоединяете секции из разных строк?
    секции присоединяются по горизонтали, а не по вертикали
  6. TopicStarter Overlay
    Norvin
    Offline

    Norvin

    Регистрация:
    26 июл 2012
    Сообщения:
    33
    Симпатии:
    1
    Баллы:
    1
    Т.е. если просто
    Код:
    Таб.ПрисоединитьСекцию("День");
    будет работать как надо? Проверить смогу только в понедельник, заранее спасибо =)
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    выложите ваш отчет
  8. TopicStarter Overlay
    Norvin
    Offline

    Norvin

    Регистрация:
    26 июл 2012
    Сообщения:
    33
    Симпатии:
    1
    Баллы:
    1

    Вложения:

  9. GlukAl
    Offline

    GlukAl Опытный в 1С

    Регистрация:
    4 окт 2012
    Сообщения:
    187
    Симпатии:
    7
    Баллы:
    29
    исправь циклы формирования макета
    Код:
      Таб=СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    Таб.ВывестиСекцию("Заголовок|Основ");
    Для Т = 1 по 31 Цикл
    ДеньМесяца = Формат(Т,"Ч(0)2");
    Таб.ПрисоединитьСекцию("Заголовок|День");
    КонецЦикла;
    Пока Запрос.Группировка("ДатаП") = 1 Цикл
    Если ((Запрос.ДатаП > ДПериодаС) или (Запрос.ДатаП = ДПериодаС)) Тогда
    Пока Запрос.Группировка("Подразделение") = 1 Цикл
    Таб.ВывестиСекцию("Подразделение|Основ");
    Для Т = 1 по 31 Цикл
    Таб.ПрисоединитьСекцию("Подразделение|День");
    КонецЦикла;
    Пока Запрос.Группировка("Сотрудник") = 1 Цикл
    М = Запрос.ПолучитьАтрибут("Сотрудник");
    Если М.ЭтоГруппа() = 1 Тогда
    Таб.ВывестиСекцию("Группа|Основ");
    Иначе
    Таб.ВывестиСекцию("Сотрудники|Основ");
    Для Т = 1 по 31 Цикл
    ДеньМесяца = Формат(Т,"Ч(0)2");
    Кол = Запрос.ПолучитьАтрибут("Колво" + ДеньМесяца);
    Таб.ПрисоединитьСекцию("Сотрудники|День");
    КонецЦикла;
    КонецЕсли
    КонецЦикла;
    КонецЦикла;
    Иначе
    Продолжить;
    КонецЕсли;
    КонецЦикла;
    // Таб.ВывестиСекцию("Подвал|Основ");
    Таб.Опции(0,0,0,0);
    Таб.ПараметрыСтраницы(1,,,,,,,,,1);
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Таблица",);
    
  10. TopicStarter Overlay
    Norvin
    Offline

    Norvin

    Регистрация:
    26 июл 2012
    Сообщения:
    33
    Симпатии:
    1
    Баллы:
    1
    Спасибо большое, именно это мне и нужно было. Теперь буду осмысливать как это происходит =)))
  11. GlukAl
    Offline

    GlukAl Опытный в 1С

    Регистрация:
    4 окт 2012
    Сообщения:
    187
    Симпатии:
    7
    Баллы:
    29
    а не надо в строку с данными выводить ячейки заголовка
    нужно в заголовке присоединяешь секции для заголовка
    а строках присоединяешь секции для строк

Поделиться этой страницей