8.х Присоединенные файлы к документу

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем SkyNetYar, 2 мар 2016.

  1. TopicStarter Overlay
    SkyNetYar
    Offline

    SkyNetYar Опытный в 1С

    Регистрация:
    11 ноя 2014
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    Добрый день! УТ 11.1.10
    Пытаюсь реализовать присоединение фотографий к документу.
    Содрал все из Справочник.Номенклатура формы и процедуры ,в общем все 1 в 1
    Но при добавлении фотки к документу вылетает ошибка

    Код:
    {ОбщийМодуль.ПрисоединенныеФайлыСлужебный.Модуль(1449)}: Ошибка при добавлении присоединенного файла.
    У владельца файлов "Документ cервиса 00СЦ-0770 от 24.02.2016 11:31:50" типа "Документ cервиса"
    не указан основной справочник для хранения файлов.
    
    В этом случае параметр "НоваяСсылкаНаФайл" должен быть указан.
        ВызватьИсключение СокрЛП(ТекстОшибки);
    
    Вроде бы все делал как у справочника номенклатура но не могу понять где искать этот НоваяСсылкаНаФайл

    Вот из общего модуля процедура
    Код:
    // Возвращает имя справочника для указанного владельца или вызывает исключение,
    // если их более одного.
    //
    // Параметры:
    //  ВладелецФайлов  - Ссылка - объект, к которому добавляется файл.
    //  ИмяСправочника  - Строка, если заполнено, то выполняется проверка
    //                    наличия справочника среди справочников владельца для хранения файлов.
    //                    Если не заполнено, возвращает имя основного справочника.
    //  ЗаголовокОшибки - Строка - заголовок ошибки.
    //                  - Неопределено - не вызывать исключение, а вернуть пустую строку.
    //  ИмяПараметра    - Строка - имя требуемого параметра для определения имени справочника.
    //  ОкончаниеОшибки - Строка - окончание ошибки (только для случая, когда ИмяПараметра = Неопределено).
    //
    Функция ИмяСправочникаХраненияФайлов(ВладелецФайлов, ИмяСправочника = "",
        ЗаголовокОшибки = Неопределено, ОкончаниеОшибки = Неопределено) Экспорт
       
        НеВызыватьИсключение = (ЗаголовокОшибки = Неопределено);
        ИменаСправочников = ИменаСправочниковХраненияФайлов(ВладелецФайлов, НеВызыватьИсключение);
       
        Если ИменаСправочников.Количество() = 0 Тогда
            Если НеВызыватьИсключение Тогда
                Возврат "";
            КонецЕсли;
           
            ВызватьИсключение СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
                ЗаголовокОшибки + Символы.ПС +
                НСтр("ru = 'У владельца файлов ""%1"" типа ""%2""
                           |нет справочников для хранения файлов.'"),
                Строка(ВладелецФайлов),
                Строка(ТипЗнч(ВладелецФайлов)));
        КонецЕсли;
       
        Если ЗначениеЗаполнено(ИмяСправочника) Тогда
            Если ИменаСправочников[ИмяСправочника] <> Неопределено Тогда
                Возврат ИмяСправочника;
            КонецЕсли;
       
            Если НеВызыватьИсключение Тогда
                Возврат "";
            КонецЕсли;
           
            ВызватьИсключение СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
                ЗаголовокОшибки + Символы.ПС +
                НСтр("ru = 'У владельца файлов ""%1"" типа ""%2""
                           |нет справочника ""%3"" для хранения файлов.'"),
                Строка(ВладелецФайлов),
                Строка(ТипЗнч(ВладелецФайлов)),
                Строка(ИмяСправочника));
        КонецЕсли;
       
        ОсновнойСправочник = "";
        Для каждого КлючИЗначение Из ИменаСправочников Цикл
            Если КлючИЗначение.Значение = Истина Тогда
                ОсновнойСправочник = КлючИЗначение.Ключ;
                Прервать;
            КонецЕсли;
        КонецЦикла;
       
        Если ЗначениеЗаполнено(ОсновнойСправочник) Тогда
            Возврат ОсновнойСправочник;
        КонецЕсли;
           
        Если НеВызыватьИсключение Тогда
            Возврат "";
        КонецЕсли;
       
        ШаблонПричиныОшибки =
            НСтр("ru = 'У владельца файлов ""%1"" типа ""%2""
                |не указан основной справочник для хранения файлов.'") + Символы.ПС;
               
        ПричинаОшибки = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
            ШаблонПричиныОшибки, Строка(ВладелецФайлов), Строка(ТипЗнч(ВладелецФайлов)));
           
        ТекстОшибки = ЗаголовокОшибки + Символы.ПС
            + ПричинаОшибки + Символы.ПС
            + ОкончаниеОшибки;
           
        ВызватьИсключение СокрЛП(ТекстОшибки);
       
    КонецФункции
    
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    На ИТС почитайте статьи по БСП, как и что нужно, а самое главное где, нужно прописать код, чтобы не изобретать велосипед:)
  3. TopicStarter Overlay
    SkyNetYar
    Offline

    SkyNetYar Опытный в 1С

    Регистрация:
    11 ноя 2014
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    Да вот нет доступа к ИТС :(
    Может ткнете на что то похожее?
    Поиском все излазил ну нет нигде НоваяСсылкаНаФайл где указать этот параметр..
  4. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Скорее всего у какого-нибудь справочника нужно установить еще один тип документа, которому разрешено присоединять файлы. Плюс еще, возможно, в подписках на событиях возможно тоже нужно проставить. Это все на коленке написано:)
  5. TopicStarter Overlay
    SkyNetYar
    Offline

    SkyNetYar Опытный в 1С

    Регистрация:
    11 ноя 2014
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    Вот если я делаю так
    Общую команда "ПрисоединенныеФайлы", в свойств "Тип параметра команды" указываю нужный объект (например, "РеализацияТоваров").
    Справочник "Файлы". Указываю нужный объект в типе реквизита "ВладелецФайла".
    То все нормально присоединяется, если же по аналогии со справочником Номенклатура то хрен там два -Arghh-
  6. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Потому что нужно почитать про внедрение подсистемы хранения файлов на ИТС :)
  7. TopicStarter Overlay
    SkyNetYar
    Offline

    SkyNetYar Опытный в 1С

    Регистрация:
    11 ноя 2014
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    Вот как бы в конфигурации нашел описание
    Но как ее передать что то не допераю...
  8. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Ну зайдите в этот справочник - хранения файлов владельца, посмотрите какие реквизиты, какие типы используются. Без документации - скуритесь что-то внедрять :)
Похожие темы
  1. Назым
    Ответов:
    8
    Просмотров:
    2.524
  2. 1C_Mouse
    Ответов:
    4
    Просмотров:
    614
Загрузка...

Поделиться этой страницей