8.х ПриСкопирование Очистить

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Эмиль0690, 26 май 2015.

  1. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    Добрый день!
    В ПКО добавил КонечныйОстаток т.е для печати чтоб было конечный остаток клиента
    Код:
    Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
       
            Запрос = Новый Запрос;
            Запрос.Текст =
            "ВЫБРАТЬ
            |    ВзаиморасчетыПоКонтрагентамОстатки.ОстатокОстаток
            |ИЗ
            |    РегистрНакопления.ВзаиморасчетыПоКонтрагентам.Остатки(, Клиент = &Контрагент) КАК ВзаиморасчетыПоКонтрагентамОстатки";
           
            Запрос.УстановитьПараметр("Контрагент", Контрагент);
            //Запрос.УстановитьПараметр("Получатель", Получатель);
           
            Результат = Запрос.Выполнить();
           
            ВыборкаДетальныеЗаписи = Результат.Выбрать();
           
            Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
                НачальныйОстаток = ВыборкаДетальныеЗаписи.ОстатокОстаток;
            КонецЦикла;
    
           КонечныйОстаток = НачальныйОстаток - USD
       
    КонецПроцедуры
    
    Но при копирование документа копирует Конечный остаток другого клиента
    Как сделать чтоб при копирование очистил Конечный остаток?
    Спасибо!
  2. Thelearning
    Offline

    Thelearning Профессионал в 1С Команда форума

    Регистрация:
    9 сен 2010
    Сообщения:
    701
    Симпатии:
    72
    Баллы:
    54
    Модуль объекта, процедура "ПриКопировании"
    Эмиль0690 нравится это.
  3. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    а дальше как?
    попробовал так ошибки дает
    Код:
    Процедура ПриКопировании(ОбъектКопирования)
       
        КонечныйОстаток = Очистить
       
    КонецПроцедуры
    
  4. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.949
    Симпатии:
    149
    Баллы:
    104
    Код:
    КонечныйОстаток = 0;
    Эмиль0690 нравится это.
  5. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    Спасибо!
Похожие темы
  1. chelentano
    Ответов:
    8
    Просмотров:
    3.658
  2. Alona
    Ответов:
    18
    Просмотров:
    4.447
  3. atynov
    Ответов:
    2
    Просмотров:
    1.790
Загрузка...

Поделиться этой страницей