8.х Принцип работы группировки

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем antares, 8 авг 2013.

  1. TopicStarter Overlay
    antares
    Offline

    antares Опытный в 1С

    Регистрация:
    30 ноя 2006
    Сообщения:
    340
    Симпатии:
    7
    Баллы:
    29
    Платформа 8.2.

    Есть такой код:
    [Code1c]
    Функция ОбходИерархииНоменклатура(Выборка)
    Пока Выборка.Следующий() Цикл
    Сообщить(Строка(Выборка.Наименование) +": Количество ="+Строка(Выборка.Количество) +" "+ Строка(Выборка.ТипЗаписи()));
    ОбходИерархииНоменклатура(Выборка.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией));
    КонецЦикла;
    Возврат Истина;
    КонецФункции

    Функция СформироватьВыборкуИерархииНоменклатуры()
    ТекстЗапроса = "Выбрать Наименование, 1 как Количество из Справочник.Номенклатура Упорядочить по Наименование Итоги Сумма(Количество) по Наименование Только Иерархия";
    Запрос = новый Запрос(ТекстЗапроса);
    Возврат ОбходИерархииНоменклатура(Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией));
    КонецФункции
    [/Code1c]
    в результате получаю вывод всех наименований номенклатур как "Детальные записи" с количестом =1, но самая первая пустая запись с количеством = количеству элементов справочника и типом записи "Итог по группировке". В синтаксис-помощнике говорится, что по иерархии будут расчитаны итоги, нопочему то расчитались итоги только по корневой папки, по вложенным итогов нет (контрольные точки не учитываем).

    Вопрос: как просчитать запросом итоги по вложенным папкам иерархии справочника? Напоминаю, рекурсивно для каждой записи выборки выполняется метод Выбрать(), но кроме Итогов корня больше итогов нет.

Поделиться этой страницей