7.7 Пример запроса

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем zetovich, 21 июл 2006.

  1. TopicStarter Overlay
    zetovich
    Online

    zetovich Гость Гость

    расскажу на уровне 7.7
    По регистру "ПартииТоваровНаСкладах" (УТ для Украины)
    нужно выбрать остатки по этому регистру на "ВыбДата"
    по складу "ВыбСклад"
    -----------
    можно не точный запрс...мне нужно знать куды копать
    не судите строго..
    спс
  2. Tiger
    Offline

    Tiger Опытный в 1С

    Регистрация:
    12 июл 2006
    Сообщения:
    489
    Симпатии:
    0
    Баллы:
    26
    Приблизительно так:
    Код:
    Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |Номенклатура = Регистр.ПартииТоваровНаСкладах.Номенклатура;
    |Склад = Регистр.ПартииТоваровНаСкладах.МОЛ;
    |Количество = Регистр.ПартииТоваровНаСкладах.Количество;
    |Функция КоличествоКонОст = КонОст(Количество);
    |Группировка Номенклатура;
    |Условие(Склад = ВыбСклад);
    |"//}}ЗАПРОС;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;
    
    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка(1) = 1 Цикл
    // Заполнение полей Номенклатура
    Таб.ВывестиСекцию("Номенклатура");
    КонецЦикла;
    // Заполнение полей "Итого"
    Таб.ВывестиСекцию("Итого");
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
    КонецПроцедуры
    
    
    

Поделиться этой страницей