8.х При выборе кассы (элемент справочника) вывести конечный остаток на форму

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем ppkmlite, 8 ноя 2014.

  1. TopicStarter Overlay
    ppkmlite
    Offline

    ppkmlite Опытный в 1С

    Регистрация:
    28 окт 2014
    Сообщения:
    70
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте. Подскажите, пожалуйста. Создаю обработку, на форме две организации, две кассы. Нужно при выборе кассы на форме справочно надписью вывести конечный остаток и если он отрицательный, то создать документ приходный кассовый ордер на сумму остатка.
    нА ТЕКУЩИЙ МОМЕНТ ДОШЛА ДО ЭТОГО

    Создаю запрос , источником выбираю регистр накопления.
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    | ДенежныеСредстваОстатки.СуммаОстаток
    |ИЗ
    | РегистрНакопления.ДенежныеСредства.Остатки(&Период, ) КАК ДенежныеСредстваОстатки";

    //Запрос.УстановитьПараметр("Период", Период);

    РезультатЗапроса = Запрос.Выполнить();

    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
    // Вставить обработку выборки ВыборкаДетальныеЗаписи
    КонецЦикла;


    Вопрос! как вывести результат запроса (то есть остаток по кассе) на форму в виде надписи
  2. TopicStarter Overlay
    ppkmlite
    Offline

    ppkmlite Опытный в 1С

    Регистрация:
    28 окт 2014
    Сообщения:
    70
    Симпатии:
    0
    Баллы:
    26
    Попробывала так
    Процедура Касса1НачалоВыбора(Элемент, СтандартнаяОбработка)
    СтандартнаяОбработка=Ложь;

    Форма=Справочники.Кассы.ПолучитьФормуВыбора(,Элемент,);
    Форма.Отбор.Владелец.Установить(ОрганизацияОт, Истина);
    Форма.ЗакрыватьПриВыборе = Истина;

    Если ЗначениеЗаполнено(Элемент.Значение) Тогда

    Форма.ПараметрТекущаяСтрока=Элемент.Значение;

    КонецЕсли;

    Форма.РежимВыбора=Истина;

    Форма.Открыть();
    //Будем выводить остаток по кассе
    Надпись1 = ОстатокПоКассе(Надпись1);
    КонецПроцедуры

    Функция ОстатокПоКассе(Надпись1) Экспорт
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    | ДенежныеСредстваОстатки.СуммаОстаток
    |ИЗ
    | РегистрНакопления.ДенежныеСредства.Остатки(&Период, ) КАК ДенежныеСредстваОстатки";

    Запрос.УстановитьПараметр("Период", Период);

    РезультатЗапроса = Запрос.Выполнить();

    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    Описание = "";

    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
    Описание = Описание + Строка(ВыборкаДетальныеЗаписи.СуммаОстаток)
    КонецЦикла;
    Но результат нет
  3. Дмитрий@
    Offline

    Дмитрий@ Новичок в 1С

    Регистрация:
    9 ноя 2014
    Сообщения:
    30
    Симпатии:
    1
    Баллы:
    4
    В этой функции ОстатокПоКассе(Надпись1) я не вижу команды возврата, После конец цикла нужно видимо добавить Возврат Описание.
  4. TopicStarter Overlay
    ppkmlite
    Offline

    ppkmlite Опытный в 1С

    Регистрация:
    28 окт 2014
    Сообщения:
    70
    Симпатии:
    0
    Баллы:
    26
    Добавила возврат описание. Спасибо
    --- Объединение сообщений, 9 ноя 2014 ---
    Подскажите, если мне нужно получить остатки из двух касс, я в запросе должна сделать разрез по организациям и по кассам?или два запроса?
    "ВЫБРАТЬ
    | ДенежныеСредстваОстатки.СуммаОстаток
    |ИЗ
    | РегистрНакопления.ДенежныеСредства.Остатки(&Период, ) КАК ДенежныеСредстваОстатки";
    Последнее редактирование: 9 ноя 2014

Поделиться этой страницей