7.7 при создании процедуры выдает ошибку

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем AlaN, 16 сен 2015.

  1. TopicStarter Overlay
    AlaN
    Offline

    AlaN

    Регистрация:
    7 сен 2015
    Сообщения:
    34
    Симпатии:
    0
    Баллы:
    1
    нужно чтобы при взаиморасчетах с контрагентами можно было вывести неоплаченные накладные
    P.S. То что вставил в кавычки, это то что я сам дописал, но мне выдает ошибку:
    <<?>>Процедура Таб.Показать("Взаиморасчеты","")
    {Отчет.Взаиморасчеты.Форма.Модуль(387)}: Определения процедур и функций должны размещаться перед операторами основной программы
  2. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    Код:
    ДатаС = Мин(ПолучитьДатуТА(),НачМесяца(РабочаяДата()));
    ДатаПо = РабочаяДата()
    должна быть в процедуре/функции!! Попробуйте удалить
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    или перенести в конец модуля или в процедуру ПриОткрытии
  4. TopicStarter Overlay
    AlaN
    Offline

    AlaN

    Регистрация:
    7 сен 2015
    Сообщения:
    34
    Симпатии:
    0
    Баллы:
    1
    мне эти строчки надо добавить или удалить?
    --- Объединение сообщений, 16 сен 2015 ---
    что перенести?
  5. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    понимаете, эти строчки должны быть в теле процедуры
  6. TopicStarter Overlay
    AlaN
    Offline

    AlaN

    Регистрация:
    7 сен 2015
    Сообщения:
    34
    Симпатии:
    0
    Баллы:
    1
    //*******************************************


    Процедура Таб.Показать("Взаиморасчеты","");

    КонецПроцедуры


    //*******************************************



    Процедура НеОплаченныеНакладные()
    ..// Отчет по неоплаченным накладным...
    ДатаС = Мин(ПолучитьДатуТА(),НачМесяца(РабочаяДата()));
    ДатаПо = РабочаяДата();

    КонецПроцедуры

    Процедура ПриОткрытии()
    НеОплаченныеНакладные();
    КонецПроцедуры

    вот так правильней?
  7. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    Код:
    Процедура ПриОткрытии()
       ДатаС = Мин(ПолучитьДатуТА(),НачМесяца(РабочаяДата()));
       ДатаПо = РабочаяДата();
       НеОплаченныеНакладные();
    КонецПроцедуры
    - так вернее
  8. TopicStarter Overlay
    AlaN
    Offline

    AlaN

    Регистрация:
    7 сен 2015
    Сообщения:
    34
    Симпатии:
    0
    Баллы:
    1
    опять
    //*******************************************
    Процедура Таб.Показать("Взаиморасчеты","");

    КонецПроцедуры
    //*******************************************
    Процедура НеОплаченныеНакладные()
    ..// Отчет по неоплаченным накладным...

    КонецПроцедуры

    Процедура ПриОткрытии()
    ДатаС = Мин(ПолучитьДатуТА(),НачМесяца(РабочаяДата()));
    ДатаПо = РабочаяДата();
    НеОплаченныеНакладные();
    КонецПроцедуры

    <<?>>Процедура Таб.Показать("Взаиморасчеты","");
    {Отчет.Взаиморасчеты.Форма.Модуль(387)}: Определения процедур и функций должны размещаться перед операторами основной программы
  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    А я бы вниз спустил.. Иначе перестанут работать механизмы сохранения реквизитов формы (если конечно это важно)
  10. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    вообще удалите!! :eek:
  11. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    //*******************************************
    Процедура Таб.Показать("Взаиморасчеты","");

    КонецПроцедуры
    //*******************************************

    это убрать
  12. TopicStarter Overlay
    AlaN
    Offline

    AlaN

    Регистрация:
    7 сен 2015
    Сообщения:
    34
    Симпатии:
    0
    Баллы:
    1
    убрал, но ошибка осталась (((
  13. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    покажите код, который получился
  14. TopicStarter Overlay
    AlaN
    Offline

    AlaN

    Регистрация:
    7 сен 2015
    Сообщения:
    34
    Симпатии:
    0
    Баллы:
    1
    //*******************************************

    Процедура НеОплаченныеНакладные()
    ..// Отчет по неоплаченным накладным...

    КонецПроцедуры

    Процедура ПриОткрытии()
    ДатаС = Мин(ПолучитьДатуТА(),НачМесяца(РабочаяДата()));
    ДатаПо = РабочаяДата();
    НеОплаченныеНакладные();
    КонецПроцедуры
  15. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    -Banghead-
    - это что у вас в теле процедуры????? удалите
  16. TopicStarter Overlay
    AlaN
    Offline

    AlaN

    Регистрация:
    7 сен 2015
    Сообщения:
    34
    Симпатии:
    0
    Баллы:
    1
    //*******************************************

    Процедура ПриОткрытии();
    ДатаС = Мин(ПолучитьДатуТА(),НачМесяца(РабочаяДата()));
    ДатаПо = РабочаяДата();
    НеОплаченныеНакладные();
    КонецПроцедуры

    <<?>>Процедура ПриОткрытии();
    {Отчет.Взаиморасчеты.Форма.Модуль(387)}: Определения процедур и функций должны размещаться перед операторами основной программы
  17. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    скорее всего или модуль не сохранили или в режиме предприятия забыли закрыть/открыть обработку
  18. TopicStarter Overlay
    AlaN
    Offline

    AlaN

    Регистрация:
    7 сен 2015
    Сообщения:
    34
    Симпатии:
    0
    Баллы:
    1
    модуль сохраняю, режим предприятия не забыл закрыть
  19. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Магия пятого уровня...
    Выложите не код, а саму обработку
  20. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    скорее всего удалена Процедура НеОплаченныеНакладные() на которую ссылается ПриОткрытии()

Поделиться этой страницей