8.х При создании док-та не записывается реквизит

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем ges58, 1 июн 2011.

  1. TopicStarter Overlay
    ges58
    Offline

    ges58 Опытный в 1С

    Регистрация:
    8 сен 2008
    Сообщения:
    104
    Симпатии:
    0
    Баллы:
    26
    Во внешней обработке создаю док-т "План производства". Формирую таб.часть "СоставПлана" по фактическому выпуску за указанный пользователем период. Реквизит "Количество" не заполняется (пусто). Пробовала заполнить другие числовые реквизиты (цена, сумма) - то же самое. А вот поле "Коэффициент" заполнилось. Оно задано в конфигураторе в форме документа как недоступное в отличии от поля "Количество" и др.
    Не пойму - в чем причина, первый раз столкнулась с таким, хотя обработок по заполнению разных документов сделано достаточно.

    Текст такой:

    ДокументПлана = Документы.ПланПроизводства.СоздатьДокумент();
    ДокументПлана.Дата = ТекущаяДата();

    Далее в цикле:

    Строка = ДокументПлана.СоставПлана.Добавить();
    Строка.Номенклатура = Номенклатура;
    Строка.Спецификация = Результат.Спецификация;
    Строка.Количество = Итог;

    Далее:

    ДокументПлана.Записать();

    Переменная "Итог" рассчитывается, при отладке имеет правильное значение, но в документ не записывается. Номенклатура и спецификация заполнены. ПОЧЕМУ???
  2. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    В модуле объекта смотрите процедуру ПередЗаписью. Там, в зависимости от сценария планирования, обнуляется количество.
  3. TopicStarter Overlay
    ges58
    Offline

    ges58 Опытный в 1С

    Регистрация:
    8 сен 2008
    Сообщения:
    104
    Симпатии:
    0
    Баллы:
    26
    Модуль объекта пустой.
  4. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Модуль объекта документа ПланПроизводства пустой?! Релиз конфигурации какой?
  5. TopicStarter Overlay
    ges58
    Offline

    ges58 Опытный в 1С

    Регистрация:
    8 сен 2008
    Сообщения:
    104
    Симпатии:
    0
    Баллы:
    26
    Релиз 1.2.39.1
    Документ создается внешней обработкой. Я чего-то не понимаю? Я его просто создаю и записываю, попросили сделать док-т "План производства", в котором количество должно равняться фактическому выпуску продукции за определенный период на определенные склады. Выбираю из регистра накопления "Выпуск продукции" и пишу в созданный док-т. Всё хорошо, но не заполняется "Количество".
  6. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Под рукой такого релиза нет. Но модуль документа не должен быть пустым (документ же проводится, есть печатные формы).
    При записи документа выполняются предопределенные функции, которые в этом модуле (документа) находятся. В частности, в вашем случае, процедура ПередЗаписью, в которой есть (должны быть) такие строки (релиз УПП какой-то 1.3):
    Код:
    УчетПоКоличеству = Сценарий.УчетПоКоличеству;
    УчетПоСуммам = Сценарий.УчетПоСуммам;
    Для каждого Строка из СоставПлана Цикл
    Если НЕ УчетПоКоличеству И Строка.Количество <> 0  Тогда
    Строка.Количество = 0;
    КонецЕсли;
    
    Если НЕ Сценарий.УчетПоСуммам  И (Строка.Цена <> 0 ИЛИ Строка.Сумма <> 0 ИЛИ Строка.СуммаНДС <> 0) Тогда
    Строка.Цена = 0;
    Строка.Сумма = 0;
    Строка.СуммаНДС = 0;
    КонецЕсли;
    КонецЦикла;
    
    
  7. Наташа
    Offline

    Наташа Опытный в 1С

    Регистрация:
    14 авг 2010
    Сообщения:
    1.442
    Симпатии:
    2
    Баллы:
    29
    Пустой модуль, видимо, у обработки, а не у документа.
    А количество обнуляется при записи, видимо, потому, что в сценарии не стоит учет по количеству.
    Ваш К.О. :angry:
  8. TopicStarter Overlay
    ges58
    Offline

    ges58 Опытный в 1С

    Регистрация:
    8 сен 2008
    Сообщения:
    104
    Симпатии:
    0
    Баллы:
    26
    Разобралась. С УПП работаю не так давно, разбираться во всём приходится одной. Я просто не указала сценарий при создании документа. Благодаря вам узнала много нового.
    Всем СПАСИБО !!!

Поделиться этой страницей