7.7 при распечатке печатной формы печатает 5 листов

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем LED82, 7 авг 2012.

  1. TopicStarter Overlay
    LED82
    Offline

    LED82 Опытный в 1С

    Регистрация:
    27 июн 2012
    Сообщения:
    66
    Симпатии:
    0
    Баллы:
    26
    Код:
    Процедура ПриОткрытии()
    СтатусВозврата(0)
    КонецПроцедуры
    Процедура Печать()
    Сп=СоздатьОбъект("СписокЗначений");  //создаем список значений для передачи во внешнюю форму
    Сп.ДобавитьЗначение("ТекущийЭлемент"); //считывает параметры текущего документа
    Сп.ДобавитьЗначение("1"); //в каждый модуль вставляем свою цифру, это даст Djgovor.ert возможность 
    ОткрытьФорму("Отчет", ," " + КаталогИБ() + ПУТЬ_ДО_ПЕЧ.ФОРМЫ + "\Dogovor.ert");//добавленное
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("М-11");
    
    ПодразделениеПолучатель = "";
    Если ВидПеремещения = 0 Тогда
    КорСчет = СчетЗатрат.Код;
    Для СчетчикЦикла = 1 По СчетЗатрат.КоличествоСубконто() Цикл
    Субконто = ПолучитьАтрибут("Субконто" + СчетчикЦикла);
    Если Субконто.Вид() = "Подразделения" Тогда
    ПодразделениеПолучатель = Субконто;
    Прервать;
    КонецЕсли;
    КонецЦикла;
    Иначе
    ПодразделениеПолучатель = МестоХраненияПриемник;
    КонецЕсли;			   
    ПодразделениеОтправитель = МестоХранения;
    
    Если Проведен() = 0 Тогда
    НомерПовторяемойСтроки = 16;
    ТекстПредупреждения = "Для непроведенного документа графы ""Цена"" и ""Сумма"" не заполняются.";
    Таб.ВывестиСекцию("Предупреждение");
    Таб.ВывестиСекцию("Шапка");
    
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
    Субсчет = КодСубсчета();
    Если Материал.Выбран() = 1 Тогда
    МатЦенность = Материал;
    Код = Материал.Код;
    ЕдиницаИзмерения = Материал.ЕдиницаИзмерения;
    ЕдиницаИзмеренияКод = Материал.ЕдиницаИзмерения.Код;
    МатериалСумма = 0;
    МатериалЦенаБезНДС = 0;
    КонецЕсли;
    Таб.ВывестиСекцию("Строка");
    Состояние("Выведено строк: " + НомерСтроки);
    КонецЦикла;
    
    ИначеЕсли Модифицированность() = 1 Тогда
    Предупреждение("Для печати документ необходимо перепровести.");
    Возврат;
    
    Иначе
    НомерПовторяемойСтроки = 15;
    Таб.ВывестиСекцию("Шапка");
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
    Если Материал.Выбран() = 1 Тогда
    Субсчет = КодСубсчета();
    МатЦенность = Материал;
    Код = Материал.Код;
    ЕдиницаИзмерения = Материал.ЕдиницаИзмерения;
    ЕдиницаИзмеренияКод = Материал.ЕдиницаИзмерения.Код;
    МатериалСумма = Сумма;
    МатериалЦенаБезНДС = Сумма / КоличествоОтпущено;
    КонецЕсли;
    Таб.ВывестиСекцию("Строка");
    Состояние("Выведено строк: " + НомерСтроки);
    КонецЦикла;
    КонецЕсли;
    Таб.ВывестиСекцию("Подвал");
    Таб.Опции(0, 0, ?(Докум.Проведен() = 0, 1, 0), 0, "ОпцииПечатиМ11", "ОкноМ11");
    Таб.ОбластьПечати(?(Докум.Проведен() = 0, 2, 1), 2,,);
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Требование-накладная (форма №М-11)");
    КонецПроцедуры // Печать
    КонецПроцедуры
    

    При выводе на печать печатает 1 лист м-11 и потом 5 листов чистых в чем проблема не пойму

    Внимание! Пользуйтесь тегами.
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Дело не в коде, а в макете печатной формы.

    Обратите внимание, что в макете справа или(и) снизу будут пустые колонки (строки). Нужно удалить все колонки и строки справа и снизу макета печатной формы, пунктирные линии в макете должны проходить по краю шаблонов (но могут перекрываться красными линиями секций, поэтому их видимость можно временно отключить).

    Снизу, как пример, видно, что одна ячейка заполнена, но есть пустые колонки и строки, которые тоже будут "выводится" на печать.

    Посмотреть вложение 11859

    Вложения:

  3. TopicStarter Overlay
    LED82
    Offline

    LED82 Опытный в 1С

    Регистрация:
    27 июн 2012
    Сообщения:
    66
    Симпатии:
    0
    Баллы:
    26
    решено удалил пустые колонки и строки

    все печатает
Похожие темы
  1. bobrakov
    Ответов:
    10
    Просмотров:
    2.128
  2. Rulezzz2
    Ответов:
    19
    Просмотров:
    1.430
Загрузка...

Поделиться этой страницей