8.х Преобразование к типу число не может быть выполнено

Тема в разделе "Установка платформы "1С:Предприятие 8"", создана пользователем Екатерина92, 25 мар 2017.

  1. TopicStarter Overlay
    Екатерина92
    Offline

    Екатерина92

    Регистрация:
    30 янв 2017
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Процедура ЗаполнитьКолонкуСуммаПродажная(ТаблицаТоваров, ТаблицаПоЦенам, ИмяКолонкиВидСклада = Неопределено, ИмяКолонкиКоличество = "Количество") Экспорт

    ЕстьХарактеристика = (ТаблицаТоваров.Колонки.Найти("ХарактеристикаНоменклатуры") <> Неопределено);

    СтруктураПоискаЦены = Новый Структура;
    ПустаяХарактеристика = Справочники.ХарактеристикиНоменклатуры.ПустаяСсылка();
    ВидСкладаРозничный = Перечисления.ВидыСкладов.Розничный;

    Для Каждого СтрокаТаблицы Из ТаблицаТоваров Цикл
    Если ИмяКолонкиВидСклада = Неопределено
    Или СтрокаТаблицы[ИмяКолонкиВидСклада] = ВидСкладаРозничный Тогда
    СтруктураПоискаЦены.Вставить("Склад", СтрокаТаблицы.Склад);
    СтруктураПоискаЦены.Вставить("Номенклатура", СтрокаТаблицы.Номенклатура);

    Если ЕстьХарактеристика Тогда
    СтруктураПоискаЦены.Вставить("ХарактеристикаНоменклатуры", СтрокаТаблицы.ХарактеристикаНоменклатуры);

    СтрокаЦен = ОбработкаТабличныхЧастей.НайтиСтрокуТабЧасти(ТаблицаПоЦенам, СтруктураПоискаЦены);
    Если СтрокаЦен = Неопределено Тогда
    СтруктураПоискаЦены.Вставить("ХарактеристикаНоменклатуры", ПустаяХарактеристика);

    СтрокаЦен = ОбработкаТабличныхЧастей.НайтиСтрокуТабЧасти(ТаблицаПоЦенам, СтруктураПоискаЦены);
    Если СтрокаЦен <> Неопределено Тогда
    СтрокаТаблицы.СуммаПродажная = СтрокаЦен.Цена * СтрокаТаблицы[ИмяКолонкиКоличество];
    КонецЕсли;
    Иначе
    СтрокаТаблицы.СуммаПродажная = СтрокаЦен.Цена * СтрокаТаблицы[ИмяКолонкиКоличество];
    КонецЕсли;
    Иначе
    СтрокаЦен = ОбработкаТабличныхЧастей.НайтиСтрокуТабЧасти(ТаблицаПоЦенам, СтруктураПоискаЦены);
    Если СтрокаЦен <> Неопределено Тогда
    СтрокаТаблицы.СуммаПродажная = СтрокаЦен.Цена * СтрокаТаблицы[ИмяКолонкиКоличество];
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;

    КонецПроцедуры // ЗаполнитьКолонкуСуммаПродажная()
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    9.128
    Симпатии:
    953
    Баллы:
    204
    В какой строке появляется ошибка?
  3. TopicStarter Overlay
    Екатерина92
    Offline

    Екатерина92

    Регистрация:
    30 янв 2017
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    СтрокаТаблицы.СуммаПродажная = СтрокаЦен.Цена * СтрокаТаблицы[ИмяКолонкиКоличество];
  4. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    9.128
    Симпатии:
    953
    Баллы:
    204
    Выясните с помощью отладчика, какое из переменных имеет не числовое значение.
  5. TopicStarter Overlay
    Екатерина92
    Offline

    Екатерина92

    Регистрация:
    30 янв 2017
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Подскажите пожалуйста как это можно выяснить.
  6. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    9.128
    Симпатии:
    953
    Баллы:
    204
    С помощью "Вычислить выражение" - F9.
    Судя по вопросам, это вам мало что даст.
    Пригласите специалиста.
  7. TopicStarter Overlay
    Екатерина92
    Offline

    Екатерина92

    Регистрация:
    30 янв 2017
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Строка Таблицы[Имя Колонки Количество] NULL
  8. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    9.128
    Симпатии:
    953
    Баллы:
    204
    Теперь нужно понять, почему так происходит и что нужно сделать, чтобы было не NULL.
  9. TopicStarter Overlay
    Екатерина92
    Offline

    Екатерина92

    Регистрация:
    30 янв 2017
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Выяснила в чем была проблема. В номенклатуре не был заполнен реквизит ед. хранение остатков.

Поделиться этой страницей