8.х Преобразование к типу число не может быть выполнено

Тема в разделе "Установка платформы "1С:Предприятие 8"", создана пользователем Екатерина92, 25 мар 2017.

  1. TopicStarter Overlay
    Екатерина92
    Offline

    Екатерина92

    Регистрация:
    30 янв 2017
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Процедура ЗаполнитьКолонкуСуммаПродажная(ТаблицаТоваров, ТаблицаПоЦенам, ИмяКолонкиВидСклада = Неопределено, ИмяКолонкиКоличество = "Количество") Экспорт

    ЕстьХарактеристика = (ТаблицаТоваров.Колонки.Найти("ХарактеристикаНоменклатуры") <> Неопределено);

    СтруктураПоискаЦены = Новый Структура;
    ПустаяХарактеристика = Справочники.ХарактеристикиНоменклатуры.ПустаяСсылка();
    ВидСкладаРозничный = Перечисления.ВидыСкладов.Розничный;

    Для Каждого СтрокаТаблицы Из ТаблицаТоваров Цикл
    Если ИмяКолонкиВидСклада = Неопределено
    Или СтрокаТаблицы[ИмяКолонкиВидСклада] = ВидСкладаРозничный Тогда
    СтруктураПоискаЦены.Вставить("Склад", СтрокаТаблицы.Склад);
    СтруктураПоискаЦены.Вставить("Номенклатура", СтрокаТаблицы.Номенклатура);

    Если ЕстьХарактеристика Тогда
    СтруктураПоискаЦены.Вставить("ХарактеристикаНоменклатуры", СтрокаТаблицы.ХарактеристикаНоменклатуры);

    СтрокаЦен = ОбработкаТабличныхЧастей.НайтиСтрокуТабЧасти(ТаблицаПоЦенам, СтруктураПоискаЦены);
    Если СтрокаЦен = Неопределено Тогда
    СтруктураПоискаЦены.Вставить("ХарактеристикаНоменклатуры", ПустаяХарактеристика);

    СтрокаЦен = ОбработкаТабличныхЧастей.НайтиСтрокуТабЧасти(ТаблицаПоЦенам, СтруктураПоискаЦены);
    Если СтрокаЦен <> Неопределено Тогда
    СтрокаТаблицы.СуммаПродажная = СтрокаЦен.Цена * СтрокаТаблицы[ИмяКолонкиКоличество];
    КонецЕсли;
    Иначе
    СтрокаТаблицы.СуммаПродажная = СтрокаЦен.Цена * СтрокаТаблицы[ИмяКолонкиКоличество];
    КонецЕсли;
    Иначе
    СтрокаЦен = ОбработкаТабличныхЧастей.НайтиСтрокуТабЧасти(ТаблицаПоЦенам, СтруктураПоискаЦены);
    Если СтрокаЦен <> Неопределено Тогда
    СтрокаТаблицы.СуммаПродажная = СтрокаЦен.Цена * СтрокаТаблицы[ИмяКолонкиКоличество];
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;

    КонецПроцедуры // ЗаполнитьКолонкуСуммаПродажная()

Поделиться этой страницей