8.х Права пользователей

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Alla, 8 янв 2008.

  1. TopicStarter Overlay
    Alla
    Offline

    Alla Опытный в 1С

    Регистрация:
    28 дек 2007
    Сообщения:
    150
    Симпатии:
    0
    Баллы:
    26
    Подскажите, пожалуйста, как сделать так, чтобы пользователь видел события, связанные только со своими контрагентами и не видел события других пользоватлей?
  2. Coder1C
    Offline

    Coder1C Слуга форума Команда форума Администратор

    Регистрация:
    10 фев 2006
    Сообщения:
    506
    Симпатии:
    31
    Баллы:
    54

    Что значит СВОИХ?
    Каким образом у Вас контрагенты закреплены за пользователями?
    Какая конфигурация?
  3. Coder1C
    Offline

    Coder1C Слуга форума Команда форума Администратор

    Регистрация:
    10 фев 2006
    Сообщения:
    506
    Симпатии:
    31
    Баллы:
    54
    Если у Вас У.Т. 10.2 и Вы в определении владельца контрагента ориентируетесь на основного менеджера в карточке контрагента.

    Решение:

    Код:
    Процедура ПанельПриСменеСтраницы(Элемент, ТекущаяСтраница)
    // Вставить содержимое обработчика.
    Если Элемент.Страницы.Получить(ТекущаяСтраница).Имя = "События" И Покупатель = Истина Тогда
    Если СокрЛП(глТекущийПользователь) <> СокрЛП(ОсновнойМенеджерПокупателя) Тогда
    ЭлементыФормы.События.Видимость = Ложь;
    КонецЕсли;
    КонецЕсли;    
    КонецПроцедуры
    
    

    Картинка 1 - чужой пользователь:
    Картинка 2 - свой пользователь:

    Вложения:

    • 1.gif
      1.gif
      Размер файла:
      11,9 КБ
      Просмотров:
      58
    • 2.gif
      2.gif
      Размер файла:
      16,5 КБ
      Просмотров:
      61

Поделиться этой страницей