8.х УТ Прайс с картинками

Тема в разделе ""1С:Управление торговлей УТ"", создана пользователем VIPOS, 24 июл 2015.

  1. TopicStarter Overlay
    VIPOS
    Offline

    VIPOS Опытный в 1С

    Регистрация:
    12 сен 2012
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    29
    Друзья, подскажите в чем проблема, делаю прайс лист с изображениями
    Код:
        ТабДок = Новый ТабличныйДокумент;
        Макет = ПолучитьМакет("Макет");
        Область = Макет.ПолучитьОбласть("Заголовок");
        ТабДок.Вывести(Область);
        Область = Макет.ПолучитьОбласть("Шапка");
        ТабДок.Вывести(Область);
        Выборка = Справочники.Номенклатура.ВыбратьИерархически();
        Группа = Макет.ПолучитьОбласть("Группа");
        Элемент =Макет.ПолучитьОбласть("Элемент");
        Элемент1 =Макет.ПолучитьОбласть("Элемент1");
        Карт2 = Элемент.Рисунки.D2;
        Пока Выборка.Следующий() Цикл
            Если Выборка.ЭтоГруппа Тогда
                Группа.Параметры.Заполнить(Выборка);
                ТабДок.Вывести(Группа);
            Иначе
                Карт = Выборка.ОсновноеИзображение.Хранилище.Получить();
                Если Не Карт = Неопределено Тогда
                    Обл = Элемент;
                    Элемент.Рисунки.D2.Картинка = Карт;
                иначе
                    Обл = Элемент1;
            КонецЕсли;
            Обл.Параметры.Заполнить(Выборка);
            ТабДок.Вывести(Обл);
        КонецЕсли;
    КонецЦикла;
    ТабДок.ОтображатьСетку = ложь;
    ТабДок.Защита = Ложь;
    ТабДок.ТолькоПросмотр = ложь;
    ТабДок.ОтображатьЗаголовки = ложь;
    ТабДок.Показать()
    Вся инфа выводиться, но без картинки
    Что тут не так???
    УТ ред. 10.3, Платформа 8.1
  2. TopicStarter Overlay
    VIPOS
    Offline

    VIPOS Опытный в 1С

    Регистрация:
    12 сен 2012
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    29
    люди, хелпните плиз
  3. TopicStarter Overlay
    VIPOS
    Offline

    VIPOS Опытный в 1С

    Регистрация:
    12 сен 2012
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    29
    спасибо=) вопрос решил=)

Поделиться этой страницей