7.7 Прайс-лист

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем alex777, 6 ноя 2009.

  1. TopicStarter Overlay
    alex777
    Offline

    alex777

    Регистрация:
    2 ноя 2009
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Добрый день, помогите разобраться с внешней формой прайс листа с остатками, в торговли работаеть все хорошо а в комплесной пишить "Заданным условиям фильтра не удовлетворяет ни одна позиция номенклатуры" когда выбираешь прайс с остатками.

    Код:
    <pre><FONT COLOR="blue"><FONT FACE="Courier"><span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> ВыбФирмы[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> ВыбСклады[color=red];[/color] 
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> ТекСтрокаВТаблице[color=red];[/color] [color=green]// текущая строка в таблице значений  МФ[/color]
    
    [color=green]// используются для стандартного механизма кнопок "Обновить" и "Настройка"[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> ИсхТабл[color=red];[/color]		
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> Обновить[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> Расшифровка[color=red];[/color] 
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> ТипЦены[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ФормПарПечШапки[color=red]([/color]Фирма[color=red],[/color]Параметры[color=red])[/color]
    
    Параметры 	[color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"СписокЗначений"[/color][color=red])[/color][color=red];[/color]
    
    [color=green]// поставщик (контрагент)[/color]
    
    Банк [color=red]=[/color] [color=black]""[/color][color=red];[/color]НомерСчета [color=red]=[/color] [color=black]""[/color][color=red];[/color]БИКБанка [color=red]=[/color] [color=black]""[/color][color=red];[/color]СчетБанка [color=red]=[/color] [color=black]""[/color][color=red];[/color]
    глПлатежныеРеквизиты[color=red]([/color]Фирма[color=red].[/color]ОсновнойСчет[color=red],[/color] [color=red],[/color] Банк[color=red],[/color] НомерСчета[color=red],[/color] БИКБанка[color=red],[/color] СчетБанка[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> [color=red]([/color]ПустоеЗначение[color=red]([/color]НомерСчета[color=red])[/color] [color=red]=[/color] [color=black]1[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/или')">ИЛИ</span> [color=red]([/color]ПустоеЗначение[color=red]([/color]Банк[color=red])[/color] [color=red]=[/color] [color=black]1[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ПоставщикРеквизиты [color=red]=[/color] [color=black]""[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    ПоставщикРеквизиты	[color=red]=[/color] [color=black]"р/с "[/color] [color=red]+[/color] НомерСчета [color=red]+[/color] [color=black]" в "[/color] [color=red]+[/color] Банк [color=red]+[/color] 
    [color=red]?[/color][color=red]([/color]ПустоеЗначение[color=red]([/color]БИКБанка[color=red])[/color] [color=red]=[/color] [color=black]0[/color][color=red],[/color] [color=black]" ,БИК "[/color] [color=red]+[/color] БИКБанка[color=red],[/color] [color=black]""[/color][color=red])[/color] [color=red]+[/color]
    [color=red]?[/color][color=red]([/color]ПустоеЗначение[color=red]([/color]СчетБанка[color=red])[/color] [color=red]=[/color] [color=black]0[/color][color=red],[/color] [color=black]" ,корр/с "[/color] [color=red]+[/color] СчетБанка[color=red],[/color] [color=black]""[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    ЮрЛицо [color=red]=[/color] Фирма[color=red].[/color]ЮрЛицо[color=red];[/color]
    
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color]СокрЛП[color=red]([/color]ЮрЛицо[color=red].[/color]ПолнНаименование[color=red])[/color] [color=red]+[/color] [color=red]?[/color][color=red]([/color]ПустоеЗначение[color=red]([/color]ЮрЛицо[color=red].[/color]ИНН[color=red])[/color][color=red]=[/color][color=black]0[/color][color=red],[/color] [color=black]", ИНН "[/color] [color=red]+[/color] СокрЛП[color=red]([/color]ЮрЛицо[color=red].[/color]ИНН[color=red])[/color][color=red],[/color] [color=black]""[/color][color=red])[/color][color=red],[/color]
    [color=black]"ПоставщикНаименование"[/color][color=red])[/color][color=red];[/color]
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color]глПредставлениеАдреса[color=red]([/color]ЮрЛицо[color=red].[/color]ФактАдрес[color=red])[/color][color=red],[/color] [color=black]"ПоставщикАдрес"[/color][color=red])[/color][color=red];[/color]
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color]СокрЛП[color=red]([/color]ЮрЛицо[color=red].[/color]Телефоны[color=red])[/color]				[color=red],[/color] [color=black]"ПоставщикТелефоны"[/color][color=red])[/color][color=red];[/color]
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color]ПоставщикРеквизиты					[color=red],[/color] [color=black]"ПоставщикРеквизиты"[/color][color=red])[/color][color=red];[/color]
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color]СокрЛП[color=red]([/color]ЮрЛицо[color=red].[/color]ОКПО[color=red])[/color]					[color=red],[/color] [color=black]"ПоставщикОКПО"[/color][color=red])[/color][color=red];[/color]  
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span>
    [color=green]//******************************************************************************[/color]
    [color=green]// ВыбратьПоФильтру()[/color]
    [color=green]//[/color]
    [color=green]// Параметры:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//  Открывает обработку отбора элементов по произвольному фильтру[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ВыбратьПоФильтру[color=red]([/color][color=red])[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span>  ВидЗначенияПодбора[color=red];[/color]
    
    ВидЗначенияПодбора[color=red]=[/color]СокрЛП[color=red]([/color]ТаблицаМФ[color=red].[/color]Вид[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ПустоеЗначение[color=red]([/color]ВидЗначенияПодбора[color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">		Возврат</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    СписокПараметров[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"СписокЗначений"[/color][color=red])[/color][color=red];[/color]
    СписокПараметров[color=red].[/color]ДобавитьЗначение[color=red]([/color][color=black]""[/color][color=red],[/color]                [color=black]"ИмяВызвавшейФормы"[/color][color=red])[/color][color=red];[/color]
    СписокПараметров[color=red].[/color]ДобавитьЗначение[color=red]([/color]ТаблицаМФ[color=red].[/color]Тип[color=red],[/color]     [color=black]"Тип"[/color][color=red])[/color][color=red];[/color]
    СписокПараметров[color=red].[/color]ДобавитьЗначение[color=red]([/color]ВидЗначенияПодбора[color=red],[/color][color=black]"Вид"[/color][color=red])[/color][color=red];[/color]
    СписокПараметров[color=red].[/color]ДобавитьЗначение[color=red]([/color]СписокЭлементовМФ[color=red],[/color] [color=black]"Объекты"[/color][color=red])[/color][color=red];[/color]
    ТаблицаМФ[color=red].[/color]ФлВкл[color=red]=[/color][color=black]2[/color][color=red];[/color]
    ОткрытьФорму[color=red]([/color][color=black]"Обработка.ПодборОбъектов#"[/color][color=red],[/color]СписокПараметров[color=red])[/color][color=red];[/color]
    
    КонецПроцедуры	[color=green]// ВыбратьПоФильтру[/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// ПерерисовкаНазванийЗакладок[/color]
    [color=green]//[/color]
    [color=green]// Параметры:[/color]
    [color=green]// 	Нет[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//  Добавляет "(!)" в заголовок закладки с множественным фильтром, когда этот фильтр задан[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/функция')">Функция</span> ПерерисовкаНазванийЗакладок[color=red]([/color][color=red])[/color]      
    
    Врем [color=red]=[/color] Форма[color=red].[/color]Закладки[color=red].[/color]ПолучитьЗначение[color=red]([/color][color=black]2[/color][color=red])[/color][color=red];[/color]
    Форма[color=red].[/color]Закладки[color=red].[/color]УстановитьЗначение[color=red]([/color][color=black]2[/color][color=red],[/color] Врем[color=red],[/color][color=red]?[/color][color=red]([/color]глМножественныйФильтрЗадан[color=red]([/color]ТаблицаМФ[color=red])[/color][color=red]=[/color][color=black]1[/color][color=red],[/color][color=black]"(!) "[/color][color=red],[/color][color=black]""[/color][color=red])[/color][color=red]+[/color][color=black]"Множественный фильтр"[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецфункции')">КонецФункции</span> [color=green]// ПерерисовкаНазванийЗакладок	[/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// СформироватьСписокПомеченных()[/color]
    [color=green]//[/color]
    [color=green]// Параметры: [/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение:[/color]
    [color=green]//  Список значений, состоящий из помеченных значений из списка значений ТипыЦен[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//  Формирует список значений, состоящий только из помеченных значений из списка[/color]
    [color=green]//  значений ТипыЦен.[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/функция')">Функция</span> СформироватьСписокПомеченных[color=red]([/color][color=red])[/color]
    
    РезСписок [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"СписокЗначений"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/для')">	Для</span> Счетчик [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/по')">По</span> ТипыЦен[color=red].[/color]РазмерСписка[color=red]([/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ТипыЦен[color=red].[/color]Пометка[color=red]([/color]Счетчик[color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    РезСписок[color=red].[/color]ДобавитьЗначение[color=red]([/color]ТипыЦен[color=red].[/color]ПолучитьЗначение[color=red]([/color]Счетчик[color=red])[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">	КонецЦикла</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">	Возврат</span> РезСписок[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецфункции')">КонецФункции</span> [color=green]// СформироватьСписокПомеченных()[/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// ОбработкаСпискаТиповЦен(Пометки)[/color]
    [color=green]//[/color]
    [color=green]// Параметры: [/color]
    [color=green]//  ВклТипы - список значений, содержащий типы цен, которые нужно пометить.[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//  Зполняет из справочника ТипыЦен список значений ТипыЦен и устанавливает[/color]
    [color=green]//  пометки у тех типов, которые находятся в списке значений ВклТипы.[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ОбработкаСпискаТиповЦен[color=red]([/color]ВклТипы[color=red])[/color]
    
    [color=green]// очистим список[/color]
    ТипыЦен[color=red].[/color]УдалитьВсе[color=red]([/color][color=red])[/color][color=red];[/color]
    
    [color=green]// перезаполним список из справочника[/color]
    СпрТипыЦен [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"Справочник.ТипыЦен"[/color][color=red])[/color][color=red];[/color]
    СпрТипыЦен[color=red].[/color]ВыбратьЭлементы[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">	Пока</span> СпрТипыЦен[color=red].[/color]ПолучитьЭлемент[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    ТипыЦен[color=red].[/color]ДобавитьЗначение[color=red]([/color]СпрТипыЦен[color=red].[/color]ТекущийЭлемент[color=red]([/color][color=red])[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">	КонецЦикла</span>[color=red];[/color]
    
    [color=green]// проставим пометки[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/для')">	Для</span> Счетчик [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/по')">По</span> ВклТипы[color=red].[/color]РазмерСписка[color=red]([/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    Поз [color=red]=[/color] ТипыЦен[color=red].[/color]НайтиЗначение[color=red]([/color]ВклТипы[color=red].[/color]ПолучитьЗначение[color=red]([/color]Счетчик[color=red])[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Поз [color=red]>[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТипыЦен[color=red].[/color]Пометка[color=red]([/color]Поз[color=red],[/color] [color=black]1[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">	КонецЦикла</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// ОбработкаСпискаТиповЦен()[/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// УправлениеДиалогом()[/color]
    [color=green]//[/color]
    [color=green]// Параметры:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Вызывается из формул диалога:[/color]
    [color=green]//  Флаг "ПоНаличию", переключатель "ВидРазделителя"[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//  Управление видимостью и доступностью элементов форм[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> УправлениеДиалогом[color=red]([/color][color=red])[/color]
    
    ТекСтрока [color=red]=[/color] Форма[color=red].[/color]Закладки[color=red].[/color]ТекущаяСтрока[color=red]([/color][color=red])[/color][color=red];[/color] 
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ТекСтрока [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ПустоеЗначение[color=red]([/color]ВидРазделителя1[color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ВидРазделителя1 [color=red]=[/color][color=black]1[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    Форма[color=red].[/color]ИспользоватьСлой[color=red]([/color]Форма[color=red].[/color]Закладки[color=red].[/color]ПолучитьЗначение[color=red]([/color]ТекСтрока[color=red])[/color] [color=red]+[/color] 
    [color=red]?[/color][color=red]([/color]ВидРазделителя1 [color=red]>[/color] [color=black]1[/color][color=red],[/color] [color=black]",Разделитель"[/color][color=red]+[/color]СокрЛП[color=red]([/color]ВидРазделителя1 [color=red]-[/color] [color=black]1[/color][color=red])[/color][color=red],[/color][color=black]""[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ПоНаличию [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    [color=green]// все связанное с фирмами недоступно[/color]
    Форма[color=red].[/color]ВидРазделителя1[color=red].[/color]Доступность[color=red]([/color][color=black]0[/color][color=red])[/color][color=red];[/color]
    Форма[color=red].[/color]ВидРазделителя2[color=red].[/color]Доступность[color=red]([/color][color=black]0[/color][color=red])[/color][color=red];[/color]
    Форма[color=red].[/color]ВидРазделителя3[color=red].[/color]Доступность[color=red]([/color][color=black]0[/color][color=red])[/color][color=red];[/color]		
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">		Иначе</span>
    Форма[color=red].[/color]ВидРазделителя1[color=red].[/color]Доступность[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    Форма[color=red].[/color]ВидРазделителя2[color=red].[/color]Доступность[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    Форма[color=red].[/color]ВидРазделителя3[color=red].[/color]Доступность[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]		
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>     
    Форма[color=red].[/color]ИспользоватьСлой[color=red]([/color]Форма[color=red].[/color]Закладки[color=red].[/color]ПолучитьЗначение[color=red]([/color]ТекСтрока[color=red])[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// УправлениеДиалогом()[/color]
    
    [color=green]//******************************************************************************[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> Сформировать[color=red]([/color][color=red])[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> Запрос[color=red],[/color] ТекстЗапроса[color=red],[/color] Таб[color=red];[/color] 
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> ПарамШапки[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> ПеачтьСкидка[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> н[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> глПроверкаДаты[color=red]([/color]ДатаОтчета[color=red],[/color]ДатаОтчета[color=red])[/color][color=red]=[/color][color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">		Возврат</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    [color=green]// хоть одна цена в списке цен должна быть выбрана[/color]
    ЕстьПомеченые	[color=red]=[/color] [color=black]0[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/для')">	Для</span> СчетчикЦикла [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/по')">По</span> ТипыЦен[color=red].[/color]РазмерСписка[color=red]([/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ТипыЦен[color=red].[/color]Пометка[color=red]([/color]СчетчикЦикла[color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ЕстьПомеченые	[color=red]=[/color] [color=black]1[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/прервать')">			Прервать</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">	КонецЦикла</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ЕстьПомеченые [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/предупреждение')">Предупреждение</span>[color=red]([/color][color=black]"Не выбрано ни одного типа цены"[/color][color=red],[/color] [color=black]60[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">		Возврат</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color] 
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ПустоеЗначение[color=red]([/color]ВыбСкидки[color=red])[/color][color=red]=[/color][color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Скидка[color=red]=[/color]ВыбСкидки[color=red].[/color]Процент[color=red];[/color]
    ПечатьСкидка[color=red]=[/color][color=red]?[/color][color=red]([/color]ВыбСкидки[color=red].[/color]Процент[color=red]<[/color][color=black]0[/color][color=red],[/color]ВыбСкидки[color=red].[/color]Процент[color=red]*[/color][color=red]([/color][color=red]-[/color][color=black]1[/color][color=red])[/color][color=red],[/color]ВыбСкидки[color=red].[/color]Процент[color=red]*[/color][color=red]([/color][color=red]-[/color][color=black]1[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    Скидка[color=red]=[/color][color=black]0[/color][color=red];[/color]
    ПечатьСкидка[color=red]=[/color][color=black]""[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color] 
    
    глПриСменеСтрокиТаблицыМФ[color=red]([/color][color=black]1[/color][color=red],[/color]ТекСтрокаВТаблице[color=red],[/color]Контекст[color=red])[/color][color=red];[/color] [color=green]// записываем изменения если они были[/color]
    
    ФормПарПечШапки[color=red]([/color]ВыбФирмы[color=red],[/color] ПарамШапки[color=red])[/color][color=red];[/color]
    [color=green]// собственная фирма[/color]
    ПоставщикНаименование	[color=red]=[/color] ПарамШапки[color=red].[/color]Получить[color=red]([/color][color=black]"ПоставщикНаименование"[/color][color=red])[/color][color=red];[/color]
    ПоставщикАдрес			[color=red]=[/color] ПарамШапки[color=red].[/color]Получить[color=red]([/color][color=black]"ПоставщикАдрес"[/color][color=red])[/color][color=red];[/color]
    ПоставщикТелефоны		[color=red]=[/color] ПарамШапки[color=red].[/color]Получить[color=red]([/color][color=black]"ПоставщикТелефоны"[/color][color=red])[/color][color=red];[/color]
    ПоставщикРеквизиты		[color=red]=[/color] ПарамШапки[color=red].[/color]Получить[color=red]([/color][color=black]"ПоставщикРеквизиты"[/color][color=red])[/color][color=red];[/color]
    ПоставщикОКПО			[color=red]=[/color] ПарамШапки[color=red].[/color]Получить[color=red]([/color][color=black]"ПоставщикОКПО"[/color][color=red])[/color][color=red];[/color]
    
    ПоставщикКратко		[color=red]=[/color] ПоставщикНаименование [color=red]+[/color] 
    [color=red]?[/color][color=red]([/color]ПустоеЗначение[color=red]([/color]ПоставщикАдрес[color=red])[/color] [color=red]=[/color] [color=black]0[/color][color=red],[/color] [color=black]", "[/color] [color=red]+[/color] ПоставщикАдрес[color=red],[/color] [color=black]""[/color][color=red])[/color][color=red];[/color]
    ПоставщикПолностью	[color=red]=[/color] ПоставщикКратко [color=red]+[/color]
    [color=green]//	?(ПустоеЗначение(ПоставщикТелефоны) = 0, ", " + ПоставщикТелефоны, "") +[/color]
    [color=red]?[/color][color=red]([/color]ПустоеЗначение[color=red]([/color]ПоставщикРеквизиты[color=red])[/color] [color=red]=[/color] [color=black]0[/color][color=red],[/color] [color=black]", "[/color] [color=red]+[/color] ПоставщикРеквизиты[color=red],[/color] [color=black]""[/color][color=red])[/color][color=red];[/color]
    Тел [color=red]=[/color][color=red]?[/color][color=red]([/color]ПустоеЗначение[color=red]([/color]ПоставщикТелефоны[color=red])[/color] [color=red]=[/color] [color=black]0[/color][color=red],[/color][color=black]"Телефон: "[/color][color=red]+[/color] ПоставщикТелефоны[color=red],[/color] [color=black]""[/color][color=red])[/color][color=red];[/color]						
    [color=green]// Подготовка к заполнению выходных форм данными запроса[/color]
    ИсхТабл [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"Таблица"[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]ИсходнаяТаблица[color=red]([/color][color=black]"Сформировать"[/color][color=red])[/color][color=red];[/color]
    
    Состояние[color=red]([/color][color=black]"Заполнение выходной таблицы..."[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]Опции[color=red]([/color][color=black]0[/color][color=red],[/color] [color=black]0[/color][color=red],[/color] ИсхТабл[color=red].[/color]ВысотаТаблицы[color=red]([/color][color=red])[/color][color=red],[/color] [color=black]0[/color][color=red])[/color][color=red];[/color]
    [color=green]// Заполнение полей "Заголовок"[/color]
    ИсхТабл[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Шапка|Название"[/color][color=red])[/color][color=red];[/color]
    
    [color=green]// Присоединим заголовку названия цен[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/для')">	Для</span> Счетчик[color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/по')">По</span> ТипыЦен[color=red].[/color]РазмерСписка[color=red]([/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ТипыЦен[color=red].[/color]Пометка[color=red]([/color]Счетчик[color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТекТипЦены	[color=red]=[/color] ТипыЦен[color=red].[/color]ПолучитьЗначение[color=red]([/color]Счетчик[color=red])[/color][color=red];[/color]
    ШапкаЦены	[color=red]=[/color] СокрЛП[color=red]([/color]ТекТипЦены[color=red].[/color]Наименование[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">			Если</span> ТекТипЦены[color=red].[/color]Рассчитывается [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ОсновнойТип [color=red]=[/color] ТекТипЦены[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">			Иначе</span>
    ОсновнойТип [color=red]=[/color] ТекТипЦены[color=red].[/color]БазовыйТипЦен[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">			КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">			Если</span> ОсновнойТип[color=red].[/color]ЦенаВклНДС [color=red]=[/color] ОсновнойТип[color=red].[/color]ЦенаВклНП <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> ОсновнойТип[color=red].[/color]ЦенаВклНДС [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    НалогиЦены [color=red]=[/color] [color=black]"(включая НДС и НП)"[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">				Иначе</span>
    НалогиЦены [color=red]=[/color] [color=black]"(без учета НДС и НП)"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">			Иначе</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">				Если</span> ОсновнойТип[color=red].[/color]ЦенаВклНДС [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    НалогиЦены [color=red]=[/color] [color=black]"(включая НДС,"[/color] [color=red]+[/color] РазделительСтрок[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">				Иначе</span>
    НалогиЦены [color=red]=[/color] [color=black]"(без учета НДС,"[/color] [color=red]+[/color] РазделительСтрок[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">				КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">				Если</span> ОсновнойТип[color=red].[/color]ЦенаВклНП [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    НалогиЦены [color=red]=[/color] НалогиЦены [color=red]+[/color] [color=black]" включая НП)"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">				Иначе</span>
    НалогиЦены [color=red]=[/color] НалогиЦены [color=red]+[/color] [color=black]" без учета НП)"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">				КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">			КонецЕсли</span>[color=red];[/color]
    
    ИсхТабл[color=red].[/color]ПрисоединитьСекцию[color=red]([/color][color=black]"Шапка|Цена"[/color][color=red])[/color][color=red];[/color] 	
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">	КонецЦикла</span>[color=red];[/color] 	
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ПоНаличию [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span> [color=green]// поищем остатки в таблице[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ВидРазделителя1[color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ИсхТабл[color=red].[/color]ПрисоединитьСекцию[color=red]([/color][color=black]"Шапка|БазОстаток"[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]ПрисоединитьСекцию[color=red]([/color][color=black]"Шапка|ОснОстаток"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">		ИначеЕсли</span> ВидРазделителя1[color=red]=[/color][color=black]2[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ИсхТабл[color=red].[/color]ПрисоединитьСекцию[color=red]([/color][color=black]"Шапка|БазОстаток"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">		ИначеЕсли</span> ВидРазделителя1[color=red]=[/color][color=black]3[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ИсхТабл[color=red].[/color]ПрисоединитьСекцию[color=red]([/color][color=black]"Шапка|ОснОстаток"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    [color=green]//	[/color]
    [color=green]// текст запроса по выбранным ценам[/color]
    ТекстЗапроса [color=red]=[/color] [color=black]"//{{ЗАПРОС(ОтборЦен)[/color]
    [color=black]	|Период с ДатаОтчета по ДатаОтчета;[/color]
    [color=black]	|Номенклатура	= Справочник.Цены.Владелец;[/color]
    [color=black]	|Тип			= Справочник.Цены.ТипЦен;[/color]
    [color=black]	|Цена			= Справочник.Цены.Цена;[/color]
    [color=black]	|Единица		= Справочник.Цены.Единица;[/color]
    [color=black]	|Валюта			= Справочник.Цены.Валюта;[/color]
    [color=black]	|Функция ЦенаСумма	= Сумма(Цена);[/color]
    [color=black]	|Группировка Номенклатура Упорядочить по Номенклатура.Наименование;[/color]
    [color=black]	|Группировка Тип;[/color]
    [color=black]	|"[/color][color=green]//}}ЗАПРОС[/color]
    [color=brown];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ПоНаличию [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    
    ТекстЗапросаОстатков [color=red]=[/color] [color=black]"[/color]
    [color=black]		|Номенклатура	= Регистр.ОстаткиТМЦ.Номенклатура;[/color]
    [color=black]		|Количество		= Регистр.ОстаткиТМЦ.Количество;[/color]
    [color=black]		|[/color]
    [color=black]		|Функция КоличествоКонОст = КонОст(Количество);[/color]
    [color=black]		|[/color]
    [color=black]		|Группировка Номенклатура без групп;"[/color][color=red];[/color]
    
    ТекстЗапросаОстатков [color=red]=[/color] [color=black]"Фирма = Регистр.ОстаткиТМЦ.Фирма;"[/color] [color=red]+[/color] 
    ТекстЗапросаОстатков [color=red]+[/color]
    [color=black]"Условие(Фирма = ВыбФирмы);"[/color][color=red];[/color]
    
    ТекстЗапросаОстатков [color=red]=[/color] [color=black]"Скл = Регистр.ОстаткиТМЦ.Склад;"[/color] [color=red]+[/color] 
    ТекстЗапросаОстатков [color=red]+[/color]
    [color=black]"Условие(Скл = ВыбСклады);"[/color][color=red];[/color]
    
    
    ЗапросПоОстаткам [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"Запрос"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ЗапросПоОстаткам[color=red].[/color]<span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/выполнить')">Выполнить</span>[color=red]([/color]ТекстЗапросаОстатков[color=red])[/color] [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">			Возврат</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    СписокПоОстаткам [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"ТаблицаЗначений"[/color][color=red])[/color][color=red];[/color]
    ЗапросПоОстаткам[color=red].[/color]Выгрузить[color=red]([/color]СписокПоОстаткам[color=red])[/color][color=red];[/color]
    
    СписокНоменклатуры [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"СписокЗначений"[/color][color=red])[/color][color=red];[/color] 
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">		Пока</span> ЗапросПоОстаткам[color=red].[/color]Группировка[color=red]([/color][color=black]1[/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">			Если</span> ЗапросПоОстаткам[color=red].[/color]КоличествоКонОст [color=red]>[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СписокНоменклатуры[color=red].[/color]ДобавитьЗначение[color=red]([/color]ЗапросПоОстаткам[color=red].[/color]Номенклатура[color=red])[/color][color=red];[/color] 
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">			КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">		КонецЦикла</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> СписокНоменклатуры[color=red].[/color]РазмерСписка[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/предупреждение')">			Предупреждение</span>[color=red]([/color][color=black]"Заданным условиям фильтра не удовлетворяет ни одна позиция номенклатуры."[/color][color=red],[/color][color=black]60[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">			Возврат</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    ТекстЗапроса [color=red]=[/color] ТекстЗапроса [color=red]+[/color] [color=black]"Условие(Номенклатура в СписокНоменклатуры);"[/color]	
    
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]   [color=green]//ПоНаличию[/color]
    
    [color=green]// Добавим отбор по флагу включения в прайс	[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ВариантВключенияВпрайс [color=red]>[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>  
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ВариантВключенияВпрайс [color=red]=[/color] [color=black]2[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТекстЗапроса [color=red]=[/color] ТекстЗапроса [color=red]+[/color] [color=black]"Условие ( Номенклатура.НеВключатьВпрайс = 0);"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">		Иначе</span>
    ТекстЗапроса [color=red]=[/color] ТекстЗапроса [color=red]+[/color] [color=black]"Условие ( Номенклатура.НеВключатьВпрайс = 1);"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    НетОш [color=red]=[/color] [color=black]1[/color][color=red];[/color] [color=green]// нет ошибок при наложении фильтров[/color]
    НетОш [color=red]=[/color] НетОш [color=red]*[/color] глФильтрПоПеременнойЗапроса[color=red]([/color]ТаблицаМФ[color=red],[/color] [color=black]"Номенклатура"[/color][color=red],[/color] ВыбТМЦ[color=red],[/color] [color=black]"ВыбТМЦ"[/color][color=red],[/color] ТекстЗапроса[color=red],[/color] [color=red],[/color] [color=black]"СвойстваНоменклатуры"[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> НетОш [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">		Возврат</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    Запрос [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"Запрос"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> Запрос[color=red].[/color]<span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/выполнить')">Выполнить</span>[color=red]([/color]ТекстЗапроса[color=red])[/color] [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">		Возврат</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    ТаблицаЦен [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"ТаблицаЗначений"[/color][color=red])[/color][color=red];[/color]
    ТаблицаЦен[color=red].[/color]НоваяКолонка[color=red]([/color][color=black]"Тип"[/color][color=red])[/color][color=red];[/color]
    ТаблицаЦен[color=red].[/color]НоваяКолонка[color=red]([/color][color=black]"Цена"[/color][color=red])[/color][color=red];[/color]
    ТаблицаЦен[color=red].[/color]НоваяКолонка[color=red]([/color][color=black]"Единица"[/color][color=red])[/color][color=red];[/color]
    ТаблицаЦен[color=red].[/color]НоваяКолонка[color=red]([/color][color=black]"Валюта"[/color][color=red])[/color][color=red];[/color]
    
    ТекущаяГруппа[color=red]=[/color] ПолучитьПустоеЗначение[color=red]([/color][color=black]"Справочник.Номенклатура"[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">	Пока</span> Запрос[color=red].[/color]Группировка[color=red]([/color][color=black]"Номенклатура"[/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    ТекЭлем [color=red]=[/color] Запрос[color=red].[/color]Номенклатура[color=red];[/color]
    Уровень [color=red]=[/color] ТекЭлем[color=red].[/color]Уровень[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Уровень [color=red]>[/color] [color=black]4[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Уровень [color=red]=[/color] [color=black]4[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ТекЭлем[color=red].[/color]ЭтоГруппа[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    
    ТаблицаЦен[color=red].[/color]УдалитьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">			Пока</span> Запрос[color=red].[/color]Группировка[color=red]([/color][color=black]"Тип"[/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">				Если</span> Запрос[color=red].[/color]ЦенаСумма [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/продолжить')">					Продолжить</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">				КонецЕсли</span>[color=red];[/color]
    
    ТаблицаЦен[color=red].[/color]НоваяСтрока<span style=
  2. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    Оформляйте код программы с помощью тега
    Код:
     Подробно ознакомиться с тэгами и их использованием можно в редакторе текста. В редакторе сообщения можно выделить необходимый участок текста и нажать кнопку "#" для автоматического добавления тега [CODE] 
    
    И, вообще, зачем весь код-то выложил? Думаю, что посмотрят на него 1-2 человека. Я даже знаю кто, но не скажу. :)

Поделиться этой страницей