7.7 "Поступление товаров" из excel и "Отгрузка товаров" на его основании

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем turgor, 16 июн 2011.

  1. TopicStarter Overlay
    turgor
    Offline

    turgor

    Регистрация:
    1 июн 2011
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    Стоит задача по автоматизации учета товаров "фирмы-посредника." Большая номенклатура, фактуры на 100 позиций. Все что приходуется все в том же периоде отгружается. Поставщики предоставляют документы (накладные/фактуры) в excel. Задача:
    1) Автоматизировать заполнение документа "поступление товаров" из файла excel. Слышал что таким способом многие пользуются. Порекомендуйте пожалуйста подобную утилиту для 1с7.7 Бухгалтерия
    2) Хочу настроить заполнение документа "Отгрузка товаров" на основании "Поступление товаров". Насколько я понял из попавшего мне в руки мануала это не слишком сложно (2 этапа) , и можно справиться даже без соответствующей квалификации. Однако сам мануал был слишком короток. Порекомендуйте где бы прочесть об этом.
  2. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.175
    Симпатии:
    13
    Баллы:
    29
    по 1) найди любую обработку загрузки из экселядля 7.7...переделай под сво нужды.
    по 2) открываешь док поступления(в конфигураторе),Кнопочку ввод на основании....выбираешь свой документ Отгрузки....и в доке отгрузки ..в модуле формы прописываешь процедуру ВводНаОсновании(ДокументОснование)
  3. TopicStarter Overlay
    turgor
    Offline

    turgor

    Регистрация:
    1 июн 2011
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    по 1) где ее можно найти
    по 2) каким образом прописывать эту самую "процедуру". Где найти инструкцию? просто замечательно, если это будет готовый скрипт чтоб его скопипастить.
  4. volodya1122
    Offline

    volodya1122 Опытный в 1С

    Регистрация:
    25 фев 2011
    Сообщения:
    96
    Симпатии:
    1
    Баллы:
    26
  5. TopicStarter Overlay
    turgor
    Offline

    turgor

    Регистрация:
    1 июн 2011
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    Нашел инструкцию.
    Не могу понять как открыть в конфигураторе этот модуль форм документов. Где он там?
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Кнопка форма. Закладка модуль
  7. TopicStarter Overlay
    turgor
    Offline

    turgor

    Регистрация:
    1 июн 2011
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    открыл "расходнаянакладная" - метаданные формы документа. подскажите, куда именно вписывать код на странице. хочу сделать "ввод на основанни" для "поступление товара"- чтоб он формировался из "расходная накладная".
    Попытаюсь обойтись без привлечения "тяжелой артиллерии". По советам трудящихся, так сказать. Авось получится.
  8. TopicStarter Overlay
    turgor
    Offline

    turgor

    Регистрация:
    1 июн 2011
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    общий заголовок там
    ПРОЦЕДУРЫ И ФУНКЦИИ МОДУЛЯ
    и дальше по порядку всякие причудливые штуки. одна от другой отделяемые
    //****************************************
    туземная логика подсказывает мне что это содержание, где мне нужно найти нужную страницу и вписать туда код отделив его от остальных.
  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Я бы лучше вам посоветовал обратиться к специалисту за помошью. Ваших уровней познаний думаю хватит только на "убийство" базы.

    Надеюсь что вы все эксперименты делаете в копии
  10. TopicStarter Overlay
    turgor
    Offline

    turgor

    Регистрация:
    1 июн 2011
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    создал базу для экспериментов.
    нужно вставить кусок кода в нужное место и сохранить. насколько я понял после этого ввод на основании должен заработать. пытаюсь разобраться куда его вставить этот код.
  11. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В модуле: Меню-Действия-Процедуры и функции.
    Ищите процедуру.
  12. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    найди процедуру вводНаОсновании и добавь в условие строки по аналогии со счетом
  13. TopicStarter Overlay
    turgor
    Offline

    turgor

    Регистрация:
    1 июн 2011
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    итак, необходимо, чтобы на основании "расходнаянакладная" формировался "поступлениетоваров". открыл модуль формы документа "расходная накладная". захожу Действия - Процедуры и функции модуля, куда мне переходить в "вводнаосновании" или все же в "заполнитьнаосновании" переходить?
  14. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.175
    Симпатии:
    13
    Баллы:
    29
    ввод на основании
  15. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Помимо всего нужно в свойствах документа разрешить вводить на основании данный вид документа.
  16. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    >итак, необходимо, чтобы на основании "расходнаянакладная" формировался "поступлениетоваров".

    ты выражовывайся аккуратнее, ибо всё с точностью до наоборот
  17. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Это по правильному наоборот. А в жизни может так и нужно))))))))
  18. TopicStarter Overlay
    turgor
    Offline

    turgor

    Регистрация:
    1 июн 2011
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    уезжал на неделю...
    Да, это я сделал первым делом.

    вот что в разделе "ввод на основании":
    так вот, я должен вставить код между этими тегами, или вписывая свой код я должен их продублировать?
  19. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.175
    Симпатии:
    13
    Баллы:
    29
    Пиши свой код..заполняй новый документ данными из документа основания...
  20. TopicStarter Overlay
    turgor
    Offline

    turgor

    Регистрация:
    1 июн 2011
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    так должно выглядеть обрамление тегами?:

    Код:
    //*****************************************************************************
    // Предопределенная процедура
    //
    [b]Процедура ВводНаОсновании(ДокОсн)
    [/b]
    Новый = 1;
    ВерсияОбъекта = Константа.НомерРелиза;
    Если ДокОсн.Вид() = "Счет" Тогда
    РасчетныйСчет = ДокОсн.РасчетныйСчет;
    ВидОтгрузки = 11;
    ЗачитыватьАванс = 0;
    МестоХранения = глЗначениеПоУмолчанию("ОсновнойСклад");
    ТипЦен = ДокОсн.ТипЦен;
    Контрагент = ДокОсн.Контрагент;
    Если ПустоеЗначение(ДокОсн.Плательщик) = 0 Тогда
    Грузополучатель = ДокОсн.Плательщик;
    КонецЕсли;
    
    Договор = ДокОсн.Договор;
    Если Договор.ВалютаДоговора.Выбран() = 1 Тогда
    Курс = Договор.ВалютаДоговора.Курс.Получить(ДатаДок);
    КонецЕсли;
    
    ВариантРасчетаНалогов = ДокОсн.ВариантРасчетаНалогов;
    ДокОсн.ВыбратьСтроки();
    Пока ДокОсн.ПолучитьСтроку() = 1 Цикл
    НоваяСтрока();
    Товар = ДокОсн.Товар;
    Количество = ДокОсн.Количество;
    Цена = ДокОсн.Цена;
    Сумма = ДокОсн.Сумма;
    НДС = ДокОсн.НДС;
    НП = ДокОсн.НП;
    Всего = ДокОсн.Всего;
    КонецЦикла;
    КонецЕсли; 
    Комментарий = "Введен на основании: "+ГлПредставлениеДокумента(ДокОсн);
    [b]
    КонецПроцедуры // ВводНаОсновании()[/b]
    [b]Процедура ВводНаОсновании(ДокОсн) //предопределенная[/b]
    [i]Новый = 1;
    Если ДокОсн.Вид() = "РасходнаяНакладная" Тогда
    РасчетныйСчет = ДокОсн.РасчетныйСчет;
    Контрагент = ДокОсн.Контрагент;
    Договор = ДокОсн.Договор;
    Контрагент = ДокОсн.Контрагент;
    Если ПустоеЗначение(ДокОсн.Грузополучатель) = 0 Тогда
    Плательщик = ДокОсн.Грузополучатель;
    КонецЕсли;
    ВариантРасчетаНалогов = ДокОсн.ВариантРасчетаНалогов;
    ТипЦен = ДокОсн.ТипЦен;
    ДокОсн.ВыбратьСтроки();
    Пока ДокОсн.ПолучитьСтроку() = 1 Цикл
    НоваяСтрока();
    Товар = ДокОсн.Товар;
    Количество = ДокОсн.Количество;
    Цена = ДокОсн.Цена;
    Сумма = ДокОсн.Сумма;
    НДС = ДокОсн.НДС;
    НП = ДокОсн.НП;
    Всего = ДокОсн.Всего;
    КонецЦикла;
    КонецЕсли;
    ВариантОтправки = 1;
    Комментарий = "Введен на основании: "+ГлПредставлениеДокумента(ДокОсн);[/i]
    [b]КонецПроцедуры //ВводНаОсновании [/b]
    
    
    код который буду добавлю (с изменениями) выделил курсивом

Поделиться этой страницей