8.х построение отчетов

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем СанСанна, 19 апр 2010.

  1. TopicStarter Overlay
    СанСанна
    Offline

    СанСанна

    Регистрация:
    19 фев 2010
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    1. Через Построитель :
    Код:
    Построитель = Новый ПостроительОтчета;
    ДанныеИсточника = Новый ОписаниеИсточникаДанных(<Таблица значений>);
    Построитель.ИсточникДанных = ДанныеИсточника; 
    Построитель.ЗаполнитьНастройки();
    ТаблДок = ЭлементыФормы.ПолеТаблДок;
    ТаблДок.Очистить();
    Построитель.Выполнить();
    Построитель.Макет = Неопределено;
    МакетПост = Построитель.Макет;
    Для Каждого СледОбласть Из МакетПост.Области Цикл
    Если СледОбласть.Имя = "Заголовок" Тогда
    Продолжить;
    КонецЕсли; 
    СледОбласть.ШиринаКолонки = 15;
    Если СледОбласть.Имя = "Детали" Тогда
    СледОбласть.Формат = "ЧЦ=15;ЧДЦ=2";
    КонецЕсли; 
    КонецЦикла; 
    Построитель.Макет = МакетПост;
    Построитель.МакетОформления = ПолучитьМакетОформления(СтандартноеОформление.Классика2);
    Построитель.ОформитьМакет();
    Построитель.Вывести(ТаблДок);
    
    При любом значении СледОбласть.ШиринаКолонки ширина в полученом отчете будет = 9 (проверено отладчиком), что соответствует минимальной из всех колонок таблицы. Если эту ширину вообще не задавать, то получим ширину = 32, соответственно максимальной. Таблица получается выгрузкой из запроса, то бишь без описания типов колонок. Кто что может посоветывать ?
    2. А это вопрос по СКД : как можно задать в нём разделение страниц средствами самого СКД без ручной работы с полученным табличным документом ?
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    1. Смотрите, как в типовых сделано. Там вызывается процедура постобработки табличного документа
    2. Никак

Поделиться этой страницей