8.х ОБМЕН Посоветуйте как перенести контактную инфу у кoнтрагентoв

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем rusavus, 1 ноя 2013.

  1. TopicStarter Overlay
    rusavus
    Offline

    rusavus

    Регистрация:
    25 окт 2012
    Сообщения:
    38
    Симпатии:
    0
    Баллы:
    1
    Добрый день.
    Посоветуйте, как перенести юрид. и почтовый адрес, атакже номер телефона контрагента из Бухгалтерии 7.7 в УПП 8.2 с помощь правил конвертации?
  2. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    кроме ПКО для самого справочника Контрагенты делаете для каждого типа контактной информации ПКО, в котором источником будет Контрагент, а приемником - регистр сведений КонтактнаяИнформация, в обработчике ПослеВыгрузки ПКО справочника Контрагенты вызываете выгрузку источника по каждому из правил. Примерно так:
    Код:
    Если СокрЛП(Источник.Адрес)<>"" Тогда
    ВыгрузитьПоПравилу(Источник,,,,"КонтактнаяИнформацияЮридическийАдрес");
    КонецЕсли;
    Если СокрЛП(Источник.ФактАдрес)<>"" Тогда
    ВыгрузитьПоПравилу(Источник,,,,"КонтактнаяИнформацияФактАдрес");
    КонецЕсли;
    Если СокрЛП(Источник.Телефон)<>"" Тогда
    ВыгрузитьПоПравилу(Источник,,,,"КонтактнаяИнформацияТелефон");
    КонецЕсли;
    

Поделиться этой страницей