8.х После тестирования не работает база

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем kot488, 10 авг 2011.

  1. TopicStarter Overlay
    kot488
    Offline

    kot488 Опытный в 1С

    Регистрация:
    9 мар 2011
    Сообщения:
    393
    Симпатии:
    0
    Баллы:
    26
    Сделал тестирование и исправление базы с всеми галками теперь не зоходит в базу, пишет ошибку, подскажите что то а то с 1с слабо знаком програмера пока нет


    {ОбщийМодуль.ОбщегоНазначения.Модуль(5504,11)}: Переменная не определена (НоменклатураНов)
    Возврат <<?>>НоменклатураНов.ПолучитьНомерБезПрефиксовОбщий(Номер);



    Попытка
    Если ТипЗнч(Документ.Ссылка) = Тип("ДокументСсылка.НалоговаяНакладная") Тогда
    Возврат НоменклатураНов.ПолучитьНомерБезПрефиксовОбщий(Номер);
    КонецЕсли;
    Исключение
    КонецПопытки;

    Возврат Номер;
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Что за конфа то? Релиз? Платформа?
  3. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.581
    Симпатии:
    717
    Баллы:
    204
    сделай синтаксический контроль модулей.
    по данной строке - не определяется объект "НоменклатураНов", судял по коду - это либо общий модуль, либо экспортная процедура в модуле объкта, скорее всего, справочника "Номенклатура" или "НоменклатураНов" - более точно не подскажет никто, не видя конфигурацию
  4. TopicStarter Overlay
    kot488
    Offline

    kot488 Опытный в 1С

    Регистрация:
    9 мар 2011
    Сообщения:
    393
    Симпатии:
    0
    Баллы:
    26
    как всегда забыл написать :angry:

    УТП Украина 1.0.8.4
    Платформа 8.2.14

    а как его сделать, там номенклатура переписана, разных дополнений дописали
  5. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.581
    Симпатии:
    717
    Баллы:
    204
    Нужно понять, что за объект НомеклатураНов.

    Выполни поиск по всей конфе строки "ПолучитьНомерБезПрефиксовОбщий" - может узнаешь, где оно располагается.
  6. TopicStarter Overlay
    kot488
    Offline

    kot488 Опытный в 1С

    Регистрация:
    9 мар 2011
    Сообщения:
    393
    Симпатии:
    0
    Баллы:
    26

    запустил проверку модулей и сразу :angry: ошибка на ошибке
  7. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.581
    Симпатии:
    717
    Баллы:
    204
    такого быть не должно - как вариант похерились метаданные, по-просту говоря - конфигурация.
    Лично не сталкивался с таким явлением, помочь не могу.

    Если сделать выгрузку/загрузку конфигурации в/из файл(а) - все нормально?
    Если сделать выгрузку/загрузку базы в/из файл(а) - все нормально?

    Все манипуляции на копии делайте.
  8. TODD22
    Offline

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.759
    Симпатии:
    147
    Баллы:
    104
    Если база лежит на простом компе без RAID. Попробуйте протестируйте HDD на наличие ошибок.
  9. TopicStarter Overlay
    kot488
    Offline

    kot488 Опытный в 1С

    Регистрация:
    9 мар 2011
    Сообщения:
    393
    Симпатии:
    0
    Баллы:
    26

    про манипуляции на копии я уже давно в курсе, выгркузку загрузку делает норм, тестирование проводилось изза того что переходим на скуль, там ошибки были, утром запускал било ошибку, только про модули проверил, нашел как и говорилось модуль ПолучитьНомерБезПрефиксовОбщий нечего не меняя в конфиге она запускается без ошибок
  10. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.581
    Симпатии:
    717
    Баллы:
    204
    эээ...мож чего поменяли в конфигураторе между копией *.DT и моментом перезда в SQL- версию?
  11. TopicStarter Overlay
    kot488
    Offline

    kot488 Опытный в 1С

    Регистрация:
    9 мар 2011
    Сообщения:
    393
    Симпатии:
    0
    Баллы:
    26
    нечего не меняли ошибка выскакивала еще при CD файле, проверку делали изза того что при перебросе в скуль была ошибка типа одинаковый документ или что то такое
  12. TopicStarter Overlay
    kot488
    Offline

    kot488 Опытный в 1С

    Регистрация:
    9 мар 2011
    Сообщения:
    393
    Симпатии:
    0
    Баллы:
    26
    мля перекинул в скуль ошибка опять всплыла
  13. TopicStarter Overlay
    kot488
    Offline

    kot488 Опытный в 1С

    Регистрация:
    9 мар 2011
    Сообщения:
    393
    Симпатии:
    0
    Баллы:
    26

    насколько я понял это наш переделанный справочник номенклатуры
  14. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.581
    Симпатии:
    717
    Баллы:
    204
    а этот справочник вообще присутствует в конфигурации?
  15. TopicStarter Overlay
    kot488
    Offline

    kot488 Опытный в 1С

    Регистрация:
    9 мар 2011
    Сообщения:
    393
    Симпатии:
    0
    Баллы:
    26

    вообще справочни к называется номеклатура, там дописывались галочки может поетому и появилась привязка НОВ, убрал НОВ ошибка тоже есть но другая, по советам поискать куда веде текст

    ПолучитьНомерБезПрефиксовОбщий

    нашел вот этот моуль НоменклатураНов модуль

    Функция ПолучитьНомерБезПрефиксовОбщий(Номер) Экспорт

    лНомер = СокрЛП(Номер);
    НомерБезПрефиксов = "";
    Сч = СтрДлина(лНомер);
    СчетЯч = 0;
    Пока (Сч > 0) и (СчетЯч <= 5) Цикл

    Символ = Сред(лНомер, Сч, 1);

    Если (Символ >= "0" И Символ <= "9") Тогда

    НомерБезПрефиксов = Символ + НомерБезПрефиксов;

    Иначе

    Возврат УбратьНулиВНомере(НомерБезПрефиксов);

    КонецЕсли;

    Сч = Сч - 1;
    СчетЯч = СчетЯч + 1;
    КонецЦикла;

    Возврат УбратьНулиВНомере(НомерБезПрефиксов);

    КонецФункции


    насколько понял ругается в налоговой
  16. TopicStarter Overlay
    kot488
    Offline

    kot488 Опытный в 1С

    Регистрация:
    9 мар 2011
    Сообщения:
    393
    Симпатии:
    0
    Баллы:
    26
    убрал

    Попытка
    Если ТипЗнч(Документ.Ссылка) = Тип("ДокументСсылка.НалоговаяНакладная") Тогда
    Возврат НоменклатураНОВ.ПолучитьНомерБезПрефиксовОбщий(Номер);
    КонецЕсли;
    Исключение
    КонецПопытки;


    запускается норм

Поделиться этой страницей