8.х Помогите заполнить ТЧ формы 1С 8.2

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Дмитрий Игоревич, 3 июн 2013.

  1. TopicStarter Overlay
    Дмитрий Игоревич
    Offline

    Дмитрий Игоревич Опытный в 1С

    Регистрация:
    11 апр 2013
    Сообщения:
    152
    Симпатии:
    0
    Баллы:
    26

    Всем доброго времени суток, помогите решить кое-какую задачу.
    Мы имеем один справочник:

    ТорговоеОбороудование, у него есть следующие реквизиты:
    Имя
    Код
    Склад
    И Табличный часть с реквизитами:
    Полка (строка, 100 символом)
    Длина
    Ширина

    Далее мы имеем справочник Номенклатура у которого есть реквизит табличная часть со следующими реквизитами:
    ТорговоеОборудование (Тип - Справочники.ТорговоеОборудование)
    Полка
    Склад

    Задача в следующем:

    При выборе ТорговогоОборудование в таблице на форме справочника номенклатура, в поле выбора Полки необходимо подставить все значение из табличной части справочника ТорговоеОборудования.

    Вопрос 1, как это сделать, вопрос 2, какой тип реквизита должен быть у элемента полка(справочник Номенклатура).

    Делаю следующим образом - Не работает!


    Перем СписокПолок;


    Процедура ТЧТорговоеОборудованиеПолкаНачалоВыбора(Элемент, СтандартнаяОбработка)
    Элемент.СписокВыбора.ЗагрузитьЗначения(СписокПолок);
    КонецПроцедуры

    Процедура ТЧТорговоеОборудованиеТорговоеОборудованиеНачалоВыбора(Элемент, СтандартнаяОбработка)
    СпПк = Справочники.ТорговоеОборудование.НайтиПоНаименованию(Элемент);
    СписокПолок = СпПк.ТабличнаяЧасть.ВыгрузитьКолонку("Полка");
    КонецПроцедуры


    Реквизит полка(ТЧ спр Номенклатура) сейчас тип - строка.
  2. TopicStarter Overlay
    Дмитрий Игоревич
    Offline

    Дмитрий Игоревич Опытный в 1С

    Регистрация:
    11 апр 2013
    Сообщения:
    152
    Симпатии:
    0
    Баллы:
    26
    дело в шляпе вот так вот над было
    Код:
    Процедура ТЧТорговоеОборудованиеПолкаНачалоВыбораИзСписка(Элемент, СтандартнаяОбработка)
    Строка = ЭлементыФормы.ТЧТорговоеОборудование.ТекущаяСтрока;
    СпПк = Справочники.ТорговоеОборудование.НайтиПоНаименованию(Строка.ТорговоеОборудование);
    СписокПолок = СпПк.ТабличнаяЧасть.ВыгрузитьКолонку("Полка");
    Элемент.СписокВыбора.ЗагрузитьЗначения(СписокПолок);
    КонецПроцедуры
    

Поделиться этой страницей