7.7 Помогите убрать проводность в реализации

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем anton, 11 фев 2010.

  1. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    Ребята помогите убрать проводность! Просто при проведении документа проводность между счетами
    Дб 90.3 Кт 41.1 не нужна!!!

    Вложения:

  2. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    Парни ну что ни кто не подскажет что и где нужно закоментировать просто очень нужно!!!!
  3. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    а нужно ли действительно?? Если это разовый случай просто операцией или справкой сторно сделай
    тем не менее:
    Код:
    //Списание по договорам поставки
    //Принимаемые материалы (10.2)
    //Принимаемые товары (41.2)   
    //Товары на комиссии (004)
    //Принимаемые товары и материалы, переданные на комиссию (КМС.1)
    //Товары переданные на субкомиссию (КМС.2)
    Если (Номенклатура.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Товар) или
    (Номенклатура.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.ТоварНаКомиссии) или
    (Номенклатура.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Материал)Тогда
    
    НеобходимоСписатьКоличество = Количество;
    
    Если (НеобходимоСписатьКоличество > 0) и
    (Номенклатура.ТипНоменклатуры <> Перечисление.ТипыНоменклатуры.ТоварНаКомиссии) и
    (ЕНВД = 1) Тогда    
    Если (Номенклатура.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Товар) Тогда    
    СчетУч = Сч41_1;
    ИначеЕсли (Номенклатура.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Материал) Тогда    
    СчетУч = Сч10_1;
    КонецЕсли;
    БИ2.ПолучитьСчет(,СчетУч); 
    НетОстатков = 0;
    Если БИ2.ПолучитьСубконто(ВидыСубконто.Номенклатура,, Номенклатура) = 0 Тогда
    НетОстатков = 1;
    КонецЕсли;
    Если (НетОстатков = 0) И (БИ2.СКД("К") = 0) Тогда
    НетОстатков = 1;
    КонецЕсли;
    Если (ВидОтгрузки <> 2) и (НетОстатков = 0) Тогда
    
    КоличествоДляСписания    = Мин(НеобходимоСписатьКоличество, БИ2.СКД("К"));
    //**-**
    //Себестоимость            = БИ2.СКД("С")/БИ2.СКД("К")*КоличествоДляСписания;
    Себестоимость            = 0;
    //end
    Операция.НоваяПроводка();
    Операция.НомерЖурнала = "ТВ";
    Fl = 0;
    Если ((ВидОтгрузки = 0)или(ВидОтгрузки = 3)) Тогда
    Если (Номенклатура.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Материал) и (Использовать91 = 1) Тогда
    Операция.Дебет.Счет             = Сч91_3;                      
    Операция.Дебет.ПрочиеДоходыИРасходы = СтатьяПрочихДоходовИРасходов;
    Иначе
    Fl = 1;
    УдалитьПроводку();
    //Операция.Дебет.Счет = СчетПоКоду("90.3");
    //Операция.Дебет.Субконто(1, Номенклатура.ВидДеятельности);
    КонецЕсли;
    Иначе
    Операция.Дебет.Счет         = СчетПоКоду("45");
    Операция.Дебет.Номенклатура = Номенклатура;
    Операция.Дебет.Контрагенты    = Контрагент;
    Операция.Дебет.Договоры     = Договор;
    КонецЕсли;
    If Fl = 0 Then
    Операция.Кредит.Счет          = СчетУч;
    Операция.Кредит.Номенклатура = Номенклатура;
    Операция.Количество          = КоличествоДляСписания;
    Операция.Сумма                 = Себестоимость;
    Операция.СодержаниеПроводки  = "Списание МПЗ"; 
    НеобходимоСписатьКоличество = НеобходимоСписатьКоличество - КоличествоДляСписания;
    EndIf;
    КонецЕсли;
    КонецЕсли;    
    
    
    
    за последствия не ручаюсь :)
Похожие темы
  1. rom133
    Ответов:
    2
    Просмотров:
    1.635
  2. Schtass
    Ответов:
    2
    Просмотров:
    1.297
  3. anton
    Ответов:
    8
    Просмотров:
    816
  4. Mamont_SXI
    Ответов:
    1
    Просмотров:
    1.500
  5. sasha300
    Ответов:
    27
    Просмотров:
    4.121
Загрузка...

Поделиться этой страницей