8.х Помогите создать процедуру

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Panchos, 14 ноя 2006.

  1. TopicStarter Overlay
    Panchos
    Offline

    Panchos Опытный в 1С

    Регистрация:
    27 окт 2006
    Сообщения:
    101
    Симпатии:
    0
    Баллы:
    26
    Я в программировании 1с8.0 новичок,поэтому не судите строго.
    Написал процедуру, а она не пеашет. Помогите кто сможет. :unsure:

    Код:
    Процедура ПриЗаписи(Отказ)
    
    //проверим есть ли головной контрагент
    
    Если НеЭтаГруппа Тогда
    Если ЗначениеНеЗаполнено(ГоловнойКонтрагент) Тогда
    Если ЭтоНовый() Тогда
    СсылкаНового = Справочник.Контрагенты.ПолучитьСсылку();
    УстановитьСсылкуНового(Справочник);
    ГоловнойКонтрагент = СсылкаНового;
    Иначе
    ГоловнойКонтрагент = Ссылка;
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;    
    
    КонецПроцедуры
    
  2. Norseman
    Offline

    Norseman

    Регистрация:
    30 окт 2006
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Напиши лучше сначала по-русски, чего должна делать данная процедура, а там уже посмотрим что не так.
  3. Tiger
    Offline

    Tiger Опытный в 1С

    Регистрация:
    12 июл 2006
    Сообщения:
    489
    Симпатии:
    0
    Баллы:
    26
    Мне кажется здесь опечатка
    Если НеЭтаГруппа Тогда
    Если Не ЭтоГруппа Тогда

Поделиться этой страницей