8.х Помогите сконвертировать запрос из 7.7 в 8.

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем ASDen, 14 фев 2011.

  1. TopicStarter Overlay
    ASDen
    Offline

    ASDen

    Регистрация:
    14 фев 2011
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Есть код в 7.7
    Код:
    Ит.ИспользоватьКорСубконто(ВидыСубконто.ВидыЗатрат,, 1);
    Ит.ВключатьСубсчета(-1, -1);
    Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, "131;132;133;135", "70;71;72;74;81;82;83;84",, 2,, "С");
    Ит.ВыбратьКорСубконто(ВидыСубконто.ВидыЗатрат,,2);
    Пока Ит.ПолучитьКорСубконто(ВидыСубконто.ВидыЗатрат) = 1 Цикл
    Ит.ВыбратьКорСчета(,2);
    Пока Ит.ПолучитьКорСчет() = 1 Цикл
    КонецЦикла;
    КонецЦикла;
    
    
    Нужно сделать аналогичный но в 8
    Все на что мозгов хватило это
    Код:
    СчетаТМЦ = Новый СписокЗначений;
    СчетаТМЦ.Добавить(ПланыСчетов.Типовой.СырьеИМатериалы); //1310
    СчетаТМЦ.Добавить(ПланыСчетов.Типовой.ГотоваяПродукция); //1320
    СчетаТМЦ.Добавить(ПланыСчетов.Типовой.Товары); //1330
    СчетаТМЦ.Добавить(ПланыСчетов.Типовой.МатериалыПереданныеВПереработку); //1351
    
    СчетаЗатрат = Новый СписокЗначений;
    СчетаЗатрат.Добавить(ПланыСчетов.Типовой.СебестоимостьРеализованнойПродукцииИОказанныхУслуг_); //7000
    СчетаЗатрат.Добавить(ПланыСчетов.Типовой.РасходыПоРеализацииПродукцииИОказаниюУслуг_); //7100
    СчетаЗатрат.Добавить(ПланыСчетов.Типовой.АдминистративныеРасходы_); //7200
    СчетаЗатрат.Добавить(ПланыСчетов.Типовой.РасходыНаФинансирование); //7300
    СчетаЗатрат.Добавить(ПланыСчетов.Типовой.ПрочиеРасходы_); //7400
    СчетаЗатрат.Добавить(ПланыСчетов.Типовой.РасходыСвязанныеСПрекращаемойДеятельностью_); //7500
    СчетаЗатрат.Добавить(ПланыСчетов.Типовой.ДоляВУбыткеОрганизацийУчитываемыхМетодомДолевогоУчастия); //7600
    СчетаЗатрат.Добавить(ПланыСчетов.Типовой.РасходыПоКорпоративномуПодоходномуНалогу_); //7700
    СчетаЗатрат.Добавить(ПланыСчетов.Типовой.ОсновноеПроизводство_); //8100
    СчетаЗатрат.Добавить(ПланыСчетов.Типовой.ПолуфабрикатыСобственногоПроизводства_); //8200
    СчетаЗатрат.Добавить(ПланыСчетов.Типовой.ВспомогательныеПроизводства_); //8300
    СчетаЗатрат.Добавить(ПланыСчетов.Типовой.НакладныеРасходы_); //8400
    
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
    |	ТиповойОборотыДтКт.СчетДт,
    |	ТиповойОборотыДтКт.СчетКт,
    |	ТиповойОборотыДтКт.СуммаОборот,
    |	ТиповойОборотыДтКт.СубконтоКт1,
    |	ТиповойОборотыДтКт.СубконтоДт1,
    |	ТиповойОборотыДтКт.СубконтоДт3
    |ИЗ
    |	РегистрБухгалтерии.Типовой.ОборотыДтКт(&ДатаН, &ДатаК, , СчетДт В ИЕРАРХИИ (&СчетаЗатрат), &ВидыСубконто, СчетКт В ИЕРАРХИИ (&СчетаТМЦ), , ) КАК ТиповойОборотыДтКт";
    
    Запрос.УстановитьПараметр("СчетаЗатрат",СчетаЗатрат);
    Запрос.УстановитьПараметр("СчетаТМЦ",СчетаТМЦ);
    Запрос.УстановитьПараметр("НачПериода", НачалоДня(ДатаНач));
    Запрос.УстановитьПараметр("КонПериода", КонецДня(ДатаКон));
    Запрос.УстановитьПараметр("ВидыСубконто",  ПланыВидовХарактеристик.ВидыСубконтоТиповые.СтатьиЗатрат);
    
    
    Результат = Запрос.Выполнить().Выбрать();
    Пока Результат.Следующий() Цикл
    
    КонецЦикла;	
    
    
    Проблема в следующем, на некоторых счетах "Статья затрат" является субконто1 на некоторых субконто3
    Как это правильно реализовать?
    Заранее спасибо!
  2. poiuy
    Offline

    poiuy Опытный в 1С

    Регистрация:
    12 окт 2010
    Сообщения:
    170
    Симпатии:
    0
    Баллы:
    26
    Вы ограничили вид субконто по дебету, так что пофиг какой он по порядку в системе на конкретном счете, в выборке он всегда будет СубконтоДт1
  3. TopicStarter Overlay
    ASDen
    Offline

    ASDen

    Регистрация:
    14 фев 2011
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Точно! Тогда вторая проблема...
    Код:
    Пока Ит.ПолучитьКорСубконто(ВидыСубконто.ВидыЗатрат) = 1 Цикл
    Ит.ВыбратьКорСчета(,2);
    Пока Ит.ПолучитьКорСчет() = 1 Цикл
    Ит.ВыбратьСчета(1);
    Пока Ит.ПолучитьСчет() = 1 Цикл
    **************
    КонецЦикла;
    КонецЦикла;
    КонецЦикла
    
    Как организовать цикл?
  4. poiuy
    Offline

    poiuy Опытный в 1С

    Регистрация:
    12 окт 2010
    Сообщения:
    170
    Симпатии:
    0
    Баллы:
    26
    Сгруппировать по СубконтоДт1 / СчетКт / СчетДт
    Результат запроса обойти по группировкам
  5. TopicStarter Overlay
    ASDen
    Offline

    ASDen

    Регистрация:
    14 фев 2011
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Ну как бы логично )
    Код где бы можно посмотреть?
Похожие темы
  1. alp
    Ответов:
    9
    Просмотров:
    770
Загрузка...

Поделиться этой страницей