7.7 Помогите сделать проводку

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем LanaKo, 4 дек 2011.

  1. TopicStarter Overlay
    LanaKo
    Offline

    LanaKo

    Регистрация:
    4 дек 2011
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте,уважаемые профессионалы!Извините, что оскверняю супер-про-форум своей ерундой.
    Помогите, пожалуйста,неделю мучаюсь.Нужно создать операцию с проводками Дт 26 Кт19.3.
    Оба субконто счета 26-СтатьиОбщехозяственныхРасходов и Подразделения формируются пустыми.Не знаю где ошибка? :angry:
    Код:
    Процедура Выполнить() 
    Док=СоздатьОбъект("Документ.УслугиСтороннихОрганизаций");
    СпрХоз=СоздатьОбъект("Справочник.СтатьиОбщехозяйственныхЗатрат");
    СпрПроизв=СоздатьОбъект("Справочник.СтатьиОбщепроизводственныхЗатрат");
    СпрПодр=СоздатьОбъект("Справочник.Подразделения");
    Опер=СоздатьОбъект("Операция");
    Опер.Новая();
    Опер.ДатаОперации=РабочаяДата();
    Опер.Содержание=("Зачет НДС");
    Док.ВыбратьДокументы(Дата1,Дата2);
    Пока Док.ПолучитьДокумент()>0 Цикл 
    Опер.НоваяПроводка();
    Док.ВыбратьСтроки();
    Если Док.ПолучитьСтроку()>0 тогда
    Опер.Дебет.Счет=Док.КоррСчет; 
    Если Док.КоррСчет=СчетПоКоду("26") тогда
    СпрХоз.НайтиПоКоду("00003");
    СпрПодр.НайтиПоКоду("0000000004");
    [color=#FF0000]Субконто1=СпрХоз.Наименование; 
    Субконто2=СпрПодр.Наименование;
    Опер.Дебет.Субконто(1,Субконто1);
    Опер.Дебет.Субконто(2,Субконто2);[/color]
    КонецЕсли;	
    Опер.Сумма=Док.НДС;
    КонецЕсли; 	  
    Опер.Кредит.Счет=СчетПоКоду("19.3");
    Опер.Кредит.Субконто(1,Док.Контрагент);
    Опер.Кредит.СчетаФактурыПолученные = Док.ТекущийДокумент();
    Опер.СодержаниеПроводки="Спис. НДС по услугам"; 
    Опер.НомерЖурнала="НД";
    Опер.ПервичныйДокумент=Док.ДатаНомерСчетаФактуры;
    Опер.Записать();
    КонецЦикла;
    Опер.Записать();
    КонецПроцедуры
    
    Благодарю заранее!!
  2. sergejk74
    Offline

    sergejk74 Опытный в 1С

    Регистрация:
    15 ноя 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Код:
    Субконто1=СпрХоз.ТекущийЭлемент();
    Субконто2=СпрПодр.ТекущийЭлемент();
    
    Опер.НоваяПроводка(); желательно поставить после Если Док.ПолучитьСтроку()>0 тогда
  3. TopicStarter Overlay
    LanaKo
    Offline

    LanaKo

    Регистрация:
    4 дек 2011
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    :D
    УРА!!!СПАСИБО!!!ВСЕ ПОЛУЧИЛОСЬ!!!
    РЕСПЕКТ- sergejK74!!!! Спасибо!!! :angry:
    СУПЕР-ПРО-ФОРУМУ СПАСИБО!!!!!!
    :aua: :D
  4. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    [off]Как мало для счастья надо :angry:[/off]

Поделиться этой страницей