8.х помогите с заполнением инвентаризации из файла .txt

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем matrixs06, 20 дек 2010.

  1. TopicStarter Overlay
    matrixs06
    Offline

    matrixs06

    Регистрация:
    7 ноя 2010
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1
    Три созданных не проведенных документа:ИНВЕНТАРИЗАЦИЯ
    на оснований их
    Необходимо создать один общии документ:ИНВЕНТАРИЗАЦИЯ

    или связать их меду собой и вывести один общии документ РЕВИЗИИ
  2. yzek
    Offline

    yzek Опытный в 1С

    Регистрация:
    13 окт 2010
    Сообщения:
    713
    Симпатии:
    0
    Баллы:
    26
    надо либо написать обработку, которая выгружает данные из этих документов
    либо, если обработка по загрузке помогла(с ее помощью были созданы эти документы), можно несколько раз ей загрузить различные текстовые документы в один и тот же документ.
  3. TopicStarter Overlay
    matrixs06
    Offline

    matrixs06

    Регистрация:
    7 ноя 2010
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1
    Просто те три инвентаризации будут оформлятся на торговых точках а одну общую будут делать в офисе руководителем
  4. Inkeeper
    Offline

    Inkeeper Опытный в 1С

    Регистрация:
    22 мар 2009
    Сообщения:
    327
    Симпатии:
    0
    Баллы:
    26
    в продолжении темы, я воспользовался обработкой vzek'а, решил её немного переделать под себя. Решил сделать следующее, не выбирать предварительно сформированный документ (в моём случае "Поступление товаров и услуг"), а создаю его программно и к нему обращатся и работать с ним, мой код:
    Код:
    
    ИмяФайла = "C:\Obmen\2.txt";
    Текст = Новый ТекстовыйДокумент;
    Текст.Прочитать(ИмяФайла,,);	
    ДокументПоступления = Документы.ПоступлениеТоваровУслуг.СоздатьДокумент();
    Документ = ЭлементыФормы.ДокументПоступления.Значение.ПолучитьОбъект();
    //Документ = ЭлементыФормы.ДокументПоступления.Значение.ПолучитьОбъект();
    Для НомерСтроки = 1 По Текст.КоличествоСтрок() Цикл
    Стр = Текст.ПолучитьСтроку(НомерСтроки);
    Результат = Лев(Стр,13);
    КолвоВТСД = Число(Прав(Стр,СтрДлина(Стр)-Найти(Стр," ")));
    Для Колво = 1 По КолвоВТСД Цикл
    Если Не ПустаяСтрока(Результат) Тогда
    ПолучитьСерверТО().ОбработатьВведенныйШтрихкод(Результат, Документ.ПолучитьФорму("ФормаДокумента"));
    КонецЕсли;
    КонецЦикла;
    Документ.Записать();
    КонецЦикла;
    
    ПереместитьФайл ("C:\Obmen\2.txt","C:\Obmen\3.txt");
    
    
    
    но выводится ошибка
    .
    Подскажите пожалуйста - как правильно исправить код?
  5. Inkeeper
    Offline

    Inkeeper Опытный в 1С

    Регистрация:
    22 мар 2009
    Сообщения:
    327
    Симпатии:
    0
    Баллы:
    26
    всё разобрался
  6. Inkeeper
    Offline

    Inkeeper Опытный в 1С

    Регистрация:
    22 мар 2009
    Сообщения:
    327
    Симпатии:
    0
    Баллы:
    26
    вопрос, а если содержимое txt файла:

    как быть в символом ;? Как его не учитывать?

    Код:
    ИмяФайла = "C:\Obmen\2.txt";
    Текст = Новый ТекстовыйДокумент;
    Текст.Прочитать(ИмяФайла,,);	
    ДокументПоступления = Документы.ПоступлениеТоваровУслуг.СоздатьДокумент();
    Документ = ДокументПоступления.ПолучитьСсылкуНового();
    //Документ = ЭлементыФормы.ДокументПоступления.Значение.ПолучитьОбъект();
    Для НомерСтроки = 1 По Текст.КоличествоСтрок() Цикл
    Стр = Текст.ПолучитьСтроку(НомерСтроки);
    Результат = Лев(Стр,13);
    КолвоВТСД = Число(Прав(Стр,СтрДлина(Стр)-Найти(Стр," ")));
    //КолвоВТСД = Число(Прав(Стр,СтрДлина(Стр)-Найти(Стр," ")));
    Для Колво = 1 По КолвоВТСД Цикл
    Если Не ПустаяСтрока(Результат) Тогда
    ПолучитьСерверТО().ОбработатьВведенныйШтрихкод(Результат, ДокументПоступления.ПолучитьФорму("ФормаДокумента"));
    КонецЕсли;
    КонецЦикла;
    ДокументПоступления.Дата = ТекущаяДата();
    ДокументПоступления.Записать();
    КонецЦикла;
    
    ПереместитьФайл ("C:\Obmen\2.txt","C:\Obmen\3.txt");
    
    
    
  7. Inkeeper
    Offline

    Inkeeper Опытный в 1С

    Регистрация:
    22 мар 2009
    Сообщения:
    327
    Симпатии:
    0
    Баллы:
    26
    у меня файл будет с содержимым
    . Как сделать, чтобы обработка "отбрасывала" последний символ в строке (;)?
  8. Inkeeper
    Offline

    Inkeeper Опытный в 1С

    Регистрация:
    22 мар 2009
    Сообщения:
    327
    Симпатии:
    0
    Баллы:
    26
    сам с собой разговариваю
  9. yzek
    Offline

    yzek Опытный в 1С

    Регистрация:
    13 окт 2010
    Сообщения:
    713
    Симпатии:
    0
    Баллы:
    26
    Добрый день.
    Замените строку
    Код:
    КолвоВТСД = Число(Прав(Стр,СтрДлина(Стр)-Найти(Стр," ")));
    
    на
    Код:
    КолвоВТСД = Число(Сред(Стр,15,СтрДлина(СокрЛП(Стр))-15));
    

Поделиться этой страницей