8.х Помогите с записью документа!

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Ultralisk, 18 дек 2010.

  1. TopicStarter Overlay
    Ultralisk
    Offline

    Ultralisk

    Регистрация:
    29 ноя 2010
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Не могу записать программно документ. Платформа V8.0 Все процедуры находятся в модуле документа.

    Вызывающая процедура:
    Код:
    
    Процедура ОЧ_АрхивДатаПриИзменении(Элемент)
    УстановитьСтатус(Лев(Элемент.Данные,2));
    КонецПроцедуры
    
    
    
    
    Исполняемая процедура

    Код:
    Процедура УстановитьСтатус(Префикс)
    Если Строка(ЭтотОбъект[Префикс+"_АрхивДата"]) <> "01.01.0001 0:00:00" Тогда
    ЭлементыФормы[Префикс].Значение = Истина;
    //ЭтотОбъект[Префикс]=Истина;
    Иначе
    ЭтотОбъект[Префикс]=Ложь;
    КонецЕсли;
    ЭтотОбъект.Записать();
    
    КонецПроцедуры
    
    
    

    Получаю ошибку:

    {Документ.[ИмяДокумента].Форма.ФормаЭлемента(9)}: Ошибка при вызове метода контекста (Записать): Элемент не выбран!
    ЭтотОбъект.Записать();
    по причине:
    Элемент не выбран!

    Это при том, что ЭтотОбъект - это текущий документ!

    Что не так?! :angry:
  2. TopicStarter Overlay
    Ultralisk
    Offline

    Ultralisk

    Регистрация:
    29 ноя 2010
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Закрывайте тему. Проблема была в том, что при копировании формы справочника в форму документа произошло наследование родителя. Соответственно, Метод ЭтотОбъект возвращал не ОбъектДокумент, а ОбъектСправочник.

Поделиться этой страницей