8.х Помогите с простым отчетом

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем XXL, 5 мар 2008.

Статус темы:
Закрыта.
  1. TopicStarter Overlay
    XXL
    Offline

    XXL Опытный в 1С Команда форума

    Регистрация:
    22 янв 2007
    Сообщения:
    1.159
    Симпатии:
    19
    Баллы:
    29
    Хочу изучить 1С 8.0, попыталась написать простой отчет как в 7.7, не прокатило, подскажите пожалуйста как данный код будет в 8.0 писаться???

    Код:
    Сп = СоздатьОбъект("Справочник.Сотрудники");
    Сп.ВыбратьЭлементы();
    Пока Сп.ПолучитьЭлемент() = 1 Цикл
    Н = Н + 1;
    Сообщить(""+Н+" "+Сп.Наименование);
    КонецЦикла;
    
  2. AlexFF
    Offline

    AlexFF Разбирающийся

    Регистрация:
    6 мар 2007
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    26
    Запросом это все необходимо делать.
    Через конструктор сделай легко и просто.
  3. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    Да, запросом - оно правильнее будет. Но сам по первой писал по привычке, как в 77.

    Код:
    выборка = Справочники.Банки.Выбрать();
    нн = 0;
    Пока выборка.Следующий() Цикл
    нн = нн + 1;
    Сообщить(" "+нн+" "+выборка.Наименование);
    КонецЦикла;
    
  4. vlashi
    Offline

    vlashi Опытный в 1С

    Регистрация:
    18 янв 2008
    Сообщения:
    143
    Симпатии:
    0
    Баллы:
    26
    Как зачем? Учится человек.

    Код:
    Сп = Справочники.СотрудникиОрганизаций;
    СпВыб = Сп.Выбрать();
    Пока СпВыб.Следующий() Цикл
    Н = Н + 1;
    Сообщить(""+Н+" "+СпВыб.Наименование);
    КонецЦикла;			
    
    
  5. TopicStarter Overlay
    XXL
    Offline

    XXL Опытный в 1С Команда форума

    Регистрация:
    22 янв 2007
    Сообщения:
    1.159
    Симпатии:
    19
    Баллы:
    29
    lazy и vlashi спасибо большое, выручили:) буду дальше восьмерку мучить:)
  6. TopicStarter Overlay
    XXL
    Offline

    XXL Опытный в 1С Команда форума

    Регистрация:
    22 янв 2007
    Сообщения:
    1.159
    Симпатии:
    19
    Баллы:
    29
    Прикольно:)
    Всем спасибо, тему можно закрыть.
Статус темы:
Закрыта.

Поделиться этой страницей