7.7 Помогите с получение данных из документа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем salashnik, 21 янв 2009.

  1. TopicStarter Overlay
    salashnik
    Offline

    salashnik

    Регистрация:
    20 янв 2009
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Есть основной документ заявка (в ней формируются заявки на выполнение работ, договора и т.д.), в табличной части документа содержатся группы товаров (названия берутся из Справочник.Номенклатура, также указана Спецификация из отдельного документа).
    Мне необходимо сформировать новую печатную форму содержащую название группы товара, а далее все данные (размеры, виды отделки, цвет, замок) должны браться из документа спецификация, подскажите пожалуйста как их можно получить.

    Табличную часть получаю следующим образом:
    Код:
    Тз = СоздатьОбъект("ТаблицаЗначений");
    ТаблицаНормативов.Выгрузить(Тз); 
    Тз.Сортировать("КодСтроки"); 
    Тз.ВыбратьСтроки();
    КоличествоГрупп=0;
    Пока Тз.ПолучитьСтроку()=1 Цикл
    Если Тз.Уровень=1 Тогда
    КоличествоГрупп=КоличествоГрупп+1; 
    НомерИзделия=КоличествоГрупп;
    НомерПартии=НомерДок;
    НаименованиеИзделия=глПолноеНаименование(Тз.Товар);
    КонецЕсли;
    КонецЦикла;
    
    Конфигурация почти вся переделанная фирмой, на основе Производство+Услуги+Бухгалтерия, ред. 2.8
    P/S В 1С новичек, только начал заниматься, поэтому если можно поподробней, заранее спасибо за ответ
  2. LeonM
    Offline

    LeonM

    Регистрация:
    15 фев 2009
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    [warn="Внимание!!!"]Пользуемся тегами!!![/warn]

    Код:
    Тз = СоздатьОбъект("ТаблицаЗначений");
    ТаблицаНормативов.Выгрузить(Тз);
    Тз.Сортировать("КодСтроки");
    Тз.ВыбратьСтроки();
    КоличествоГрупп=0;
    Пока Тз.ПолучитьСтроку()=1 Цикл
    Если Тз.Уровень=1 Тогда
    КоличествоГрупп=КоличествоГрупп+1;
    НомерИзделия=КоличествоГрупп;
    НомерПартии=НомерДок;
    НаименованиеИзделия=глПолноеНаименование(Тз.Товар);
    Иначе
    Сообщить("Тз.Уровень не равен 1");//возможно просто Тз.Уровень не равен - 1 поэтому и нечего выводить
    КонецЕсли;
    КонецЦикла;
    

Поделиться этой страницей