7.7 Помогите с печатной формой 1Сv7

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем Ветал, 11 фев 2008.

  1. TopicStarter Overlay
    Ветал
    Offline

    Ветал

    Регистрация:
    11 фев 2008
    Сообщения:
    14
    Симпатии:
    0
    Баллы:
    1
    Создал конструктором печати
    Потом добавил чтобы выводил Если НомерСтроки <=50 тогда и Если НомерСтроки >50 тогда

    Код:
    Процедура Печать() 
    
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Печать");
    Таб.ВывестиСекцию("Шапка");
    Таб.Опции(7,0,7,0);
    //***************************************************************** 
    ВыбратьСтроки(); 
    Пока ПолучитьСтроку() = 1 Цикл 
    Если НомерСтроки <=50 тогда
    Таб.ВывестиСекцию("Строка");
    КонецЕсли; 
    КонецЦикла; 
    //****************************************************************** 
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл 
    Если НомерСтроки >50 тогда
    Таб.ВывестиСекцию("С"); 
    ВысС=Таб.ВысотаСекции("С");
    КонецЕсли;
    КонецЦикла; 
    //******************************************************************
    Таб.ВывестиСекцию("Подвал");
    Таб.ТолькоПросмотр(0);
    Таб.Показать("Печать Заявка","");
    КонецПроцедуры
    
    
    Он мне выводит печатну фому такую

    Наименование КГ
    колбаса1 25
    колбаса2 30
    колбаса 3 40
    колбаса н н

    как мне сделать чтобы выводилась такая таблица

    Наименование КГ
    колбаса1 25 колбаса 3 40
    колбаса2 30 колбаса н н

    [warn=Читайте правила]1. Используйте тэг
    Код:
    2. Дублирование тем запрещено[/warn]
  2. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    Выгрузи табличную часть в таблицу значений и тебе никто не помешает получать из неё текущее значение и значение из строки с номером=номертекущей+2 можно значение получать непосредственно в таблице ("Печать"), красивее получать в переменную и пользоваться командой ПрисоеденитьСекцию() тогда можно создать условаие по которому будет выводиться любое количество столбцов :unsure:
  3. TopicStarter Overlay
    Ветал
    Offline

    Ветал

    Регистрация:
    11 фев 2008
    Сообщения:
    14
    Симпатии:
    0
    Баллы:
    1
    благодарю за совет
  4. TopicStarter Overlay
    Ветал
    Offline

    Ветал

    Регистрация:
    11 фев 2008
    Сообщения:
    14
    Симпатии:
    0
    Баллы:
    1
    можно ли показать на примере

Поделиться этой страницей