8.х помогите с ОСВ

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Z-bob, 27 июн 2013.

  1. TopicStarter Overlay
    Z-bob
    Offline

    Z-bob Опытный в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте, в РБ добавил "Аудиторский", в формах документа есть реквизит "Дата Аудита", добавил ОСВАудиторская, теперь надо чтобы ОСВ при выборе начальное и конечный период выбирал документы по реквизиту "Дата аудита". В СКД ОСВАудиторская все поменял чтобы ссылался на РБ "Аудиторский"...
    Помогите как сделать так чтобы ОСВ выбирал документы по ДатаАудита.
  2. TopicStarter Overlay
    Z-bob
    Offline

    Z-bob Опытный в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    Народ, подскажите... Нужна ваша помощь...
  3. Draco
    Online

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.635
    Симпатии:
    946
    Баллы:
    204
    Не совсем понятно
    1. Вы добавили регистр бухгалтерии "Аудиторский"
    2. На формах документа добавили Реквизит "Дата аудита"
    3 ОСВ Аудиторская - это Вы отчет создали???

    Проводки в РБ "Аудиторский " как делаются ? период какой - дата аудита в документе?

    Или тогда покажите Вашу ОСВ или ее код
  4. TopicStarter Overlay
    Z-bob
    Offline

    Z-bob Опытный в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    Сейчас постараюсь вам все подробно объяснить:
    1. Да, добавил РБ "Аудиторский"
    2. Да, есть реквизит "Дата аудита"
    3. Я скопировал работающий ОСВ Типовой и переименовал на ОСВ Аудиторский, поменял в СКД ОстаткиИОбороты на Аудиторский.

    Код:
    Процедура ПроверкаПроводок(Кнопка)
    Запрос	   = Новый Запрос();
    ТекстПериода = "";
    Для Каждого ЭлементОтбора из Отбор Цикл
    Если НЕ ЭлементОтбора.Использование Тогда
    Продолжить;
    КонецЕсли;
    Если Найти("Период, Счет, Активность, Регистратор, СчетДт, СчетКт, Организация, Сумма, Содержание, НомерЖурнала", ЭлементОтбора.Имя) > 0 Тогда
    Сообщить("Отбор """ + ЭлементОтбора.Представление + """ не учитывается при проверке проводок.", СтатусСообщения.Информация);
    Продолжить;
    КонецЕсли;
    ДобавитьУсловие(ТекстПериода, Отбор, ЭлементОтбора, Запрос)
    КонецЦикла;
    Если НЕ ПустаяСтрока(ТекстПериода) Тогда
    ТекстПериода = Сред(ТекстПериода, 6);
    КонецЕсли;
    ТекстЗапроса =
    "ВЫБРАТЬ
    | Аудиторский.СчетДт,
    | Аудиторский.СчетКт,
    | Аудиторский.СчетДт.Код КАК КодДт,
    | Аудиторский.СчетКт.Код КАК КодКт,
    | Аудиторский.Содержание КАК Комментарий,
    | СУММА(1) КАК ВесПроводки
    |ИЗ
    | РегистрБухгалтерии.Аудиторский КАК Аудиторский
    |  ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
    |   Аудиторский.СчетДт КАК СчетДт,
    |   Аудиторский.СчетКт КАК СчетКт
    |  ИЗ
    |   РегистрБухгалтерии.Аудиторский КАК Аудиторский
    |    ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.КорректныеКорреспонденцииСчетов КАК КорректныеКорреспонденцииСчетов
    |    ПО Аудиторский.СчетДт = КорректныеКорреспонденцииСчетов.СчетДт И Аудиторский.СчетКт = КорректныеКорреспонденцииСчетов.СчетКт"
    + ?(ПустаяСтрока(ТекстПериода) = Ложь, "
    |  ГДЕ", "") + ТекстПериода + "
    |
    |  ОБЪЕДИНИТЬ
    |
    |  ВЫБРАТЬ
    |   Аудиторский.СчетДт,
    |   Аудиторский.СчетКт
    |  ИЗ
    |   РегистрБухгалтерии.Аудиторский КАК Аудиторский
    |    ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.КорректныеКорреспонденцииСчетов КАК КорректныеКорреспонденцииСчетов
    |    ПО Аудиторский.СчетДт = КорректныеКорреспонденцииСчетов.СчетДт И (КорректныеКорреспонденцииСчетов.СчетКт = &ПустаяСсылка)"
    + ?(ПустаяСтрока(ТекстПериода) = Ложь, "
    |  ГДЕ", "") + ТекстПериода + "
    |
    |  ОБЪЕДИНИТЬ
    |
    |  ВЫБРАТЬ
    |   Аудиторский.СчетДт,
    |   Аудиторский.СчетКт
    |  ИЗ
    |   РегистрБухгалтерии.Аудиторский КАК Аудиторский
    |    ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.КорректныеКорреспонденцииСчетов КАК КорректныеКорреспонденцииСчетов
    |    ПО (КорректныеКорреспонденцииСчетов.СчетДт = &ПустаяСсылка) И Аудиторский.СчетКт = КорректныеКорреспонденцииСчетов.СчетКт"
    + ?(ПустаяСтрока(ТекстПериода) = Ложь, "
    |  ГДЕ", "") + ТекстПериода + ") КАК Проверенные
    |  ПО Проверенные.СчетКт = Аудиторский.СчетКт И Проверенные.СчетДт = Аудиторский.СчетДт
    |ГДЕ
    | ((Проверенные.СчетКт) ЕСТЬ NULL )" + ?(ПустаяСтрока(ТекстПериода) = Ложь, " И", "") + ТекстПериода;
    ТекстЗапроса = ТекстЗапроса + "
    |
    |СГРУППИРОВАТЬ ПО
    | Аудиторский.СчетДт,
    | Аудиторский.СчетКт,
    | Аудиторский.Содержание
    |
    |УПОРЯДОЧИТЬ ПО
    | КодДт,
    | КодКт";
    Запрос.Текст = ТекстЗапроса;
    Запрос.УстановитьПараметр("ПустаяСсылка", ПланыСчетов.Типовой.ПустаяСсылка());
    Результат = Запрос.Выполнить();
    Если НЕ Результат.Пустой() Тогда
    Сообщить("Обнаружены некорректные корреспонденции.");
    ФормаСпискаКорреспонденций = РегистрыСведений.КорректныеКорреспонденцииСчетов.ПолучитьФорму("ФормаСпискаКорреспонденций");
    ФормаСпискаКорреспонденций.ТаблицаКорреспонденций = Результат.Выгрузить();
    ФормаСпискаКорреспонденций.ТаблицаКорреспонденций.Колонки.Добавить("Пометка");
    ФормаСпискаКорреспонденций.ТаблицаКорреспонденций.ЗаполнитьЗначения(Истина,"Пометка");
    ФормаСпискаКорреспонденций.Открыть();
    Иначе
    Предупреждение("Проверка проводок завершена!");
    КонецЕсли;
    КонецПроцедуры
    
  5. TopicStarter Overlay
    Z-bob
    Offline

    Z-bob Опытный в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    ПланСчетов не трогал, так и ссылается на ПланСчетов.Типовой, еще при помощи "точки останова" пошагово смотрел куда и как ссылается, походу дела скопировав СтандартныеОтчеты и ТиповыеОтчеты переименовал их на СтандартОтчетАудит и АудитОтчеты, везде поставил так чтобы ссылался на РБ Аудиторский.
    Вроде все идет нормально, но в самом ОСВ выдает ошибку "Не найдены поля ДополнительныеПоля".
    Не знаю почему выдает такую ошибку, эта ошибка выходила даже тогда, когда я просто копировал ОСВТиповой и ничего не менял...
    Из за чего может выйти такая ошибка?
  6. Draco
    Online

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.635
    Симпатии:
    946
    Баллы:
    204
    1. как вы пишите записи в свой регистр "Аудиторский" - дата периода там какая стоит? дата регистратора или дата вашего добавленого реквизита
    2 Скрин ошибки можете показать?
  7. TopicStarter Overlay
    Z-bob
    Offline

    Z-bob Опытный в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    1. дата регистратора
    2.

    Вложения:

    • скрин.png
      скрин.png
      Размер файла:
      74,5 КБ
      Просмотров:
      5
  8. Draco
    Online

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.635
    Симпатии:
    946
    Баллы:
    204
    1. А смысл тогда вашего реквизита? если все движения по дате регистратора, соответвенно все остатки и двежения РС Аудиторский на дату регистратора, а не дату аудита
    2 на нудо тогда смотреть по отладчику что происходит в процедурерна строчку Выше - ЗапольнитьДанныеОтчета. так трудно сказать - над по конфигуратору двигаться
  9. TopicStarter Overlay
    Z-bob
    Offline

    Z-bob Опытный в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    1. я перепутал, по ДатаАудита
    2. Вроде все правильно, в ОСВ Типовой все также и работает, не пойму в чем ошибка

Поделиться этой страницей