7.7 Помогите с кодом

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем Arfey, 7 авг 2008.

  1. TopicStarter Overlay
    Arfey
    Offline

    Arfey

    Регистрация:
    31 июл 2008
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    Есть у меня следущий код:

    Код:
    Процедура Сформировать()  
    
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ИспользоватьСубконто(ВыбВидСубконто1,, 1);  // отбор итогов по субконто 
    Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, ВыбСчет,,, 1, "Квартал", "СК"); 
    Таб.ВывестиСекцию("Шапка");
    Ит.ВыбратьСубконто(ВыбВидСубконто1, 1); // выборка субконто
    
    Пока Ит.ПолучитьСубконто(ВыбВидСубконто1) = 1 Цикл 
    Таб.ВывестиСекцию("Субконто1"); 
    Пока Ит.ПолучитьСубконто() = 1 Цикл 
    Таб.ВывестиСекцию("Субконто2");
    КонецЦикла;
    КонецЦикла;
    
    Таб.ВывестиСекцию("Подвал"); 
    Таб.ТолькоПросмотр();
    Таб.Показать();
    
    КонецПроцедуры  
    
    Процедура ПриОткрытии()
    
    ВыбНачПериода = НачалоПериодаБИ();
    ВыбКонПериода = КонецПериодаБИ();
    
    КонецПроцедуры 
    
    
    Процедура ПриВыбореСчета() // подстраиваем выбор субконто
    
    НазначитьСчет(ВыбВидСубконто1, ВыбСчет, 1);
    
    КонецПроцедуры;
    
    

    А проблема в вот в чём - нада чтоб по каждому субконто выводились его детали ...


    Например выбираем Склад в таблице - идет перечесление каждого Склада - а под ним (автоматически - тоесть ненада делать пункт в диалоге и явно задавать что...) всё что в нём есть

    Я немогу подобрать синтаксис правильный - помогите :unsure:
  2. TopicStarter Overlay
    Arfey
    Offline

    Arfey

    Регистрация:
    31 июл 2008
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    кароче разобрался... можно ответ не писать
Похожие темы
  1. Arfey
    Ответов:
    2
    Просмотров:
    772
  2. bvv79
    Ответов:
    9
    Просмотров:
    1.193
Загрузка...

Поделиться этой страницей