7.7 Помогите с кодом

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем Arfey, 31 июл 2008.

  1. TopicStarter Overlay
    Arfey
    Offline

    Arfey

    Регистрация:
    31 июл 2008
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    Такая задача

    Есть таблица (например в ней перечислены пользователи) есть промежуток времини (дата начала и дата конца) и нада с помощю языка 1С её отсортировать и вывести результат в консоль ... в 1 строке

    Вот код для на несколько строк - а мне нужно в 1 строке​
    Код:
    Процедура Сформировать()
    Док = СоздатьОбъект("Документ");
    Док.ВыбратьДокументы(ДатаНач, ДатаКон);
    Пока Док.ПолучитьДокумент() > 0 Цикл
    Сообщить (Док);
    КонецЦикла;
    КонецПроцедуры
    
    ПОМОГИТЕ unsure.gif :unsure:

    Есть догадки что нада его перебрать с помощью цикла какого нить а потом склеить - но увы синкаксис знаю плохо и не получаеться ((
  2. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    Чет я не пойму, а при чем тут таблица и документы? или пользователи твои в табличной части документа? или что вообще?

    если у тебя код "который тебе нужен", но надо просто в одну строчку, тогда сделай так:
    Код:
    Процедура Сформировать()
    Сообщение = "";
    Док = СоздатьОбъект("Документ");
    Док.ВыбратьДокументы(ДатаНач, ДатаКон);
    Пока Док.ПолучитьДокумент() > 0 Цикл
    Сообщение = Сообщение + Док;
    КонецЦикла;
    Сообщить (Сообщение);
    КонецПроцедуры
    
    
  3. TopicStarter Overlay
    Arfey
    Offline

    Arfey

    Регистрация:
    31 июл 2008
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    СПАСИБА :) ... Насчёт задания - то это просто учат меня ... по чуть осваиваю 1С

    Задания такие дал:

    1. Вывести в строку в "сообщить()" список документов за период выбранный на форме.
    2. Вывести все строки в сообщить список документов за период выбранный на форме.
Похожие темы
  1. Arfey
    Ответов:
    1
    Просмотров:
    634
  2. bvv79
    Ответов:
    9
    Просмотров:
    1.193
Загрузка...

Поделиться этой страницей