7.7 Помогите разобраться!

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем vadim, 27 сен 2007.

  1. TopicStarter Overlay
    vadim
    Offline

    vadim Опытный в 1С

    Регистрация:
    31 июл 2007
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    Помогите разобраться!!
    Мне нужна обработка которая поможет с помощью сканера штрих кода вставлять в строку в акте списания строку с наименованием и весом того товара который я сканирую!!!
    Например имеется штрих код
    2218793002783-это груша

    первые 2-е цифры ни чего не обозначают
    следующие5-тьцифр 18793 обозначают код товара
    потом 00278 означает массу товара
    и последняя цифра 3 означает что товар весовой

    вот мне надо при создании акта списания при сканировании штрих кода чтобы он в строку вставлял код наименование и вес товара
    есть приблизительно первоначальная обработка


    Процедура ОбработкаВнешнегоСобытия(Источник,Событие,Данные)
    Если (Источник = "AnyScanner") Тогда
    Если (Событие = "BarCodeValue") Тогда
    Сканер.ПосылкаДанных = 1;
    КонецЕсли;
    Если Проведен() = 1 тогда
    возврат;
    КонецЕсли;
    ШК = СокрЛП(Данные);

    //СпрЕдПрихода = СоздатьОбъект("Справочник.ЕдиницыПрихода");
    //СпрЕдПрихода.ВыбратьЭлементыПоРеквизиту("Код");
    ???? НайтиПоКоду( ,0);
    Таб = СоздатьОбъект("ТаблицаЗначений");
    Таб.НоваяКолонка("Код",,,,,10);
    Таб.НоваяКолонка("Товар","Справочник.Товары",,,,40);
    Таб.НоваяКолонка("Единица","Справочник.ВходящиеШтрихКоды",,,,10);
    Пока СпрЕдПрихода.ПолучитьЭлемент() = 1 Цикл
    Если СпрЕдПрихода.ПометкаУдаления() = 0 тогда
    Таб.НоваяСтрока();
    Таб.Код = СпрЕдПрихода.Владелец.Код;
    Таб.Товар = СпрЕдПрихода.Владелец.ТекущийЭлемент();
    Таб.Единица = СпрЕдПрихода.ТекущийЭлемент();
    КонецЕсли;
    КонецЦикла;

    Таб.Сортировать("+Код");
    Если Таб.КоличествоСтрок() > 0 Тогда
    Если Таб.КоличествоСтрок() = 1 Тогда
    Таб.ПолучитьСтрокуПоНомеру(1);
    ИначеЕсли Таб.КоличествоСтрок() > 1 Тогда
    Н = 0;
    Если Таб.ВыбратьСтроку(Н,"Выберите товар:") = 0 Тогда
    Возврат;
    Иначе
    Таб.ПолучитьСтрокуПоНомеру(Н);
    КонецЕсли;
    КонецЕсли;




    Что дальше без понятия я только начинаю в этом разбераться!!!!!!! :unsure:
  2. PaNo
    Offline

    PaNo

    Регистрация:
    11 сен 2007
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1

    Задавай конкретнее вопрос. Что именно не получается?
    Чтобы найти в справочнике по коду твою грушу-
    Код:
    Товары = СоздатьОбъект("Справочник.Товары");
    
    Товары.НайтиПоКоду(Сред(Данные,3,5));
    
    
  3. TopicStarter Overlay
    vadim
    Offline

    vadim Опытный в 1С

    Регистрация:
    31 июл 2007
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    Мне надо что бы при сканировании в акт списания вставлялась позиция и масса
    а так при сканировании он пишет товар с таким штрих кодом не найден
Похожие темы
  1. Михаил.
    Ответов:
    3
    Просмотров:
    216
Загрузка...

Поделиться этой страницей