7.7 Помогите разобраться

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем russlix, 9 окт 2009.

  1. TopicStarter Overlay
    russlix
    Offline

    russlix

    Регистрация:
    15 авг 2008
    Сообщения:
    35
    Симпатии:
    0
    Баллы:
    1
    Есть такой код в модуле объекта (справочника) и больше ничего нету:

    Код:
     
    //Module number 
    Перем модуль; 
    
    Модуль=СоздатьОбъект("Модуль"); 
    Модуль.AppendModuleFromStorage("214",Контекст); 
    
    
    
    
    
    Глобальный модуль выглядит так:


    Код:
    
    //Module number 
    Перем модуль; 
    
    Процедура ПриУдаленииДокумента(пДокумент, Режим) 
    Модуль.ПриУдаленииДокумента(пдокумент, режим); 
    КонецПроцедуры 
    
    Процедура ПриОтменеПроведенияДокумента(Докум) 
    Модуль.ПриОтменеПроведенияДокумента(докум); 
    КонецПроцедуры 
    
    Процедура ПриНачалеРаботыСистемы() 
    Модуль.ПриНачалеРаботыСистемы(); 
    КонецПроцедуры 
    
    Процедура ПриЗавершенииРаботыСистемы() 
    Модуль.ПриЗавершенииРаботыСистемы(); 
    КонецПроцедуры 
    
    Если ЗагрузитьВнешнююКомпоненту(КаталогИБ()+"2222.dll")=0 тогда 
    Предупреждение("Не удается загрузить внешнюю компоненту <"+КаталогИБ()+"2222.dll>!"); 
    ЗавершитьРаботуСистемы(); 
    КонецЕсли; 
    
    Модуль=СоздатьОбъект("Модуль"); 
    Сообщить(КаталогИБ());
    Модуль.OpenStorage(КаталогИБ(),,); 
    Модуль.ь("319",Контекст); 
    
    
    

    Никаких процедур и функций во всех модулях нет.


    Где они как их посмотреть и отредактировать?
  2. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    Искать автора, больше никак
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Все действия вынесены во внешнюю библиотеку 2222.dll. Без ее автора вы ничего не отредактируете.
  4. TopicStarter Overlay
    russlix
    Offline

    russlix

    Регистрация:
    15 авг 2008
    Сообщения:
    35
    Симпатии:
    0
    Баллы:
    1
    Т.е. получается, что весь код (функции и процедуры) находятся в 2222.dll?

    dll - это же обычная библиотека и должны существовать программы, которые могут ее открыть!
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Существуют конечно.... А вы хорошо знаете ассемблер?
  6. ЧКДзержинский
    Offline

    ЧКДзержинский Опытный в 1С

    Регистрация:
    7 дек 2006
    Сообщения:
    487
    Симпатии:
    3
    Баллы:
    29
    Если библиотека написана на .NET, то можно воспользоваться ILDasm
  7. TopicStarter Overlay
    russlix
    Offline

    russlix

    Регистрация:
    15 авг 2008
    Сообщения:
    35
    Симпатии:
    0
    Баллы:
    1
    Боагодарю за внимание, я думал это можно сделать как-то проще.
  8. Ivan1c
    Offline

    Ivan1c

    Регистрация:
    16 дек 2009
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Есть программы, которые в ряде случаев помгают определить что (какие функции и процедуры) есть внутри файла DLL. Если Вас это интересует вышлите мне Dll.
  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Да - такой софт есть, но как правило в подобных библиотеках прописана какая-либо привязка или к ключу или к железу. Так что знание функций не поможет - все равно работать не будет. Иначе как правило вообще не имеет смысл выносить функции во внешний модуль
  10. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    Названия функций можно и в конфигурации прочитать :unsure:
Похожие темы
  1. Михаил.
    Ответов:
    3
    Просмотров:
    216
Загрузка...

Поделиться этой страницей