8.х Помогите разобраться в одном моменте

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Пиночет, 22 окт 2006.

  1. TopicStarter Overlay
    Пиночет
    Offline

    Пиночет

    Регистрация:
    22 окт 2006
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Пишу в модуле приложения такой код:


    // Модуль приложения

    Код:
    //ПримерыОбращенияККонстантам() - содержит примеры обращения
    // к Константам
    Процедура ПримерыОбращенияККонстантам()
    
    // Если это первый запуск конфигурации, то константа
    // содержит в качестве значения 1 января 0001 года.
    Если Константы.ДатаРегистрации.Получить() = '00010101' Тогда
    // Тогда установим 1 января текущего года
    Константы.ДатаРегистрации.Установить(НачалоГода(ТекущаяДата()));
    КонецЕсли;
    // Выведем значения констант в окно служебных сообщений:
    Сообщить("Дата регистрации:" + Константы.ДатаРегистрации() + ".");
    Сообщить("Наименование организации:" + Константы.НаименованиеОрганизации() + ".");
    
    КонецПроцедуры
    
    Процедура ПриНачалеРаботыСистемы()
    
    //Примеры:
    ПримерыОбращенияККонстантам();
    
    КонецПроцедуры
    
    
    
    При запуске самой платформы мне выдаёться такая ошибка:
    {МодульПриложения(14)}: Метод объекта не обнаружен (ДатаРегистрации)
    Сообщить("Дата регистрации:" + Константы.ДатаРегистрации() + ".");



    В чём проблема, в самой платформе вводил и дату регистрации и наименование организации, но в конфигарторе не возможно найти их значения.

    Заранее благодарен за помощь
  2. Kirya
    Offline

    Kirya Опытный в 1С

    Регистрация:
    3 авг 2006
    Сообщения:
    106
    Симпатии:
    0
    Баллы:
    26

    В этой строчке нужно написать
    Сообщить("Дата регистрации:" + Константы.ДатаРегистрации.Получить() + ".");
  3. TopicStarter Overlay
    Пиночет
    Offline

    Пиночет

    Регистрация:
    22 окт 2006
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Заработало, спасибо
Похожие темы
  1. Miller
    Ответов:
    5
    Просмотров:
    1.890
Загрузка...

Поделиться этой страницей