7.7 Помогите разобраться с кодом

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем potemkin, 26 окт 2011.

  1. TopicStarter Overlay
    potemkin
    Offline

    potemkin

    Регистрация:
    24 янв 2009
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Добрый день, уважаемые форумчане.
    Помогите разобраться с ниже написанным, а именно: объясните что делает этот код (для бухгалтера)?
    Особенно эта часть: БухИт.ВыполнитьЗапрос(НачДата,КонДата,СчетД,СчетПоКоду("70"),,2);

    Код:
    Процедура ЗакрытьТЗсуб_х_х_Подр25(подр)
    ------    Если ТаблицаЗакрытия.КоличествоСтрок()=0 Тогда
    -------------Возврат;
    ------    КонецЕсли;
    
    ------    СчетТЗ = СчетПоКоду("25");
    ------    Итого = ТаблицаЗакрытия.Итог("Сумма");
    ------    ТаблицаЗакрытия.ВыбратьСтроки();
    ------    Пока ТаблицаЗакрытия.ПолучитьСтроку() <> 0 Цикл
    ----------ТаблицаЗакрытия.Процент = ТаблицаЗакрытия.Сумма / Итого;
    ------    КонецЦикла;
    
    ------    Опер = СоздатьОбъект("Операция");
    ------    Опер.Новая();
    ------    СуммаОп = 0;
    ------    Опер.ДатаОперации = КонДата;
    ------    Опер.Содержание = "Закрытие счета "+СчетТЗ+" по подразделению "+подр;
    
    ------    БухИт = СоздатьОбъект("БухгалтерскиеИтоги");   
    ------    БухИт.ИспользоватьСубконто(ВидыСубконто.Подразделения,подр,2);
    ------    БухИт.ИспользоватьСубконто(ВидыСубконто.СтатьиОбщепроизводственныхЗатрат);
    ------БухИт.ВыполнитьЗапрос(НачДата,КонДата,СчетТЗ);
    
    ------БухИт.ВыбратьСубконто(2);
    ------    Пока БухИт.ПолучитьСубконто(2) = 1 Цикл
    -------------Если (БухИт.ДО()-БухИт.КО()) <> 0 Тогда
    -------------ТаблицаЗакрытия.ВыбратьСтроки();
    -------------------    ИтогоПров = 0;
    -------------------    Пока ТаблицаЗакрытия.ПолучитьСтроку() <> 0 Цикл
    -------------------------СуммаПров = Окр((БухИт.ДО()-БухИт.КО()) * ТаблицаЗакрытия.Процент,2);
    -------------------------    Если СуммаПров <> 0 Тогда
    --------------------------------Опер.НоваяПроводка();
    --------------------------------Опер.Дебет.Счет = ТаблицаЗакрытия.Счет;
    --------------------------------Опер.Дебет.Субконто(1,ТаблицаЗакрытия.Субконто1);
    --------------------------------Опер.Дебет.Субконто(2,ТаблицаЗакрытия.Субконто2);
    --------------------------------Опер.Дебет.Субконто(3,ТаблицаЗакрытия.Субконто3);
    --------------------------------Опер.Кредит.Счет = СчетТЗ;
    --------------------------------Опер.Кредит.Подразделения=подр;
    --------------------------------Опер.Кредит.СтатьиОбщепроизводственныхЗатрат=БухИт.Субконто(2);
    --------------------------------Опер.Сумма = СуммаПров;
    --------------------------------ИтогоПров = ИтогоПров + СуммаПров;
    --------------------------КонецЕсли;
    -------------------КонецЦикла;
    -------------------    Опер.Сумма = Опер.Сумма + ((БухИт.ДО()-БухИт.КО()) - ИтогоПров);
    -------------------    СуммаОп = СуммаОп + (БухИт.ДО()-БухИт.КО());
    -------------КонецЕсли;
    ------    КонецЦикла;
    ------    Опер.СуммаОперации = СуммаОп;
    ------    Если СуммаОп <> 0 Тогда
    -------------Опер.Записать();
    -------------Сообщить("Создана операция №"+Опер.Документ.НомерДок+" от "+Опер.Документ.ДатаДок);
    ------    КонецЕсли;
    КонецПроцедуры
    
    Процедура Закрытие25()
    ------    СчетД = СчетПоКоду("20"); 
    ------    СпрПодр = СоздатьОбъект("Справочник.Подразделения");
    ------    БухИт = СоздатьОбъект("БухгалтерскиеИтоги");   
    ------    БухИт.ИспользоватьСубконто(ВидыСубконто.Подразделения);
    ------    БухИт.ИспользоватьСубконто(ВидыСубконто.ВидыНоменклатуры);
    ------БухИт.ВыполнитьЗапрос(НачДата,КонДата,СчетД,СчетПоКоду("70"),,2);
    ------БухИт.ВыбратьСубконто(1);
    ------Пока БухИт.ПолучитьСубконто(1) = 1 Цикл
    -------------ТаблицаЗакрытия.УдалитьСтроки();
    -------------БухИт.ВыбратьСубконто(2);
    -------------Пока БухИт.ПолучитьСубконто(2) = 1 Цикл    
    --------------------Если БухИт.ДО() <> 0 Тогда
    --------------------------ТаблицаЗакрытия.НоваяСтрока();
    --------------------------ТаблицаЗакрытия.Счет = СчетД;
    --------------------------ТаблицаЗакрытия.Субконто1 = БухИт.Субконто(2);
    --------------------------ТаблицаЗакрытия.Субконто2 = Константа.СтОбщепроизЗатр;
    --------------------------ТаблицаЗакрытия.Субконто3 = БухИт.Субконто(1);
    --------------------------ТаблицаЗакрытия.Сумма = БухИт.ДО();
    -------------------    КонецЕсли;
    -------------КонецЦикла;
    -------------ЗакрытьТЗсуб_х_х_Подр25(БухИт.Субконто(1));
    ------    КонецЦикла;
    КонецПроцедуры
    
    
    
    Заранее благодарен.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Выбор бухгалтерских итогов за указанный период в корреспонденции (Счет дебета где-то выбирается) и кредита 70го

    З/Ы Если вы бухгалтер - мой вам добрый совет: не нужно копаться в коде... Это не ваше. Что-то нужно сделать или разобраться - лучше спросите. Поможем (и не обязательно за деньги)
  3. TopicStarter Overlay
    potemkin
    Offline

    potemkin

    Регистрация:
    24 янв 2009
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Спасибо. Но я не бухгалтер, я учусь программировать на 1С...

    Вопросик:
    БухИт.ИспользоватьСубконто(ВидыСубконто.Подразделения);
    БухИт.ИспользоватьСубконто(ВидыСубконто.ВидыНоменклатуры);
    БухИт.ВыполнитьЗапрос(НачДата,КонДата,СчетД,СчетПоКоду("70"),,2);

    Я так понимаю, здесь бух. итоги группируются по 2 видам субконто: по подразделениям и по видам номенклатуры. Затем выполняется выборка оборотов в корреспонденции с 70 счетом, т.е. затраты на зар.плату. Я правильно понимаю?
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Этим методом устанавливается по каким субконто следует производить отбор.
  5. TopicStarter Overlay
    potemkin
    Offline

    potemkin

    Регистрация:
    24 янв 2009
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    А остальные рассуждения верны?
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
  7. TopicStarter Overlay
    potemkin
    Offline

    potemkin

    Регистрация:
    24 янв 2009
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Спасибо

Поделиться этой страницей