8.х Помогите разобраться с формой списка нового(самописного) документа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Lily_1C, 5 окт 2011.

  1. TopicStarter Overlay
    Lily_1C
    Offline

    Lily_1C Опытный в 1С

    Регистрация:
    25 окт 2010
    Сообщения:
    152
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте! Нужна помощь!
    Создала новый документ,вроде все основные механизмы учла. Но вот проблема! Добавляю новый документ в интерфейс Склад. При открытии формы списка,ошибка:
    {ОбщийМодуль.РаботаСДиалогами(3630)}: Поле объекта не обнаружено (ВидПередачи) ФормаДокумента.ЭлементыФормы.ВидПередачи.ТолькоПросмотр = Ложь;
    При открытии через Операции-Документы,форма списка отображается правильно. Но к форме элемента тоже выскакивают ошибки(

    комментировать эти строки пробовала,не помогает,открывается сразу форма элемента,а не форма списка( это если интерфейс Склад)

    Вот сам кусочек кода.на который ругается(в общ.модуле РаботаСДиалогами)
    Код:
    Процедура ПроверитьВидПоступленияПередачи(ДокументОбъект, ФормаДокумента) Экспорт
    ......................
    Если МетаданныеДокумента.Реквизиты.Найти("ВидПередачи") <> Неопределено Тогда
    ФормаДокумента.ЭлементыФормы.ВидПередачи.ТолькоПросмотр = Ложь;//коммент.не помогает
    ФормаДокумента.ЭлементыФормы.ВидПередачи.КнопкаВыбора = Истина;
    ФормаДокумента.ЭлементыФормы.ВидПередачи.Рамка = Новый Рамка(ТипРамкиЭлементаУправления.Одинарная, 1);
    КонецЕсли;
    КонецЕсли;
    
    КонецПроцедуры
    
    

    Вложения:

    • 11111111111.JPG
      11111111111.JPG
      Размер файла:
      252,6 КБ
      Просмотров:
      15
  2. Diego
    Offline

    Diego Любитель 1С Команда форума

    Регистрация:
    3 апр 2009
    Сообщения:
    966
    Симпатии:
    2
    Баллы:
    29
    Скорее всего у этого документа есть реквизит "ВидПередачи", но нет элемента на форме с таким названием.
    Отсюда и ошибка.

Поделиться этой страницей