7.7 Помогите разобраться с документом

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Staskostanay, 23 июл 2007.

  1. TopicStarter Overlay
    Staskostanay
    Offline

    Staskostanay

    Регистрация:
    23 июл 2007
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    здраствуйте,я недавно устроился на работу сисадмином я живу в казахстане там стоит типовая ТИС переделка под казахстан ,там добавлен документ расчет ЗП ,раньше говорят работал теперь вроде считает но ничего не выводит вот исходник посмотрите пожалуйста
    Процедура Заполнить()
    Перем Запрос, ТекстЗапроса, Таб;
    УдалитьСтроки();
    ТЗ.УдалитьСтроки();
    ТЗ.Очистить();
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =
    "//{{ЗАПРОС(Заполнить)
    |Период с Дата1 по Дата2;
    |ЗакрытиеДня = Документ.ЗакрытиеДня.ТекущийДокумент;
    |СкладДок = Документ.ЗакрытиеДня.Склад;
    |Сотрудник = Документ.ЗакрытиеДня.Сотрудник;
    |Сумма = Документ.ЗакрытиеДня.Сумма;
    |Функция СуммаСумма = Сумма(Сумма);
    |Группировка Сотрудник без групп;
    |Условие(Склад=СкладДок);
    |Условие (РаботаетНаДату(Сотрудник,Дата2)=1);
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;

    Пока Запрос.Группировка(1) = 1 Цикл
    НоваяСтрока();
    Сотрудник=Запрос.Сотрудник;
    Оклад=Сотрудник.Оклад;
    Наработано=Запрос.СуммаСумма;
    Сумма=Оклад+Наработано;
    // Таб.ВывестиСекцию("Сотрудник");
    КонецЦикла;

    // ******************************
    ТекстЗапроса =
    "//{{ЗАПРОС(Авто)
    |Период с Дата1 по Дата2;
    |СотрудникРег = Регистр.Зарплата.Сотрудник;
    |Сумма = Регистр.Зарплата.Сумма;
    |ВидНУ = Регистр.Зарплата.ВидНУ;
    |ТекущийДокумент = Регистр.Зарплата.ТекущийДокумент;
    |Функция СуммаПриход = Приход(Сумма);
    |Функция СуммаРасход = Расход(Сумма);
    |Функция СальдоСумма = НачОст(Сумма);
    // |Условие(Сотрудник=СотрудникРег);
    |Группировка ВидНУ;
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;

    ТЗ.НоваяКолонка("Сотрудник");
    ТЗ.НоваяКолонка("Нач_НАРАБОТАНО");
    ТЗ.НоваяКолонка("Нач_ОКЛАД");



    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    ТекстЗапроса =
    "//{{ЗАПРОС(Авто)
    |Период с Дата1 по Дата2;
    |СотрудникРег = Регистр.Зарплата.Сотрудник;
    |Сумма = Регистр.Зарплата.Сумма;
    |ВидНУ = Регистр.Зарплата.ВидНУ;
    |ТекущийДокумент = Регистр.Зарплата.ТекущийДокумент;
    |Функция СуммаПриход = Приход(Сумма);
    |Функция СуммаРасход = Расход(Сумма);
    |Функция СальдоСумма = НачОст(Сумма);
    |Условие(Сотрудник=СотрудникРег);
    |Группировка СотрудникРег без групп;
    |Группировка ВидНУ;
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;

    Пока Запрос.Группировка(1) = 1 Цикл
    НачСальдо=Запрос.СальдоСумма;
    Начислено=Запрос.СуммаПриход;
    Удержано=Запрос.СуммаРасход;
    Сумма=НачСальдо+Сумма+Начислено-Удержано;
    ТЗ.НоваяСтрока();
    ТЗ.Сотрудник=Сотрудник;
    ТЗ.Нач_НАРАБОТАНО=Наработано;
    ТЗ.Нач_Оклад=Оклад;

    Пока Запрос.Группировка(2) = 1 Цикл
    // Сообщить(""+Сотрудник+" "+Запрос.СуммаРасход);
    Если (Запрос.СуммаРасход<>0) или (Запрос.СуммаПриход<>0) Тогда
    Если Запрос.СуммаРасход<>0 Тогда
    ТЗ.УстановитьЗначение(ТЗ.НомерСтроки,("Уде_"+СловоНУ(СокрЛП(Строка(Запрос.ВидНУ)))),Запрос.СуммаРасход);
    КонецЕсли;

    Если Запрос.СуммаПриход<>0 Тогда
    ТЗ.УстановитьЗначение(ТЗ.НомерСтроки,("Нач_"+СловоНУ(СокрЛП(Строка(Запрос.ВидНУ)))),Запрос.СуммаПриход);
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;
    КонецЦикла;
    КонецЦикла;


    //Таб.ВывестиСекцию("Итого");
    //Таб.ТолькоПросмотр(1);
    //Таб.Показать("Заполнить", "");
    КонецПроцедуры
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    В последних строках знак "//" означает коментарий.
    Убери его и будет выводится сформированная таблица.

Поделиться этой страницей