7.7 Помогите присвоить значение субконто

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем X-Man, 13 июл 2007.

  1. TopicStarter Overlay
    X-Man
    Offline

    X-Man Опытный в 1С

    Регистрация:
    18 май 2007
    Сообщения:
    439
    Симпатии:
    3
    Баллы:
    29
    Народ, помогите кто чем может, сроки горят, а у меня ничего не выходит
    Проблема такая: не присваивается значение первому субконто кредита. В отладчике проверял, присваиваемое значение не пустое, но после прохождения метода присваивания значение субконто все равно остается пустаым. Вот фрагмент кода:

    Для Сч = 1 По Таблица43_1.КоличествоСтрок() Цикл
    Таблица43_1.ПолучитьСтрокуПоНомеру(Сч);
    Операция.НоваяПроводка();
    Операция.СодержаниеПроводки = "Реализованы ТМЦ";
    Операция.Дебет.Счет = СчетПоКоду("62.1");
    Операция.Дебет.Субконто(1,Контрагент);
    Операция.Дебет.Субконто(2,Договор);
    Операция.Кредит.Счет = СчетПоКоду("90.1.1");
    //В следующем операторе не присваивается значение
    Операция.Кредит.Субконто(1,Таблица43_1.СубконтоДебета1);
    //
    Операция.Кредит.Субконто(2,Таблица43_1.СубконтоКредита2);

    Операция.Сумма = Окр(Таблица43_1.Сумма * Коэффициент62,2,1);
    СуммаПроводок62 = СуммаПроводок62 + Окр(Таблица43_1.Сумма * Коэффициент62,2,1);


    Если Сч = 1 Тогда
    НачалоПроводок62 = Операция.КоличествоПроводок();
    КонецЕсли;
    КонецЦикла;


    Тип вида субконто и тип значения идентичны, никакой ошибки не выдается, просто субконто остается пустым.
  2. TopicStarter Overlay
    X-Man
    Offline

    X-Man Опытный в 1С

    Регистрация:
    18 май 2007
    Сообщения:
    439
    Симпатии:
    3
    Баллы:
    29
    Я уже переписал явным образом, все равно ни фига не получается
    Для Сч = 1 По Таблица43_1.КоличествоСтрок() Цикл
    Таблица43_1.ПолучитьСтрокуПоНомеру(Сч);
    Операция.НоваяПроводка();
    Операция.СодержаниеПроводки = Таблица43_1.СодержаниеПроводки;

    Операция.Дебет.Счет = Таблица43_1.СчетДебета;
    Операция.Дебет.ВидыНоменклатуры = Таблица43_1.ВидНоменклатуры;
    Операция.Дебет.ВидыПродукции = Таблица43_1.ВидПродукции;

    Операция.Кредит.Счет = Таблица43_1.СчетКредита;
    Операция.Кредит.Номенклатура = Таблица43_1.Номенклатура;
    Операция.Кредит.ВидыПродукции = Таблица43_1.ВидПродукции;
    Операция.Кредит.МестаХранения = Таблица43_1.МестаХранения;

    Операция.Количество = Таблица43_1.Количество;
    Операция.Сумма = Таблица43_1.Сумма;
    КонецЦикла;



    После выполнения оператора
    Операция.Дебет.ВидыНоменклатуры = Таблица43_1.ВидНоменклатуры;

    значение Операция.Дебет.ВидНоменклатуры пустое, хотя значение
    Таблица43_1.ВидНоменклатуры
    не пустое

    Ребята, помогите,а ! Очень надо.
  3. landay
    Offline

    landay Опытный в 1С

    Регистрация:
    23 янв 2007
    Сообщения:
    103
    Симпатии:
    0
    Баллы:
    26
    Может быть тип субконто имеет неопределенный. Как, например, тип "ДОкумет", вроде все понятно, что документ, а вот какой из множества уже не понятно, поэтому желательно сначала явно указать тип а потом присвоить значение. Только это пока могу предположить.
  4. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Такая проблема бывает из-зи несоответствия типов.
    В отладчике проверь тип присваемого значения с типом ВидаСубконто.
    Если присваемое значение было получено с использованием функции СоздатьОбъект... то необфодимо использовать методы ТекущийЭлемент(), -Документ(), -Счет()...

Поделиться этой страницей